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Introduction
Welcome to CounterPoint, the dynamic solution to PowerPoint presentations. CounterPoint gives the user instant access to all parts of a presentation. This robust program also allows the user to display the entire presentation on an interactive plain with a variety of hierarchical patterns. Designed for presentation expansion, CounterPoint supports multiple slideshow traversals for the same presentation.

About this user manual
The CounterPoint user manual provides step-by-step information for using this product. It allows you to familiarize yourself with CounterPoint and is also a valuable reference tool. 

This guide assumes you have a working knowledge of presentation design in PowerPoint. For help with PowerPoint operations, refer to documentation provided by the Microsoft Corporation. 
Installing CounterPoint

System Requirements

CounterPoint is designed for Windows versions 98/NT/2000/XP running Microsoft Office 2000 or later (including PowerPoint 2000). The minimal system requirements are

· 266 MHz Pentium Processor or equivalent

· 96 MB RAM

Note: Additional RAM beyond 96 MB will increase CounterPoint performance.

There are two additional methods to improve CounterPoint performance. 

- Reduce the color quality on the screen 

· Right click on the Windows Desktop.

· Within the popup menu, choose Properties.

· Click the Settings tab at the far-right top of the window.

· In the dialog box, click the Color Quality drop-down box.

· Choose Medium (16 bit) provided in the list.

- Reduce the screen resolution

· Right click on the Windows Desktop.

· Within the popup menu, choose Properties.

· Click the Settings tab at the far-right top of the window.

· Slide the Screen Resolution slider to a lower resolution.
Downloading CounterPoint
Make sure you are installing as a Computer Administrator.

Before downloading, you will need a program for unzipping files, such as WinZip. You can download WinZip from http://www.winzip.com/.  

Download the Java Runtime Environment. 
Note: You must install the Java platform before downloading CounterPoint. 
You can obtain the Java 2 Platform from http://java.sun.com/j2se/1.4.2/download.html. Follow the instructions provided in the setup to install Java and reboot the machine.

Download the CounterPoint setup from http://www.cs.umd.edu/hcil/counterpoint/download/counterpoint-1.3.003-setup.zip.

Once you have downloaded the CounterPoint setup, follow these steps

· Double click on the file named counterpoint-1.3.003-setup.zip to open the file with the unzipping program on your machine such as WinZip

· In the CounterPoint folder double click on the unzipped file named setup.exe.

· Follow the directions provided by the installation Wizard.

Running CounterPoint

When you have installed CounterPoint, open PowerPoint. Make sure the Standard toolbar is visible. To make the toolbar visible

· Right click on the PowerPoint menubar or any toolbar. 

· In the popup menu, click the Standard option to check the item and make it visible.

Click on the CounterPoint toolbar button to run the CounterPoint program. 
Additional Information

If you experience any problems installing or running CounterPoint after referring to this user manual, please report to counterpoint-info@cs.umd.edu.
For a complete listing of bug fixes, refer to http://www.cs.umd.edu/hcil/counterpoint/download/.
Look for new versions of CounterPoint at http://www.cs.umd.edu/hcil/counterpoint/.

Utilizing the View Control

Click on the View control at the top of the screen. Use this control to select the running mode you will work in. To run the program in the desired mode, either click on the mode itself or enter the command for the appropriate mode.
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Figure 1: Mode selection provided in the dropdown box 

               for View.
Working in Layout Organizer Mode

The Layout Organizer Mode allows you to view the presentation in a few common profiles. Layout Organizer mode contains two main panels on the screen. The narrower, left panel contains the hierarchical design of the slides. The right panel contains the actual slides in a grid arrangement. Simply select the Layout Organizer option in the View menu, to access this mode. 
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Figure 2: Left and right panels as they appear in Layout Organizer Mode.

Using the Right Panel

You will use the right panel to spatially arrange how you want the slides to appear in the presentation. This is a Zoomable User Interface used by many of the Jazz or Pad++ programs. It is a semi-infinite surface where you can pan and zoom through objects on the surface. Additional products with this interface are available at http://www.cs.umd.edu/hcil/jazz/.  
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Figure 3: Default grid structure in the right panel. 
You can interact with the right panel by using the

· Hand tool [image: image4.png]



· Arrow tool [image: image5.png]



· Text tool [image: image6.png]



You will see the hand tool icon as the mouse cursor when it is active.

To pan on the panel, click with the left mouse button at any location within the panel and drag the mouse to the desired location while the left button is still depressed.
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Figure 4: Panning right with the hand tool.
To zoom in, move the mouse over a slide and click with the left mouse button. 

To zoom back out, right click on the zoomed panel.
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Figure 5: Clicking on slide to zoom.
You can also zoom in by positioning the mouse at any point on the panel and scrolling upward with the mouse wheel. Likewise, you can zoom out by scrolling downward with the mouse wheel.

To activate the arrow tool, click on the arrow icon in the tool bar.

To move an object, click on it and drag it with the mouse to the desired location while the mouse button is still depressed.
To change the size of an object

· Highlight the desired object.

· Press the Page-Up key on the keyboard to make it larger or Page-Down key to make it smaller.

To activate the text tool, click on the text tool icon in the tool bar.

To create a text label, click with the left mouse button at any location on the surface of the panel.
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Figure 6: Placing text in the panel.
Using the Upper-Left Panels

The controls of the upper-left panel allow you to create the hierarchy of your presentation. For example, if you had a slide titled Windows XP, you might have sub-slides (child slides) titled Windows Media Player, Microsoft Works, and Microsoft Office. Then you might have sub-slides for the Microsoft Office slide titled Microsoft Word and Microsoft Excel.
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Figure 7: Presentation hierarchy in the left panel.
To make a slide a child of another slide in the upper-left panel box

· Activate the arrow tool.

· Highlight the slide, which will be the child slide.

· Drag the child slide onto the parent slide.

To make a slide a child of another child slide in the right panel

· Activate the arrow tool.

· Highlight the slide you will make a child slide in the right panel box.

· Click the [image: image12.png]


or [image: image13.png]


 key in the left panel box to increase or decrease the slide’s level.

To expand or collapse all the slides, click on the [image: image14.png]


 or [image: image15.png]


button.

Using the Lower-Left Panel

You will receive a set of layout options when one of the parent slides is selected.
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Figure 8: Auto layout with design and parameters.
Select whether or not you want to apply the automated layout. 

When you select the auto layout, you can then choose

· Layout shape

· Parameters of the layout

Working in Path Editor Mode 

When you have created the layout for your presentation, the Path Editor mode allows you to create a path through the slides. To access this mode, select the Path Editor option in the View menu. This mode will display two panels

· The Left Panel will display the slides for your presentation and views on the path.

· The Right Panel will display the layout of your slides.
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Figure 9: Path Editor Mode – The Left Panel contains slides and views of the

 
     presentation and the Right Panel contains the slide layout
CounterPoint creates an intelligent default path for the presentation. However, the path might become out of sync with the layout of your presentation due to modification. To update the path to your current layout

· Select the Path control at the top of the screen.

· Click on Synchronize Path With Layout.
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Figure 10: Updating the path with the current layout
Using the Left Panel (modifying the path)
The Left Panel will direct the animation of slides through the arrangement you create in the Right Panel. CounterPoint adds each PowerPoint slide as a stop along the default path. You can modify the path by rearranging, removing, or repeating slides.

To rearrange

· Click on the desired slide in the Left Panel.

· Drag the slide using the [image: image19.png]


and [image: image20.png]


 buttons.

To delete

· Click on the desired slide.

· Press the Delete key.

To repeat a slide or reinsert a deleted slide

· Select the Path control.

· Click on Insert Slide on Path.
· Select the desired slide from the dialog box.
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Figure 11: Dialog box for inserting a slide.

Adding a viewpoint

The camera button [image: image22.png]


 allows you to add different viewpoints of your right panel as marker slides in the path of your Left Panel. 

To add a viewpoint slide to the path, press the camera button when you are at a viewpoint of interest in the Right Panel. 

Note: When you add a viewpoint slide after inserting or reinserting a slide, the new viewpoint slide is added to the end of the path by default.
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Figure 12: Adding a layout from the Right Panel as a view to the Left Panel. 

To place the viewpoint slide at a different location

· Drag the slide using the [image: image24.png]


or [image: image25.png]


 buttons.
· Select a slide you wish the viewpoint slide to be placed immediately after, then press the camera button.

Using the Right Panel
The Right Panel in Path Editor mode functions in the same fashion as Layout Organizer mode. Refer to the section on Using the Right Panel in Working in Layout Organizer Mode for further instruction.

Using the Path Selector

CounterPoint allows you to have multiple paths for the same presentation in the Left Panel. You can produce different slideshows of the same presentation by creating different paths.
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Figure 13: Different slide paths for the same presentation.

To add a new path

· Select the Path control.

· Click on New Path in the menu.

· Name the Path when prompted with the dialog box.

· Click OK to proceed.

To rename an existing path

· Open the path you wish to rename.

· Select the Path control.

· Click on Rename Path.

· Enter the new name when prompted by the dialog box.

· Click OK to proceed.
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Figure 14: Dialog box for creating or renaming a path. 

To delete an existing path

· Open the path you wish to delete.

· Select the Path control.

· Click on Delete Path.

· Click Yes to proceed.

Inserting Images

You can insert images into your presentation in the Path Editor mode. CounterPoint accepts images in the following formats

· JPEG

· GIF

· some SVG files   

To insert images in Path Editor mode:

· Go to the Insert menu.

· Click on Picture.

· Specify file name and type.

· Highlight the desired image.
· Click on Open.
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Figure 15: Dialog box for inserting an image.
Working in Slide Sorter Mode


The Slide Sorter mode works similar to the Slide Sorter mode in PowerPoint. Simply select the Slide Sorter option in the View menu to access this mode. 
Arrange the slides in your presentation by clicking and dragging each slide to the desired location on the Right Panel.
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Figure 16: Arranging slides in Slide Sorter mode.

To add a new path in Slide Sorter mode

· Select the Path control.

· Click on New Path in the menu.

· Name the Path when prompted with the dialog box.

· Click OK to proceed.

To rename an existing path in Slide Sorter mode

· Open the path you wish to rename.

· Select the Path control.

· Click on Rename Path.

· Enter the new name when prompted by the dialog box.

· Click OK to proceed.

To delete an existing path in Slide Sorter mode:

· Open the path you wish to delete.

· Select the Path control.

· Click on Delete Path.

· Click Yes to proceed.

Using the Slide Show
Select the path you wish to use for your presentation.

To begin the slide show, select the Slide Show option in the View menu or click on the Slide Show icon toward the top of the screen.
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Figure 17: Button to begin the slide show.
Press the Escape key to exit the presentation at any time.
Navigating through the Presentation
Navigating through the presentation is similar to navigating through a PowerPoint presentation.

To advance to the next slide or view in the path press the

· Right Arrow key 

· Down Arrow key

· Space Bar

· Left mouse button

To return to the previous slide, press the Left Arrow key.

To zoom out one level in the hierarchy you designed in your layout, press the Up Arrow key. 

Note: CounterPoint zooms out to make all slides visible if there is no hierarchy. 

To go directly to any slide in the presentation, left click with the mouse button over the desired slide at any time.

To zoom a specific level in your hierarchy:

· Move the mouse cursor over the level you wish to view.

· Click the left mouse button when the desired level is automatically highlighted by a navigation rectangle.
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Figure 18: Zooming in to the highlighted area in the presentation.

Modifying the Presentation Appearance
To change the appearance of your slide borders, select Slide Borders in the Format menu. In the dialog box

· Select the border shape.

· Specify the border color using the Color Editor.

· Select the border shape of the visited slide.

· Specify the border color of the visited slide.

· Click Apply and/or OK.
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Figure 19: Dialog box for modifying the slide borders.

To change the appearance of navigation rectangle, select Navigation Color in the Format menu. In the dialog box, select the navigation color using the color editor.
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Figure 20: Dialog box for modifying the navigation rectangles.

To change the background color, select Canvas Background Color from the Format menu. In the dialog box, select the background color using the color editor.
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Figure 21: Dialog box for modifying the background color.

Saving the CounterPoint File

Before exiting remember to save any desired changes to your CounterPoint presentation with the Save control in the File menu. All data and modifications from your presentation are stored in a file that is placed in the same directory as your PowerPoint file as a “.cpt” file.
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Figure 22: “.cpt” files are placed with your “.ppt” files.
In rare instances, the CounterPoint file becomes corrupted and does not function properly with the PowerPoint presentation. 

To fix this problem, select from the following options

· Delete the “.cpt” file and recreate the CounterPoint portion of your presentation.

· Edit the “.cpt” file. 


Note: This file uses an XML format. You can potentially fix these problems with a text editor. 

Frequently Asked Questions
Why didn’t CounterPoint install correctly?
Installation problems may occur if

· Java was not installed before CounterPoint.

· CounterPoint was not installed by a Computer Administrator.

· PowerPoint 2000 or later was not installed on the machine.
For further instruction, refer to the installation procedures in this manual.

How do I make slides children of other slides?
This can be done in either the left or right panels of Layout Organizer Mode.
To make a slide a child of another slide in the upper-left panel box

· Activate the arrow tool.

· Highlight the slide, which will be the child slide.

· Drag the child slide onto the parent slide.

To make a slide a child of another child slide in the right panel

· Activate the arrow tool.

· Highlight the slide you will make a child slide in the right panel box.

· Click the [image: image40.png]


or [image: image41.png]


 key in the left panel box to increase or decrease the slide’s level.

For further instruction, refer to the procedures for Upper-Left Panels in Layout Organizer Mode.

How do I change the size of child slides?

To change the size of children slides at any level 
· Go to Layout Organizer Mode.

· Highlight the parent of these slides in the Upper-Left Panel. 
· Select auto layout in the Lower-Left Panel, 

· Adjust the size of these children slides with the Mag. of Children tool.

