GSAK 101!

[image: image5.wmf]This is a step-by-step guide to get you started using GSAK.  All underlined text in this guide is a link to a web site – click on the underlined text to go directly to that website.   This guide is very detailed (step-by-step) and therefore rather long.  Don’t Panic!  Once you’ve been through this guide, you’ll be using GSAK on your own in no time.   

Please note:  this guide covers getting started with GSAK.  It’s designed to be read from start to finish (although not necessarily in one sitting!), and each section builds on the last   If you skip to topic headings without reading through the earlier material, you’ll miss key points and end up hopelessly confused.  

Many GSAK features are not addressed here – for information on those features, see the GSAK help file (in GSAK, go to the “Help” menu, then click on “Contents”, or press the F1 key on your computer).

Geocaching.com Premium Membership

To take maximum advantage of GSAK, you’ll want to download GPX (not LOC) files from Geocaching.com.  GPX files include almost all of the information from the online cache page, and allow you to import all of this information into GSAK.  LOC files only include the cache name and the coordinates (latitude and longitude).  Although GSAK will work with LOC files, you will not have the detailed cache information that allows you to take advantage of many of GSAK’s features.
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Geocaching.com requires you to become a “Premium Member” to download GPX files.  Premium membership costs $3 per month or $30 per year.   To become a Premium Member of Geocaching.com, go to http://www.geocaching.com/subscribe/ and scroll down to “How Much is Membership”.  Choose your payment method (credit card or PayPal) and the term of your membership.  Complete the payment process to become a Premium Member of geocaching.com so that you can download GPX files and Pocket Queries.

Download the GSAK Program

Go to http://gsak.net/ and download the latest version of GSAK.  When prompted, save the file to your computer (remember where you saved it!).

GSAK is free to try and $30 US to buy.  The free download includes all GSAK features and is fully functional.  After 21 days of using GSAK without registering, you will receive a “nag” when the program starts, and the delay for this screen will get longer with each subsequent use.  If you like the program, please register at http://gsak.net/Register.php.  When you enter your registration key (serial number), the nag screens will go away permanently

Install GSAK

In Windows, go to Start>Run and browse to where you saved the file (GSAKxxxx.exe, where xxxx is the version number).  Click on the file, click “Open”, and then click “OK”.

The GSAK installation will begin.  If the Windows “Open File Security Warning Appears”, click “Run”.

We recommend that you allow GSAK to install in the default location.  Just click on “Next”, “Accept”,  “Next” and “Install”.   GSAK will be installed on your computer.  

Starting GSAK for the First Time
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Double click the GSAK icon (a stylized “GK” within a red button) on your Windows desktop.  The GSAK program will start.  

You’ll be asked if you want to “Associate” GPX and LOC files with GSAK, which means that whenever you double click one of these files, they will open in GSAK.  If you have other geocaching software on your computer and you always want GSAK to open a double clicked GPX or LOC file, check the “Force Association Each Time GSAK starts” box.  This prevents other software from “stealing” this file association when it runs.

If you want GSAK to open GPX and LOC files when you double click them, click “Associate”.  If you want some other program to open these files when double clicked, click “Cancel”.  Note:  You can change this setting at any time in GSAK by going to the “Tools” menu, then choosing “GPX File Association…”.

Next GSAK will ask if you want to populate your database with the sample database.  If you’ve ready to put real data into GSAK, click “no”.   If you want to play with the sample database before loading real data, click “yes”.  

The GSAK “Getting Started” help file will open. Read through this help topic and click on the links to get some basic familiarity with the program and its help files.  Don’t worry about memorizing everything at this point – this guide will take you through the basics step-by-step.

[image: image1.wmf]
Using GSAK
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Load cache data: The first thing to do is to load some cache data into GSAK.  You can load individual cache files, or, if you’re a Premium Member, you can create Pocket Queries at geocaching.com so that information on up to 500 caches will be emailed to you (we’ll get into this below).  

From here on, we’re going to assume that you’re a Premium Member of geocaching.com, since, as we said above, this is the best way to get cache information for use in GSAK.

In Windows, create a folder in “My Documents” to hold your cache downloads.  Call this folder “Geocaches”. 

Download Individual Cache Data:  To download the information on an individual cache, log into geocaching.com and go to that cache’s page at geocaching.com and, under “Click Icon to Download” near the top of the cache page, click on “GPS eXchange File (*.gpx)”.  A “File Download” window will open.  Click on “Save” and save this file to the “Geocaches” folder you just created (above) on your computer.  
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Load Cache Data into GSAK:  In GSAK, click on the “File” menu and click on “Load GPX/LOC” (from here on, we’ll refer to menu commands like this as “File>Load GPX/LOC”).  A window will pop up reminding you to set your method for matching placed and hidden caches.  This is an important step so that GSAK knows who you are and can recognize caches you own and the ones you find.  Type your geocaching name into the space provided (double check to make sure it’s spelled correctly) and click “OK”.  You only have to do this once – this reminder will not pop up again.

The “Load…” dialog will now appear.  Click on the little folder icon to the right of the first blank entry box and browse to your “Geocaches” folder.  Click on the file you just downloaded, click “Open”, then click “OK”.  GSAK will load the cache information into its database and a “Load Summary” will pop up providing information about the file that was just loaded.  Click “OK”.

You’ll notice that the cache now appears as a row in the top half of the GSAK window.  This is called the “Grid View” and each row in this view contains information about one cache.

At the bottom of the Grid View there is a status bar that will say:  Subset: None; 1 Shown (all waypoints); Centre Point: Greenwich Meridian; Counts (followed by four different colored boxes).   Click on the bottom edge of this status bar and hold down the mouse button to drag the status bar upward.  If you can’t drag the status bar upward, press the “F2” key on your keyboard (this opens the Split Screen View), then drag the status bar upward so that it’s in the middle of the screen.

You’ll now see the cache information in the lower have of the GSAK window.  This is called the “Split Screen View”.   

The default format is “Full Display”.  This shows you all of the cache information included in the GPX file without the need to go to geocaching.com.   In the middle of the tool bar near the top of the GSAK window, you’ll see a drop down labeled “Split Screen Format”.   Try choosing different options in this drop down to see what they do (note: you have to be connected to the Internet for “Online” view to work!).   Set the Split Screen Format back to “Full Display” for now.
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Creating your Home Location:  One of the powerful features of GSAK is the ability to sort or view caches by their distance from a given location.  Unless you live on the Greenwich meridian in England (very few of us do!), you’ll need to set up a “home location” that reflects where you live.  

First, you need to know the coordinates (latitude and longitude) for your home.  If you don’t know your home coordinates, go outside your home with your GPSr and mark a waypoint.   View that marked waypoint on your GPSr and copy the coordinates into GSAK as follows:

Go to Tools>Options and click on the “Locations” tab.   Click below “#Somewhere else….” in the text box on that dialog and type Home, a comma, and then the coordinates for your home location taken from the waypoint you marked on your GPSr, separated by a comma.  Note that the coordinates must be in one of the formats shown in the examples in the text box.  Be sure to put a comma between the word Home, the latitude and the longitude.  Be sure to put the latitude before the longitude!   Be sure to type the coordinates exactly as they appear on your GPSr, including N or S latitude (north or south of the equator) and E or W longitude (east or west of the Greenwich meridian).   

Click “OK” to return to the GSAK grid view.  In the “Locations” drop down on the GSAK toolbar, select “Home”.    The cache in your grid view will now reflect the distance from your home in kilometers, in the column titled “Kms”.  “But I don’t use kilometers”, I hear you say?    Go to the Tools>Options and on the “General” tab and, in the upper right hand corner, click on “Miles” under “Distance Calculation”.   Click OK.  The heading of the distance column in the grid view is now “Miles” and the distance from your home location is now shown in miles.
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Getting Pocket Queries: To take full advantage of GSAK, you’ll want to load many caches into the database (e.g. all of the caches in your area).   The best way to do this is to generate “Pocket Queries” at geocaching.com.     For detailed information on Pocket Queries, and a step-by-step guide to setting them up, go to: 

http://www.markwell.us/pq.htm
Or, if you just want to wing it, go to: http://www.geocaching.com/pocket/ and click on “Create a New Query” (you must be logged into geocaching.com as a Premium Member for this to work). 
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Either way, once you submit your Pocket Query at geocaching.com, a file will be emailed to you, usually within a few minutes.  So check your email!! 

Loading a Pocket Query into GSAK:  The process for loading a Pocket Query into GSAK is quite similar to loading a single GPX file.

First, save the Pocket Query file attached to your email into your “Geocaches” folder (created above) on your computer.

Next, go to File>Load in GSAK and browse to the Geocache folder.

Click on the saved Pocket Query file (note: GSAK is smart enough to loaded zipped files – no need to unzip the file first).  Click “Open”.  Click “OK”.   The caches in the Pocket Query (up to 500) will now be loaded into GSAK, and a summary of the load will pop up.   Click OK to dismiss the load summary.

Viewing cache information: Each of the rows in the GSAK now shows one cache.   If you click on a row, the details of that cache will appear in the Split Screen view.

If you want to view a cache on an online map, make sure you’re connected to the Internet, then RIGHT click on that cache’s row in the grid view, move your cursor down to “Custom URL” and select the map you want to view (try “Google Satellite View”, at the bottom of the Custom URL list).  

Sorting:   Click on any column heading to sort the caches by the information in that column.  For example, clicking on the “Code” column will sort the caches by the GC code.   Clicking that column a second time will reverse the order of the sort.  Clicking on the Kms (or Miles) column heading will sort the caches by distance from your home location.   Clicking on that column again will reverse the sort.

Selecting Caches:  To select a cache in GSAK, click in the column under the [image: image3.png]


 icon in the row for that cache and a checkmark will appear in that column. This is the “User Flag” column.   User flags can be used to select individual caches or multiple caches.  To select multiple caches, just click in the User Flag column for each cache that you want to select.   You can also select multiple caches from the User Flag menu or using keyboard shortcuts (click on the User Flags menu to see the choices).   

One useful way to select a large number of caches is User Flags>Select for next nn records.  What’s “nn records”?  This just means the next number (nn) records in the GSAK grid.  To use this feature, click on any cache in your grid, and then go to User Flags>Select for next nn records.   Type 10 into the box that pops up and click on “OK”.  You’ll notice that the 10 caches below the one you clicked on now have the user flag set (a checkmark appears in the user flag column).

To clear a user flag (unselect a cache), just click in the User Flags column for the cache a second time, and the checkmark will disappear.  To unselect multiple caches, go to User Flags>Clear all user flags.  Everything that was selected is now unselected!

Filtering:  One of the most powerful features of GSAK is filtering.   Filtering allows you to select a subset of caches and then to act on those caches as a set.   You can delete, move, copy, export or send a group of caches to your GPSr all at once.

To see how filtering works, click in the User Flag column to select a few caches.  Now press the F8 key on your keyboard.  Notice that the only caches now displayed in the grid are the ones you selected with the user flag.   You’ve just filtered your caches for those where the user flag is set, and you can now act on those caches as a group.   Go to User Flags>Clear all user flags, or press F7 on your keyboard to clear the user flags and again view all of your caches.

GSAK filtering is much more powerful than just using user flags.  To filter your caches in other ways, go to Search>Filter.    Or you can click on the Filter button on the GSAK toolbar, which looks like this: 
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A “Set Filter” dialog pops up that shows you all of the criteria you can filter on.  There are multiple tabs in the dialog – each tab gives you additional criteria to include in your filter for selecting certain caches.

Let’s create a simple filter to show you how it works.  Let’s say you want to see all of the Traditional caches that are located within 20 miles (or Kms) of your home.    Click on Search>Filter.  On the General tab, the fourth item down is “Distance”.   In the “Any Distance” drop down, select “Less than or Equal To”.   Type 20 into the box to the right of the drop down.

Now click on the “Other” tab in the Set Filter dialog window, and click on “Clear All” below the list of cache types.   Now click on the box to the left of  “Traditional”.   Click on “Go” at the bottom left corner of the Set Filter dialog window.  GSAK returns to the grid view, and the only caches displayed are now Traditional caches within 20 miles (or Kms) of your home location!
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To cancel the filter (view all of your caches again), go to Search>Cancel Filter or click on the big red X button on the toolbar.

Sending Waypoints to Your GPSr: GSAK can export a set of waypoints directly to Garmin and Magellan GPSr units.   A “set” is whatever appears in your grid view at the moment.  So, if you’ve filtered your caches on some criteria, those are the caches that will be sent to your GPSr.

First, go to GPS>Setup.    Select the brand of your GPSr (Garmin or Magellan).  If your GPSr connects to your computer using USB (not a USB-to-Serial converter), check the “GPSr is USB” box.    If your GPSr connects to your computer using a serial cable or a USB-to-Serial converter, leave this box unchecked and select the COM port (computer port) that your GPSr is connected to and, for Magellans, the Port Speed set in your GPSr (all Garmins use the same speed, so that item is grayed out for Garmins).  Finally, set the maximum number of waypoints your GPSr can handle (see the owner’s manual to determine this number) and click “OK”. 

Now, set a filter to select the caches you want to send to your GPSr (or you can skip the filter and export all the waypoints in your database if you like).  Make sure that the total number of caches selected (shown in the status bar below the Grid View) is no greater than the number your GPSr can handle.  

Connect your GPSr to your computer and turn the GPSr on.  Now go to GPS>Send Waypoints and click on “Send”.  The selected waypoints will be transferred to your GPSr.  

Don’t have a Garmin or Magellan GPSr?   Or want to send waypoints to some other software (e.g. mapping software on your computer)?  See Exporting, below.

Exporting:   Set a filter to select the waypoints you want to export (or you can skip the filter and export all the waypoints in your database if you like).

Go to File>Export and select the type of export (to match either your GPSr or the software you want to export to).    A dialog will appear that is specific to that type of export.   There are too many exports to cover here.  Please see the GSAK help file for more information (Help>Contents or F1 on your computer).  

For tips on using the GSAK help file, please see this post in the GSAK forums:  http://www.gsak.net/board/index.php?showtopic=955&st=0& - entry5743
Enjoy using GSAK!

For the next in the series please see GSAK 201 – Customizing GSAK which you can download here http://gsak.net/board/index.php?showtopic=2335
