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Class Info

Spring Term 2019, 1/30-5/15
Wednesdays 7PM-10PM 

(Includes 1 hour lab 7-8)
On Campus and Online: 

53 Church Street 202
CRN 25486
4 Credits
Instructor Info

Jason Wiser, MFA
JasonWiserArt@gmail.com
Available daily by email.

Estimated Homework: 

6+ Hours/week to pass
	DGMD E-48 Advanced 3D Art & Animation 

"I made tons of films. I did animation for my friends’ films. I animated scenes just for the fun of it. Most of my stuff was bad, but I had fun, and I tried everything I knew to get better." -- Pete Docter
Description: The second course in the two-course 3D animation sequence, introducing students to advanced modeling and animation techniques and preparing them for independent computer animation production work. Continues to develop skills acquired in Introduction to 3D Art and Animation, including modeling, texturing, and lighting scenes for film and VR, animation, dynamics, rendering, and post-production compositing with live action.
Learning Objective: Upon successful completion of this course students will gain an understanding of how to design, model, texture, rig, and animate 3D characters for animation and games. Students will develop tools for solving visual story and production pipeline problems, and create an original 3D film.
These learning objectives will be accomplished by: Weekly pre-production and production on studio projects. In-class and at-home design, planning, production, reading, research, and writing. Lecture, discussions, laboratory, and workshops. Teacher and peer critique.


RECOMMENDED TEXTS:  Hand-outs supplied by teacher. Recommended books:
Timing for Animation by Harold Whitaker and John Halas
Maya Visual Effects The Innovator's Guide by Eric Keller (expected for graduate students, who will present a visual effects tutorial to the class after midterms)
To supplement your studies in Maya, watch Lynda.com tutorials (free for Harvard students)

REQUIRED MATERIALS: Notes/ Drawing (pencils/sketchpad). Data Drive (at least 10 gigs).  
REQUIRED TECHNOLOGY: Students will use in class every week: computer with Autodesk Maya (free with .EDU email: students.autodesk.com) and a 3-button mouse. Also needed: Adobe Photoshop or alternate, and a Digital Drawing Tablet (small Wacom Intuos recommended), all of which will be taught in this course.
GRADING POLICY
30%
Class Participation (attendance, in-class work, and professional manner).

30%
Weekly Homeworks (including full character development, due every class on Piazza).
10%
Film Pre-production: Storyboard, Shot List, and Color Scipt.

30%
Full 3D Film Production: Character, Object, Camera Animation and Post Production.

ADVANCED 3D ART AND ANIMATION 
WORK EXPECTATIONS:
1. Homework: Assignments are due every class. They are needed for the next lesson or homework, so finish early! Late work gets less credit: -20%/week. TIME MANAGEMENT: Work 1-3 hours EVERY DAY instead of 10 hours the day before due for better results. Minimum homework hours per week: 6-10
2. Attendance: Every class contains critical information. In case of emergency, email teacher, and make up material. As class participation counts for 30% of the grade, significant absences, tardiness, or leaving early will result in significant grade reduction, and in combination with poor/incomplete work can result in failing the course.

3. SAVE FREQUENTLY! Do NOT open files directly from or save files directly to a portable drive. Copy (move Project Folder) to/from computer hard drive and open there, or risk corruption and slowdown. Save a copy of all work in an online repository (dropbox.com, cubby, etc).

4. Note Taking: Bring a pad to class! Write down all concepts, tools, and procedures, and review Powerpoints. Please ask teacher to further explain or repeat concepts during or after the class.

5. Academic Integrity:  You are responsible for understanding Harvard Extension School policies on academic integrity (www.extension.harvard.edu/resources-policies/student-conduct/academic-integrity) and using sources responsibly. There are no excuses for failure to uphold academic integrity. For academic citation rules, please visit the Harvard Extension School Tips to Avoid Plagiarism (www.extension.harvard.edu/resources-policies/resources/tips-avoid-plagiarism). See links to Harvard Guide to Using Sources and free, anonymous, online 15-minute tutorials to test your knowledge of academic citation policy. 

LAB/CLASS:

1. Students must treat one another with respect in their behavior and project content.

2. Avoid Distractions: Please turn off all websites, device sounds, and put phones away.

3. Help Each Other: You are encouraged to help each other both during and after class. Be careful to not talk when teacher is speaking. Credit on Piazza those who give you support!

COMMUNICATION:

1. Communication: Talk with the teacher! Going to be late or absent? Having trouble with a concept, or anything else interfering with your success? Ask for help! Teacher can be reached by email every day: JasonWiserArt@gmail.com or in person after class. Teacher typically responds to emails within 24 hours. No attachments, please: Link to Piazza Screenshots!
2. Accommodations: The Harvard Extension School is committed to providing an accessible academic community. The Disability Services Office offers a variety of accommodations and services to students with documented disabilities. For more information please visit: www.extension.harvard.edu/resources-policies/resources/disability-services-accessibility
PLEASE NOTE:

· Advancing your 3D Art skills will continue to be time-consuming. As you saw in the intro class, be patient with yourself and the software and you will get it!

· Email the teacher as soon as you hit a problem, so I can help! Include Piazza links with screenshots and your course/school name. I should respond within 24 Hours.
· Watch videos online to supplement class learning: YouTube /Lynda.com. Reference Autodesk Maya Docs. Google issues: Type “Maya 2018” and the troublesome feature/ function (Some answers using older Maya versions will still help, some will be obsolete).
ADVANCED TO 3D ART AND ANIMATION 
WEEKLY BREAKDOWN:
All homework are due on Piazza as attached files at least an hour before class (PNG, .MB, .ZIP, or Youtube Links). Please constructively comment on posts by at least 3 classmates every week. Questions should be emailed directly to the teacher: JasonWiserArt@gmail.com and please accompany questions with piazza links to posted screenshots. 

WEEK 1: Wed Jan 30: Intro to Course, Expectations, and Projects. Review animation and modeling tools. Intro to Pre-visualization: Cinematography, Storyboarding and Shotlists. Zero Drafting. Models and Textures. FK Character Proxies.
HOMEWORK 1: Choose a Practice Clip from the provided list and build primitive set in Maya. Draw the Storyboard and type Shotlist. 

ALSO: Submit 3 initial pitches for your Final Film (3-sentences each: full story, sketches)


WEEK 2: Wed Feb 6: Practice Clip Pipeline: Storyboarding and Rough Animation: Camera and Character Blocking. Disney 12, Root-Driven motion, timing considerations. Basic Lighting.
HOMEWORK 2: Draft Practice Clip animation (cameras/proxies) with lighting and imported Audio. Submit Playblast and project .ZIP. 

ALSO: Read and constructively respond to at least 2 classmate Final Film concepts: what you liked, where you might be confused, what you might suggest to revise / enhance.

WEEK 3: Wed Feb 13:  Live Film Compositing Pipeline 1: Color Correction and Blur. Colored/high-contrast lighting. 
HOMEWORK 3: Revise all Practice Clip character animation. Submit Playblasts with Audio.
Revised Final Film Story (the one you are pursuing) and Draw Initial Storyboards: JPGs

WEEK 4: Wed Feb 20: Live Film Compositing Pipeline 2: Tracking and Integration
HOMEWORK 4: Draw and compile Final Film Orthographic Character Diagrams: 2048x2048, 

proportional flat, in T-pose (see provided example). Review and constructively respond to at least 3 classmate Final Film Storyboards: what you liked, what you might suggest they revise.
ALSO: Eleven Rig Animation Composite: Body Story Moment, composited into live footage.
WEEK 5: Wed Feb 27: Character Modeling 1: Rough Volumes for Body and Head. 

Timed Storyboard MOVs.
HOMEWORK 5: Watch Character Video 1, Model Final Film Character Body and Head
Submit your Revised, Timed Final Film Storyboard as an MOV, including scratch audio.
ALSO: Eleven Rig Animation Composite: Facial Story Moment, composited in live footage.
WEEK 6: Thurs Mar 6:  Character Modeling 2: Cut and Extrude Details
Body, Clothing, and Head Details. Review Basic Unwrapping tools (Hut)
HOMEWORK 6: Watch Character Video 2, revise Final Film Character clothing, face, hair.

WEEK 7: Wed March 13:  Character Unwrapping and Texturing and Visual Effects 1
Precision UV mapping. Overview of Maya Effects options. Characters Review and Feedback

HOMEWORK 7: Watch Character Video 3, revise your Final Film Character and Unwrap. Build a primitive setting for your final film in proportion to your character model.
GRADUATE STUDENTS: Choose and Prepare a Maya VFX Presentation
[Wed March 20: NO CLASS for Spring Break]


WEEK 8: Tues March 27: Character Rigging 1: FK Rigs and Skinning, Character FK/ IK Set-up, Character Unwrapping 2. Demo: Texture Effects.
HOMEWORK 8: Zero Draft Final Film: Camera blocking, Character Proxy and Object Animation, Include Scratch Sound Track. Character joint FK and IK setup.

WEEK 9: Wed April 3: Character Rigging 2: Character Rig Controllers. Hand and Reverse Foot with Set Driven Key. Facial Animation with BlendShapes. 
HOMEWORK 9: Final Film Character Initial Rig (inside Zero Draft film file)

Revise Final Film Character Rig: FK, IK, Controllers, and Set Driven Key for hands and feet.


WEEK 10: Wed April 10: Visual Effects: Student VFX Presentations
HOMEWORK 10: Final Film Character Rig Eyes, Blendshapes: Phonemes, Blink, 3 extremes  
ALSO: Final Film Character Walk Cycle (copy of the file, frames 10-40)
WEEK 11: Tues April 17: Mudbox Sculpting and Texturing. Student VFX Presentations 
HOMEWORK 11: Final Film: Initial Character Animation 1/2, Submit Playblast


WEEK 12: Wed April 24: Basic Vehicle Rigging. Student VFX Presentations
Rigging Shock absorbers. Students provide feedback and work on final projects
HOMEWORK 12: Final Film: Full draft of initial Character Animation, Submit Playblast

WEEK 13: Tues May 1: Rendering. VR Pipeline 1: Considerations for VR spaces/ projects.
Arnold Rendering Topics, and Render Sequence. Review of films.
HOMEWORK 13: Final Film: Revised Character Animation.
Improved models, textures, and lighting. Submit Playblast

WEEK 14: Tues May 8: VR Pipeline 2: Implementing 3D models in VR.
Students provide feedback and work on final projects

HOMEWORK 14: Final Film: Revised character animation, lighting, and Cinematography. Submit Final Rendered Film, complete with post-production, soundtrack, title card and credits. 

WEEK 15: Wed, May 15: Final Presentations of 3D Animated Films!
Schedule subject to change per class needs. 

Please coordinate with teammates AND instructor if absent to confirm assignments.
ADVANCED 3D ART AND ANIMATION

COURSE PROJECTS:
[1]. PRODUCTION PIPELINE  PRACTICE CLIP PROJECT: Weeks 1-3: Choose one of the provided 20-50 second TV clips and reproduce in Maya to practice pre-production “Zero Draft” tools for quick scene building and animation. This system is practice for your final project!
[3]. ONE TEXTURED & RIGGED CHARACTER MODEL:  Design, Model, Unwrap, Texture, Rig and Animate an original bipedal human character. Please choose a character with two arms, two legs, one head, and clothes, no robots. Lesson Videos:

· Character Body and Head Roughs: youtube.com/watch?v=2R8Hh954ecs
· Character Body and Head Details: youtube.com/watch?v=yZDRc023XAE
· Character Unwrapping and Texturing: youtube.com/watch?v=tJcZe8rGHxs
· Character Rigging: youtube.com/watch?v=tJcZe8rGHxs
[4]. FINAL 3D ANIMATED FILM: 20-30 second story featuring 1 bipedal humanoid character, rigged for full-body and face animation. Other characters may be implied (cameras/ shadows/ sound). Grade is for storytelling and creative uses of 3D, not polished scenery, so get models in quickly and animate! Environments can also include composited photographs or footage.

Show dynamic and expressive character/object/camera motion, original shapes and surfaces with modeling/texturing/ lighting, and creative atmosphere with your VFX and post-processing in After Effects. Render (Arnold) a final film. Include original Audio.
[2]. ELEVEN RIG PRACTICE ANIMATION:  Before your Original Film character is modeled and rigged, you will create 2 short animations related to your story on a provided industry rig.

[6] EXTRA CREDIT: ATTEND AT LEAST ONE NETWORKING EVENT: Choose an animation/game industry event from the list below, attend, and write up a single typed page on your experience. Be sure to include your name, the date, name, and location of the event, and a summary of your experience and reactions: http://madwomb.com/tutorials/GamesBoston.html
Graduate Student Short VFX Presentations: 

Graduate students are responsible for a 10-minute demonstration of a VFX topic using Maya. Find a tutorial and email the teacher by week 8 with title and link to confirm that topic it is still available. 
Prepare your presentation: review and practice steps so you can present it in about ten minutes. Type-up your own version of the steps. Choose a class weeks 10-13 to present. Bring your step as a printed copy and submit digitally on piazza, along with files needed to show your core VFX topic.

PARTICLES (use an opacity map texture): Fire, Smoke, Weather (rain, snow, sleet), Dust (in air, or kicked up by a vehicle), Leaves blowing on the wind, Sparks, Fireworks, Explosions 

SIMULATION: Cloth (nCloth), Fluid Effects (water faucet, river,glass of juice, etc) Physics (make objects fall apart: bridge collapsing, stacked toy blocks falling, etc) 

TEXTURE FRAME SEQUENCE: Fire, video on screen, etc 

POST PROCESS/CAMERA EFFECTS: Glow, Depth of Field, Visible Light (beam, lens flares) 

Other Recommended Texts:

Digital Lighting and Rendering by Jeremy Birn


ISBN-10: 0321928989
Stop Staring: Facial Modeling and Animation by Jason Osipa 
ISBN-10: 0470609907

Rig it Right! Maya Animation Rigging Concepts by Tina O'Hailey
ISBN-10: 0240820797

The Animator's Survival Kit by Richard Williams 


ISBN-10: 086547897X
SOFTWARE: 
PHOTOSHOP KEYBOARD SHORTCUTS

Create a New file (sized to clipboard): [ Ctrl ]+[ n ]
Open existing file: [ Ctrl ]+[ o ]
Save a file as a .PSD: [ Ctrl ]+[ s ]

Save a file as another type: [ Ctrl ]+[ Shift ]+[ s ]


Select All: [ Ctrl ]+[ a ]

Copy:
[ Ctrl ]+[ c ]

Paste:
[ Ctrl ]+[ v ]


Duplicate Layer or selection: [Ctrl]+[ j ]

Copy-Move: Marquee select, [ Alt ]+LeftClick/drag

Undo (step back multiple changes): [ Ctrl ] + [ z ]  or  [ Ctrl ]+[ Alt ]+[ z ] 
Paint Brush: [ b ]
Eraser: [ e ] 

Change Brush or Eraser size: [ [ ]  or  [ ] ]

In Brush or Paintbucket tools, hold [Alt] to color-pick from a palette.

Switch colors between background and foreground: [ x ] 





Tool Opacity (increments of 10% opacity): top numbers between [ 1 ] - [ 0 ] 
Free Transform (selection or layer): [ Ctrl ]+[ t ] 

Move tool: [ v ]


Marquee Selection tools: [ m ] 
Lasso Selection tools: [ l ]

Magic Wand:
[ w ]



Select the shape of layer content:
[ Ctrl ]+LeftClick on a layer icon

Paint Bucket / Gradient tools: [ g ] 
Clone tool (hold [alt ] to choose target): [ s ] 

Rotate the Screen: [r]
Hide/Show Palettes: [ tab ]







Zoom tool: [ Z ] , click or [Alt]+click
Hand tool (explore zoomed-area):
 [ h ] 
Fit on Screen (show extents): [ Ctrl ]+[ 0 ] (zero) 





View all keyboard command shortcuts: 
[ Ctrl ] + [ Alt ] + [ Shift ] + [ k ]
NOTE: Hover over any button in Photoshop to see the keyboard shortcut.
COLOR BASICS

· Hue = color. Increase saturation to make color richer, desaturate for duller results

· Value=shade: how much black (0) or white (255) is in the color.

· Use Image> Adjustments (Hue/Saturation, Brightness/Contrast, Levels) to change selections.

· Use Blending Modes in Layers for Multiply (darker), Screen (brighter), Overlay (richer).

PHOTOSHOP TEXTURE PAINTING BASIC STEPS
We will mostly be painting our textures (though you can also manipulate photos or scan materials):

1. Bring Unwrap UV art into a new Photoshop file 2048”x2048”, 72ppi
2. Set UV layer to 20% opacity, blending mode= multiply.

3. Add 3 layers below (from bottom): BaseColors, Details, and DirtShadows.

4. Find a reference image for colors (photo, painting, frame of a movie or game), and color-pick 5-12 colors in various shades to paint swatches in the palette layer. 

5. BaseColor Layer: With the Paintbucket, quickly paint the main colors to fill the areas of the UV map. Use a solid brush, 100% opacity.

6. Details Layer: With a medium brush, paint the desired details. Use a solid brush for main colors and highlights, 100% opacity, and then use push-pull at 30% to paint transitions.

7. DirtShadows Layer: With a solid brush, 30% opacity, draw layers of shadows with dark colors. Assume light source is above. Use a 20% opacity eraser, to paint and erase, repeat.

SOFTWARE: 
MAYA MODELING AND TEXTURING 
Body Modeling: https://youtu.be/2R8Hh954ecs
Head Modeling: https://youtu.be/yZDRc023XAE
Unwrapping:      https://youtu.be/tJcZe8rGHxs
Rigging:             http://bit.ly/1Nf5909
MAYA INTERFACE AND MODELING:

SHELVES: Near top: Poly Modeling to create geo, Rendering for lights, Rigging for joints, etc.

CHANNEL BOX: Right: set Transforms, Inputs, Name, Deformer values. Can switch to Attribute Editor.
LAYERS: Bottom of Channel Box, create new layers to hide/freeze, RightClick to Add Selected Objects. 

TRANSFORMS: Change objects or components: [Q] = Select, [W] = Move, [E] = Rotate, [R] = Scale

ATTRIBUTE EDITOR: Alt RightPanel, set parameters on selected object. Off Arnold > Opaque for opacity.
SELECTION: [Shift] = hold to add to a selection, [Cmd] = hold to remove from a selection.
DISPLAY MODES: [4] = Wireframe, [5] = Surface, [6] = Textures, [7] = Lighting

COMPONENT MODES: RightClickHold selected object, choose Vertex, Face, or Edge. Exit component: RightClick/ Object Mode. DoubleClick an Edge to select its loop. Select face, [Shift]+DoubleClick neighbor to select face ring. [Shift]+[>] = grow component selection, [Shift]+[<] = shrink selection.

VIEWS: Tap [Space] to toggle from four views to one, hold [space] for main menus. 

[Shift]+RightClick = context tools.
[Cmd]+RightClick = Component Mode Conversion

Render in Perspective view, work in Orthographic views (right side, top, front)! Avoid Move square in Persp.
VIEW MENUS: View > Image Plane and Camera Settings, Shading > turn on Xray, Show > turn off Grid.

Delete: [Delete] key to remove selected faces. [Cmd]+[Backspace] to remove edges/verts but keep faces.

COPY: [Cmd]+[d] = duplicate. Edit > Duplicate Special option box to set Instance or mirror (Scale [x] = -1). 

MODELING TOOLKIT: Alt RightPanel, includes primary modeling tools:
· Extrude: select 1 or more faces and tap to create new geometry. Use Thickness and Offset settings or hit [W] to move out directly. Select 1 or more edges and extrude to pull out a face for Strip Modeling.
· MultiCut to create surface shapes for extruding. Insert Edge Loop: MultiCut+[Shift].

· Connect: Select 2 or more parallel lines or adjacent vertices and hit for a new perpendicular line.

· Bevel: select 1 or more edges, hit to split into doubled edges. Open OptionBox for split distance.
· TargetWeld: select a vertex, click and drag to weld to another vertex.

· Bridge: select edges on gap sides or facing polygons. Hit to create polys. OptionBox for tessellation.
MODULES: In upper left-corner choose module. For modeling and UV editing, choose “Modeling”
Menus: At top, changes per Module. Open and hit top dotted line to break off. 
Tools ([Y] to end/repeat) and Functions ([G] to end/repeat).
	MESH


	· Fill Hole = select a hole by doubleClicking an edge and hit to fill.

· Combine = Select two forms to attach into one form. New pivot point will be at (0/0/0). 

· Extract = Select faces to detach from a form. After Extracting, deselect before transforming.

	EDIT 

MESH


	· Chamfer Vertex: split vertices along their terminal edges. Use to cut a circle into a square.

· Merge: hold [v] to snap a vertex to neighbor, select around and hit Merge to become 1 vertex.

· Collapse: select 1 or more edges and hit to collapse into vertices.

	MESH

TOOLS
	· Create Poly = Draw a 2d form for extrusion into a volume .

	MESH DISPLAY


	· Soften Edge = apply to edges for light to move smoothly between adjacent faces.

· Harden Edge = apply to edges to form a hard line between make adjacent faces.

· Reverse = select  face and flip the Normal (direction it faces)

· Conform = select around all faces to make all Normals face the same direction


CLEAN UP: Always Edit > Delete By Type > History & Modify > Freeze Transforms before saving work.

PIVOT CHANGING: Modify > Center Pivot. Tap [d] to move the pivot by hand, tap again for normal move.
FK PARENTING: [p] = parent selected objects to the last selected. [Shift]+[p] = break parenting.
MAYA TEXTURES:
Window > RenderingEditor > Hypershade to open material editor (or hit blue olive on top bar). Primarily used to apply textures to objects, can also be used for node-based programming

· Add a Shader to work space, in Property Editor (right) click Checkered Square to add file node and click the manila folder icon to add a .PNG to that node. NOTE: Maya only stores a pointer to the bitmap, and only if Project is Set. Store bitmap files in a subfolder of your Maya project folder, and Set the Project: File> Set Project, choose the project folder. Re-Set the Project on new computers.
· Use AiStandardSurface for object textures (use search box, left). Put Color PNG into Base > Color. Put Specular PNG into Specular > Color. Bump & Opacity channels are found under Geometry.

· Hit [6] to view color textures in the Viewport. Hit Arnold > Render to see all channels active.

· Clean Up Nodes: RightClickHold material to choose Graph Network.
Modeling Module Menu UV > Cylindrical Map hit red “T” to access special UV Move/ Rotate/ Scale.  

UV > Planar Map option box: choose projection axis based on selection: Z=front, X=side, Y=top or bottom. Hit [Apply] and red “T” to access special UV transforms.
UV > UV Editor to open the 2D “UVW” interface for any selected object. Primarily used for managing location of each surface “UV Shell” on a texture square for painting, can also be used for selecting component parts.

· RightClickHold to choose UVs component to Move/Rotate/Scale. DoubleClick one UV for all attached UVs. Rotate by hand or use quarter-turn buttons on toolbar (circle arrow icons).

· Select edge to Cut/Sew menu > Split or Cut/Sew menu > Move and Sew.
· To flip UVs, select and non-uniform scale “through” itself.
· Export UVs to Photoshop: Image menu > UV Snapshot. Set size (2048x2048) and browse for name/location. Be sure selection is in Object Mode (not a component), hit [OK].

Arnold Render to render Current Frame. Requires lights + materials to function. Updates with scene changes!

Or use Clapboard icon on Module bar. 3rd icon is Render Settings. In Render view, hit “Keep Image” icon to compare renders, or select in view and hit Render Region icon. Software, Hardware, or Arnold available.
MAYA TOON SHADING:
"Surfacing" is the work of managing lights and textures to create a specific look and feel for a 3D render. 
Toon Shading can create a non-CG appearances that integrates well with 2D art and VFX. 

The Maya Arnold AiToon shader was introduced in Spring 2018 with Arnold 5.1, and includes a rich array of varied tools for rendering edges with comic book line weight and colors, shadows, and highlights with varied degrees of flatness. Download newest version here: http://solidangle.com/arnold/download/
Learn about Maya Arnold Toon Shading here: https://support.solidangle.com/display/A5AFMUG/Toon
Sven: https://support.solidangle.com/display/A5AFMUG/Toon+Shading+and+Lighting+Sven
Mech: https://support.solidangle.com/display/A5AFMUG/Toon+Shading+a+Mech+Tutorial
See Toon Shading file and others here: https://support.solidangle.com/display/A5AFMUG/Learning+Scenes
Fake a Toon shader with a Ramp : https://www.youtube.com/watch?v=4hcrd0FFa6s
SOFTWARE: 
MUDBOX SCULPTING AND PAINTING 
Here is an introduction to keyboard shortcuts and tools in Mudbox.

.
KEYBOARD SHORTCUTS: http://download.autodesk.com/us/mudbox/help2010/index.html
· Tools Properties: Size=[b]+LMB, Strength=[m]+LMB, Mirror=[Shift]+[Alt/Option]+[x] / [y] / [z]
· Focus=[F], Frame All=[A], Wireframe=[W], Undo [Ctrl/Cmd]+[z] Redo [Shift]+[z]

· CAMERA: Rotate=[alt/option]+LMB, Pan=[alt/option]+MMB, Zoom=[alt/option]+RMB

· Add SubD Level=[Shift]+[d], 
Step up/down SubD levels=[Page Up]/[Page Down]

· Toggle Smooth=[Shift],
Invert Sculpting Tool=[Ctrl] 
· Invert Freeze=[Shift]+[i] 
Unfreeze All =[Shift]+[u]

· First nine Sculpting tools = 1-9 on the keyboard: 

Sculpt (2) Smooth (3) Grab (4) Pinch (5) Flatten (6) Foamy (7) Spray (8) Repeat (9) Imprint

BASICS:
· Menu/Create/Sphere.
RightClick in scene, turn off “Grid” and “Gradient” in context menus.

· Select object in Scene or Object List to transform.

· Add a Layer: click on Layer tab, or RightClick on Layers Menu to choose “New Layer”.

· DoubleClick to change layer name.

· Shift+[D] to subdivide (resolution flash in upperRight HUD, see in lowerLeft Status Bar).

· [Page Up]/[Page Down] to view geometry SubD Levels.

NOTE: Once you start to sculpt, that Layer is locked to that SubD Level; you can add more SubD Levels, but to sculpt at them you need to add more Layers.

· Use SubD level 3 for large shape changes, level 5 for adding medium details.
· Select the Layer to make it active. 
· To Draw Guidelines, use Knife or reverse-Bulge tool [Ctrl].
· Bulge and Grab tools to pull out forms, Pinch tool to accentuate edges.

· Wax tool to add to forms. Foamy Tool to add finer fine sculpting, like nostrils.

· Fill tool to make a surface in a depression, for modeling upon.
· Hold [Shift] to toggle to Smooth tool while using any other.

· Use Pinch tool to pull tighter any details made with Bulge tool. For seams, reverse Bulge [Ctrl] and then Pinch. Use property “Steady Stroke”.

· An “extrude” is a freeze/invert/grab: In a new Layer and SubD Level: select Layer, select Freeze tool at 100% strength, paint shape to be “extruded.” Hit [Shift]+[i] to invert Freeze so everything EXCEPT the painted shape is frozen. Use Bulge or Grab tool to pull out the form. To turn off all Freeze, hit [Shift] +[W]. Use Flatten tool to flatten top of “extrude.” 
BEST SCULPTING PRACTICES (Textbook, p47):
· Rough-in large forms first at lowest possible level that holds the form, add details later at higher levels (work general to specific).

· When building up forms, blend into the surrounding area with the Smooth tool.
· Organize reference materials, save often, save incremental files.

· Rotate around model often. Move scene light [L]+MiddleMouse to see details.

· View model with different materials. Try lighter materials to bring out details.

SOFTWARE: 
NOTES ON CLEAN 3D MODELING

The following are critical considerations for creating strong 3D Polygon Models in Maya:
TERMS: 

· Polygon: A triangle unit for building 3D forms. 3ds max mistakenly calls this a “face.”

· Normal: The polygon facing direction, represented by a perpendicular arrow (normally invisible).

· Modular: Geometry with a consistent, unbroken surface.

HYGIENIC (Clean) MODELING: “Unclean” geometry is where the model is no longer Modular. When geometry is unclean its surface can display strange shadows, change shape unpredictably when animated, and break when advanced techniques like Boolean are applied. Unclean geometry includes:
· Interior Geometry: All models should be a hollow shell. Polygons crossing through your shell, sometimes with vertices attached both to one side and the opposite side, must be deleted. Another example is if two vertices on opposite sides of a form get collapsed.

· Duplicate Vertices: What appears to be a single vertex is actually two or more in the same space. These must be merged.

· Coplanar Geometry: Two polygons occupying the same space, sometimes with Normals facing in opposite directions. One of these polygons must be deleted, or bad “flickering” will appear in the render.

· T-Geometry: Planes that intersect without being connected by vertices (essentially, one object just stuck into another and attached, without being connected to create a consistent, modular surface). Both objects can be Cut at their intersections, the internal geometry deleted, and the matching vertices welded, or they can be detached and Booleaned into each other.

WASTED GEOMETRY:  Vertices sitting on straight lines which do not contribute to the form represent wasted polygons. In both real-time games and pre-rendered film projects these wasted polygons cost money and resources, and must be eliminated through collapsing and snap-merging vertices.

AVOID LONG POLYGONS: Long polygons will frequently cause issues with lighting and shadows. Most rendering systems calculate lighting by the location of vertices, and if these are too far apart the space between them will have difficulty lighting properly. The solution is NOT to add wasted vertices along the surface; instead, design your forms with more variation and detail.
GOOD CURVES AND SILHOUETTES:  Curves need enough polygons to appear smooth. Consider added detail to make the silhouette interesting, such as clothing breaks.
ORGANIC MODELING: For all characters, the following three principles must be applied to create forms which will animate smoothly:

· Even Tessellation: Be sure to evenly space the divisions on all the parts of the body, so that the upper arms, lower arms, upper and lower leg, and torso have roughly even spacing. Joints and the face will have higher tessellation, but should still be internally even. 

· Quads: Work toward only 4-sided shapes everywhere (two triangular polygons). Avoid triangles where possible, and absolutely be sure to cut down all shapes more than 4 sides (N-gons)

· Edge loops: Cut lines on the body to enhance animation by following muscle forms: straight circles around the limbs and torso, concentric circles around the mouth and eyes.

ANGLES: Most outside edges should be Beveled to not appear sharp. Avoid acute angles (<90 degrees) and adjust interior extruded edges to make them obtuse (>90) for better visibility and appeal. 

SOFTEN/HARDEN: Use these buttons under the “Mesh Display” menu to remove hardness from edges and create unified surfaces on big forms, and to define the difference between material forms. On a character, for example, all the skin should be one form, the pants one, the shirt one, the belt one, etc. 
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