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Where To Find Information

Your Portable IMPACT device comes with this manual and supplemental reference material on a CD-ROM. Refer to this manual for information on operating the Portable IMPACT software and associated peripherals (such as external switchboxes). Refer to the iPAQ PocketPC Reference Guide on the CD-ROM for information on operating the device itself.

Your ChatPC device comes with this printed manual and a CD-ROM labeled "CASSIOPEIA Software Application".  Refer to the printed manual for information on operating the ChatPC software and hardware.  This manual also contains instructions for the PC Editor software.  When you are ready to learn about the Casio computer and the PocketPC operating system, place the CD in your PC and you will be given the option to "View Manuals".  Selecting that option will allow you to view the hardware manual titled Getting Started with the CASSIOPEIA (for information on operating the device) or the user's manual titled Pocket PC User's Guide (for information on using PocketPC).  You can either use these manuals directly from the CD or you can print either manual on your computer printer.  You can also contact Casio directly to purchase printed versions of these manuals.

Using This Manual

This User's Manual will provide all the information you need to operate your ChatPC device.  For specific information refer to the appropriate section as follows.

1. Getting Started
…provides all the information you need to get ChatPC up and communicating right away.  Start here after you have unpacked all the parts.

2. Vocabulary Organization,
…provides instruction on creating new configurations

    Creating/Editing Configurations 
and editing existing configurations.  

3. Customizing Configurations
…provides instructions on the most common functions.  This section will walk you through common operations.

4. Overview of Menus
…contains a detailed description of all of the options available in the software.  Look here if you want to explore all of the software functionality, or if you have a question about how a specific feature works.

5. Clinical/Research Data
…provides detail about the data logging feature.

6. About PocketPC
…contains an overview of ChatPC’s navigating capability to the PocketPC operating system.  

7. Expanding ChatPC capabilities
…provides details on using the PC Editor.  Go here to learn how to back-up your custom vocabulary to a PC and import custom images into the device.

8. Troubleshooting
…provides solutions to a list of common problems.  Go here if you are having trouble with a particular action or if the system is not behaving as you expect.

NOTE: This manual assumes that you have some experience using Windows and are comfortable with concepts such as navigating menus, clicking, and double-clicking. Refer to the iPAQ Pocket PC User’s Guide (on CD-ROM)  for additional information on the basic operation of the device.
1. Getting Started

· Introduction

· Turning the Device On & Off

· About the iPAQ 3835 Portable Computer

· Explore ChatPC’s Standard Configurations

· About ChatPC’s Software

· Batteries & Charging

· Auto Power Down

· Auto Dim
1.1. Introduction

Thank you for purchasing ChatPC, a revolutionary dynamic display augmentative communication device.  More than just a new look for old technology, ChatPC provides advanced augmentative communication in one of the smallest and lightest packages available.  ChatPC is designed to offer symbol-based communication in a device that doesn't get in the way and is ready to go whenever and wherever you want.

1.2. What’s in the Box

· Packing list

· ChatPC Device - Consisting of:

· HP iPAQ 3835 PocketPC (with software preinstalled)

· Rubberized case with integrated speaker and amplifier

· Multimedia card (installed in computer)

· Important Information about ChatPC manual

· ChatPC User's Manual with VocabPC documentation (this book)

· USB/serial cradle for connecting ChatPC to Windows computer

· AC adapter for charging the ChatPC

· ChatPC Editor CD-ROM

· iPAQ PocketPC Companion CD-ROM with ActiveSync and Outlook 2002
· Quick Reference Guide
· 1 additional stylus (The 2nd stylus has been stored in the iPAQ for safe keeping. The iPAQ must be removed from the rubberized case to remove the second stylus from the unit.)  

IMPORTANT! Recharging the batteries.  

Since the computer runs on rechargeable batteries it is important to plug in the AC adapter immediately after unpacking it to charge the computer back up to full power (some power will be drained during shipping).  The AC adapter plugs into the jack on the right hand side of the ChatPC.  When the computer is charging, a red light beside the charger will light up.  Complete charging details begin in section 1.8. 
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1.3.Turning Your Device On and Off
The power switch is located near the top on the front face of the device.  You will notice that the device comes on almost instantly when you press the button.  You never need to wait for the computer to "boot up" as you do with a typical desktop or laptop computer.  Just turn it on and it's ready to use.

You can also turn on the ChatPC by pressing any of the 4 special functions keys on the front of the ChatPC.  This allows the device to be turned on by a system operator.

To turn the computer off, simply press the power button again.  With a desktop computer you typically shut down all the programs before you turn the computer off – if you don't you may lose whatever you were working on.  With a PocketPC computer you can turn it off and on again and your programs will be running just as you left them.  There is no need to shut down any running programs.

Note:  The computer is designed to conserve battery power by automatically shutting down after several minutes of inactivity.  If this happens simply press the power button to turn it back on.

Running ChatPC.  When you first turn the ChatPC on, the ChatPC application should be running.  You should see a page with symbols similar to the screen shown below.  If you don’t see such a screen or if the unit won’t turn on, turn to section 6.3.  

Just start tapping the onscreen buttons. Depending upon the type of button, selecting it may speak a word or phrase, navigate you to a different page, or perform an editing action.  Buttons are selected by tapping or pressing on the touchscreen.
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WARNING: Never use a sharp metal object such as a pen or paperclip for tapping, as it will damage the screen.
1.4. About the HP iPAQ 3835 Portable Computer

Portable IMPACT is currently being shipped on the HP iPAQ 3835 PocketPC. This computer provides an excellent display and a fast microprocessor for a reasonable price. In addition, it has a serial/USB port for attaching external switches and a headphone jack for attaching external speakers. If you cannot find the information you need regarding operation of your HP iPAQ 3835 in this manual, please refer to the included CD-ROM titled “iPAQ Pocket PC Companion CD”. The CD-ROM contains electronic versions of iPAQ Pocket PC Reference Guide (for information on operating the device) and the iPAQ Pocket PC User’s Guide (for information on using Windows CE).

ChatPC is currently being shipped on the HP iPAQ 3835 PocketPC.  This computer provides an excellent display and a fast microprocessor for a reasonable price. If you cannot find the information you need regarding operation of your Casio EM-500 in this manual, please refer to the included CD-ROM titled " CASSIOPEIA Software Applications ".  
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Figure 1: The HP iPAQ 3835 (out of protective housing)
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Figure 2: The HP iPAQ 3835 (in protective housing)

1.5. Explore ChatPC’s Standard Configurations 
ChatPC allows you to load a variety of pages that have different button layouts.  Each set of pages, or vocabulary set, is called a configuration.  ChatPC includes two configurations that can be used as a starting point for a configuration or just used as a demonstration.  To see the two configurations included with ChatPC: Symbol-Base and VocabPC:
· tap on the File menu

· then tap on Standard Configs  

· simply tap on the one you want to load  (The device was originally shipped with the Symbol Base configuration loaded.)

Complicated configurations with many pages may take up to 2 minutes to load, but most will load quicker.  Once loaded, you can leave ChatPC running and your chosen configuration will always be ready for you to use.  Just start tapping the onscreen buttons to explore the vocabulary.

The Symbol-Base interface includes a number of topic-organized pages with Mayer-Johnson symbols.  The Symbol-Base configuration is intended to provide a basis for building a set of custom symbol-based pages for a specific user. By no means is this configuration comprehensive enough to be used as a person's sole means of communication. It is included to provide a head start to anyone attempting to create a fully functional configuration. It also serves as an example of one possible way to organize symbol pages. If you have a preferred method of organization and page design, you might want to consider starting from scratch. For more information on creating and editing configurations, see section 2.
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Home Page

WARNING: Never use a sharp metal object such as a pen or paperclip for tapping, as it will damage the screen.

Symbol Based Vocab cont’d
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Greetings Page
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Telephone Page

VocabPC was developed for adolescents and adults who have moderate to severe intellectual disabilities.  The vocabulary was selected based on what these individuals might need to say at home, work, in adult education activities, and in their communities.  VocabPC is organized with single words and phrases, some sentences, 28 pages of vocabulary with 12 keys on each page, color coded keys to help individual’s tell the difference between the keys and empty keys on most pages so specific words can be added for the person’s unique needs. A complete description of this configuration can be found at the back of this manual.
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General Talking Page


[image: image10.png]



Feelings Page

VocabPC Vocabulary Cont’d
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Category Page
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Activity Page

1.6. Controlling the Volume

The rubberized case has a built-in speaker and amplifier.  The amplifier is connected to the iPAQ computer at the top of the device.  This connector should always be plugged in except when removing the iPAQ from the protective case.  On the right-hand side of the ChatPC are two controls for the amplifier; an ON/OFF switch and a volume knob.  The ON/OFF switch can be left in the ON (1) positions most of the time.  If you are not using the ChatPC for an extended period of time, move the switch to the OFF (0) position.  The volume knob adjusts the speaker volume.  Turn the knob clockwise to increase volume.  Turn the knob counterclockwise to decrease volume. 

Volume controls can also be added to buttons within the vocabulary pages.  See section 2.5.7 for details.
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1.7. About the ChatPC Software

The ChatPC window is divided into three regions, see below.  At the bottom of the screen, there is a Menu Bar on the left and a Tool Bar to the right.  These controls are used to configure the software.  At the top of the screen is the Editor Window.  This is the area where text will appear as you type it.  Below the Editor Window is the Interface Window.  This is where the symbol pages will appear.  By loading new pages into the application, you can completely change the appearance and functionality of the Interface Window.  The menus, tool bar buttons, and Editor Window appear the same, regardless of the current configuration.

Note: The Editor Window, Menu Bar and Tool Bar can be turned off if desired.  See section 3.5 for more information.
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1.7.1.Menus

The pull-down menus at the bottom left of the ChatPC window allow you to determine which configuration will be used, which augmentative options are enabled, how and when to speak messages, and how a wide variety of other options are configured.  Some of these features are accessed directly through the pull-down menus, while others are accessed through pop-up dialog boxes called up through the menus.

You can access menu items using the touchscreen, either with the stylus or your finger.  Tap on the menu name in the lower left portion of the screen.  Once the menu appears, tap on the selection you want.

Note: If the menus do not appear at the bottom of the display, the ChatPC has been set to 'full screen' mode.  Press the record button to turn the menus back on.

1.7.2.Toolbar 

The tool bar to the right of the menu bar provides a quick way to access some of the more common menu items, as well as providing additional functionality.  When in Run Mode (when not editing a configuration) you will see the normal toolbar.  The first button allows you to change the Font Size.  The second button brings up the Options dialog.  The Clear Editor button clears text out of the editor window.  Finally, to Stop speech while still speaking, tap the fourth button.
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1.8.Power 

1.8.1. Batteries
The ChatPC contains 3 separate batteries.  Each battery serves a unique purpose.  Below is a short description of each battery and its function.  

· The iPAQ Main Battery is a sophisticated rechargeable Lithium-Ion Battery.  It supplies power for running the iPAQ computer and the color display.  This battery is the main supplier of power for your ChatPC.  Normally when you need to charge the ChatPC, it is because the iPAQ Main Battery is low.  The iPAQ computer has an internal circuit which keeps the main battery from overcharging.  The iPAQ Main Battery discharges within 2 weeks even if it is not being used.  Data loss is possible when the main battery discharges.  See section 8.2. for instruction on replacing the main battery.

· The IPAQ Backup Battery is a small Lithium 'watch' type battery.  This small battery functions as a backup when the main battery discharges.  The backup battery in non-rechargeable.  When the main battery completely discharges, the IPAQ draws on the backup battery to protect memory.  See section 8.3. for instruction on replacing the backup battery.

· The Amplifier Battery is a rechargeable Nickel Cadmium (NiCad) battery.  This battery supplies the power to the amplifier circuit in the rubberized ChatPC case.  The amplifier battery recharges in 4 hours.  If the Amplifier On/Off switch is left in the ON (1) position, the battery will discharge within a week or so. See section 8.4. for instruction on replacing the amplifier battery.

1.8.2. Charging the Batteries

At the end of each day, the device should be plugged in to ensure that the batteries are fully recharged for the next day.  A complete recharge only takes about 4 hours, but since it is impossible to "overcharge" the batteries you can safely leave the device plugged in whenever you are not using it.  If the device is left unplugged for more than 1 or 2 weeks without being used, the battery and backup battery can discharge completely and you will have to restore some of the software.  To avoid this, keep the device plugged in whenever you are not using it.  If you do accidentally discharge the batteries, refer to section 6.3 of this manual for an explanation of how to restore the device.  

Regular charging of your batteries is important for several reasons.  First the batteries protect the memory in your ChatPC.  If the main batteries are left uncharged, the backup battery can drain and certain aspects of the software need to be reloaded.  While your data will usually be intact when this happens, it does present an inconvenience and requires you to spend time reloading the software.  Secondly, charging the batteries properly allows you to get better performance out of the batteries and reduce the cost of replacing batteries.

The ChatPC is designed so that both the iPAQ Main Battery and the Amplifier Battery charge from the same charger.  The battery charger plugs into the charger jack on the right hand side of the ChatPC (on the rubberized case).  You will see a charger connector coming from the rubberized case on the left side and plugging into the iPAQ computer.  When the charger is plugged into the right hand side of the ChatPC, this connector transfers charging current from the amplifier board to the iPAQ Main Battery.  
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                                                                                                                                                                                                                                                                                                                                                    When the Charger is plugged into the ChatPC, the red lamp beside the charger will light up to indicate that it is charging.

Here are some guidelines for charging the batteries.  

During Normal Use - Charge the batteries on a regular basis.  Often the ChatPC can be charged every night.  In cases where the ChatPC is used for an hour or less during the day, you may want to charge the batteries once every two or three nights.

When the ChatPC is stored for an extended period of time.-  In cases where the ChatPC is stored for an extended period of time (For example during Christmas vacation or during the summer vacation. We recommend the following:

Turn the Amplifier On/Off Switch to the Off (0) position.

Find the charger connector coming from the left hand side of the rubberized case and plugging into the IPAQ computer.  Unplug this connector.  

Plug the battery charger into the connector where you removed the connector.

Look under the rubber case at the top of the screen.  You should see a lamp lit either green or amber. Make sure the ChatPC is turned off (the screen should be dark).

When you are ready to get the ChatPC out of storage:

Unplug the charger.

1. Replace the connector coming from the rubberized case back into the charging connector on the IPAQ.

2. Plug the charger into the normal charger jack on the right hand side of the ChatPC.  The red indicator light should illuminate.

Charge for 4 hours.

Move the Amplifier On/Off switch to the On (1) position.  The ChatPC will now be ready for use.

A complete recharge only takes about 4 hours.  If you do accidentally discharge the batteries, refer to section 6.3 of this manual for an explanation of how to restore the device.  

1.8.3. Checking Battery Status

To check the current status of the IPAQ Main Battery and the IPAQ Backup Battery:

· tap on the Tools Menu

· choose Options

· choose the System folder

[image: image17.png]Chatpc

Options

Suspend after:

NOTE: The "Suspend after” setting wil
overrids the system setting whi the
applcation i runring,

] acthe deisted device

NOTE: When opersting as a dedicated device,
vou il nct have access to any ather
Programs o the Windaws CE contral panel,

]

Setting dilogs [<select didbg> <]

General | speech | system





· tap on the down arrow next to Settings dialogs (a list of controls should appear)

· choose Power 

This screen shows the current battery status and sets the automatic power-down feature.
1.8.4. Auto Power Down

The computer is designed to suspend automatically after a set duration if the computer is not in use.  As long as you perform some action within the "Power Off" period, the computer will stay on.

To change the time the device waits before shutting off by itself:

· Go to the Tools menu

· Go to Options

· Go to System

· Go to Suspend after:
The first option is use system settings.  If this choice is selected, you control the "Power Off" settings through the Settings dialog ( Power dialog (at the bottom of the System screen).  That dialog will allow you to set the computer to power off between 1 and 5 minutes.  If you need to have the power stay on longer than 5 minutes (such as during a demonstration), use one of the other settings (10, 20, 30, 40, or 50 minutes).  Using a setting of infinite, will keep the power on continuously.  This is dangerous since it can drain the batteries completely.


1.8.5. Dimming the Screen to Conserve Power

Another battery saving feature of PocketPC devices is called Auto Dimming.  You can adjust the amount of time the system will wait before it dims the screen or you can turn this feature off entirely.  To adjust this time:

· Go to the Tools menu

· Go to Options

· Go to System 

· Go to Settings Dialogs

· Choose Brightness

· Choose Auto Dim

Adjust time as appropriate.

2.  Vocabulary Organization, Creating and Editing Configurations
· Creating a New Configuration

· Editing Buttons

· Creating Pages
· Copying Pages
2.1. Basics of Communication

A configuration is a set of vocabulary pages.  Every configuration consists of a series of pages, each with a grid of onscreen buttons.  These buttons may include text labels, graphical symbols, or both.  The number of buttons, as well as their appearance, can be customized.  Depending upon the type of button, selecting it may speak a word or phrase, navigate you to a different page, or perform an editing action.  Buttons are selected by tapping or pressing on the touchscreen.

Speech synthesis can be used to speak what you are typing.  ChatPC uses the high-quality DECtalk™ software speech synthesis engine.  You can pick any one of 9 different voices, adjust the volume, adjust the speaking rate, and determine whether to speak every character, word, phrase, or sentence (or all of them if you like.)  Simply tapping on the editor window will speak all previously entered text.  Tool bar buttons and on-screen buttons allow you to speak text as well.  

Typically, all of an individual’s pages will be in one configuration.  Evaluation sites or schools might choose to have more than one configuration set up if they are working with a number of different clients with the same device.  The device comes with two standard configurations installed.

2.2. Modifying the Included Standard Configurations

The VocabPC and Symbol-Base configurations are included with ChatPC.  Either of these configurations can be used as the basis for a complete communication system.  This will require adding pages and modifying existing pages to include the required vocabulary.  To do this:

· tap on the File Menu

· tap on Standard Configs
· choose either the Symbol-Base or VocabPC standard configuration. (it will take a moment for the config to load)

· tap on the File Menu

· tap on Configurations
· tap on Save Config As…(you will be asked to name the new configuration)

· begin typing a new name for your users configuration (i.e. users name)

· tap on OK (upper right corner)

Your new configuration is ready for editing, see section 2.4.

Your new configuration will now show up under the File menu User Configs item.  i.e.
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Note:  The ChatPC will automatically make a backup of your configuration.  These backup configurations will only be used for troubleshooting purposes.

2.3. Creating New Configurations

In addition to modifying existing configurations, you can create new configurations from scratch.  

· select the File menu

· tap on the Configurations item  (this will display several options related to creating, saving, and loading configurations)  

· select New Config  (you will be asked to name the new configuration)

· Begin typing a new name for your users configuration (i.e. users name)

· Tap OK (you will be asked for the name of the first page of the configuration and the size of the button grid (for example, "3x4" means 3 columns and 4 rows) 

Page names are important for configurations with multiple pages since they provide a way to navigate from one page to another. By default, the name “Page 1” will be assigned to the first page of your new configuration. If you want to give the page a more descriptive name (like “Food” or “Medical care”), enter this name in the New Page Name box. 
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You can also select the number of buttons that appear on a page using the Page Type list. The available grid sizes are 2x2, 2x3 No Labels, 3x3, 3x4, 3x4 Small Symbols, 4x4, 5x5, 1x4 Phrase, and 2x6 Phrase. The first number represents the number of button columns and the second the number of button rows. Most pages are designed for use with pictures and icons, and have buttons which are more-or-less square. The 2x3 No Labels configuration has buttons that are too squat to include both text labels and symbols. The Phrase pages are designed for showing longer text sentences, and have buttons which are much wider than they are tall. Pictures cannot be displayed on these Phrase buttons. You can mix pages with different grid sizes in a single configuration.

After you tap OK , ChatPC will create your first page. You will see a grid of blank buttons. 

2.4. Editing a Configuration

After you create and save a new configuration, you can edit it at any time. If it isn’t already, load the configuration:

· tap on the File Menu

· select User Configs and choose your configuration
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You can now go into Edit Mode by:

· tapping on the View menu

· choosing Go to Edit Mode
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In Edit Mode you will see a flashing red box around the window to remind you that you are editing the configuration. 

2.4.1.Edit Mode Toolbar

When editing a configuration, a different toolbar will be displayed.  The Page Control drop-down list allows you to change the page that is currently being edited.  To the right of the list, the Add Page button pops up the Add Page menu.
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2.4.2. Previewing Buttons (in Edit Mode)

If you’re in edit mode and you want to try out a button to see what it says or does, simply tap once on it.  After a short pause (less than a second), the button action will be previewed.  When previewing, make sure that you tap and release in the same spot so that the program doesn't think you're trying to drag and swap the button.  Also, don’t tap and hold for too long or the cut/copy/paste pop-up menu will appear.

2.4.3. Navigating Between Pages (in Edit Mode)

There are three ways to switch to a previously existing page from edit mode.  

1. You can use the drop down list embedded in the toolbar at the bottom of the screen.  This list allows you to quickly access any page in the configuration.  

2. You can also 

· tap the View menu

· choose Page Editing

· choose the Go to Page menu item  

3. Alternatively, you can tap on a navigation button in the configuration and you will be taken to the page indicated by that button.

2.4.4. Finished Editing  

To return to Run Mode and test your changes

· tap on the View menu

· choose Go to Run Mode
If you changed the configuration at all, you will be asked if you want to save the changes you made.  If you tap Yes, the configuration will be saved to the filename you specified when you first created (or loaded) the configuration.  If you tap No, the changes you made while in Edit Mode will remain, but the configuration will not be saved to a file. 

Note:  Make sure to save your configuration before loading or creating a new configuration or exiting ChatPC! If you don't, you will lose any changes you made since the last time it was saved. 
· tap on the File menu
· choose Configurations
· choose Save Config menu item to force ChatPC to save the latest version of your configuration

2.5. Editing a Button

When in Edit Mode, you can edit a button by quickly tapping twice on it.  After you do this, the Button Properties dialog will open.  

This dialog has 4 tabs named Labels, This Button, All Buttons, and Advanced.  The controls on the Labels tab are used to configure what appears on the button and what the button does.  Those on the This Button tab control how the button looks – its font, font color, body color, and border color.  The controls on the All Buttons tab provides the means to change the look of all the buttons in a configuration.  Finally, the Advanced tab allows you to set the page color and button shapes.

The Preview box is shared by all four tabs of the Button Properties dialog.  This area of the dialog shows the current appearance of the button, including labels, pictures, fonts, and colors.  On the Labels tab, if you tap on the button preview you'll see what the button looks like when you select it.

After you make changes to a button, tap the OK button to return to page editing mode.  If you tap the X button instead, any changes you made to that button will be lost.
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2.5.1.Setting an Action

The Action control determines exactly what happens when you tap on a button in the interface.  For example, you may want to set up one button to speak its text label, another button to play a pre-recorded message, and another button to change the active page.  To set the button action, simply choose one of the drop-down list items described below.

The simplest Action setting is Speak Label.  When this option is selected for a button, ChatPC will use DECtalk to read the button's text label whenever it is tapped.  Additionally, the label text will be inserted into the editor window.  The text label is defined using the Label slot.  In some cases you may want the message associated with a button to be different than the text that is shown on the button.  For example, you might want to label the button "Dinner" (or have no text label, but just a picture of a meal) but have ChatPC say "I would like some dinner." when the button is tapped.  The Speak Message setting allows you to do this.  The spoken message is defined using the Message slot.  If you want ChatPC to speak a button’s label or message, but not put any text in the editor, use the Say Label or Say Message action.

If you want the button to play a recorded audio message (digitized speech) rather than speak a label or a message, select the Play Audio option.  You can then use the Browse button to the right of the Audio slot to select the sound file that you want to associate with the button.

If you would like to use the button to navigate between different pages in the configuration, select the Navigate action.  You can then use the Navigate drop-down list to specify the page to be associated with the button.  A Visit action is similar to a Navigate action, but means “go the indicated page, but come back to the current page after you’ve selected a button on that page.”  The Visit action is used to set up temporary pages that behave like pop-up pages.  A button with a Navigate or Visit action is represented visually as a stack of papers with their corners folder over.  A Visit button has an additional arrow in the upper right or lower right corner to differentiate it from a Navigate button.

The final Action option is Control.  A button of this type can be used for editing commands or to control the speech output of ChatPC.  Use the Function drop-down list (in the same location as the Navigate drop-down list) to choose the particular control function of the button.

2.5.2. Setting a Secondary Action

For buttons with Speak, Say, or Play Audio actions, you can set up a “secondary action”.  This is a navigation action that will take place after the standard button action.  You might, for example, set up a button to speak “I would like some” and give it a secondary navigation action that will send the system to a page with food items.  The Second Action drop-down list is used to set the secondary action.   If you set this action to Navigate or Visit, you can then set the destination page using the Navigate/Visit drop-down list.  In our food example, we might have preferred to use a Visit secondary action rather than Navigate – after selecting the food item we’d be sent back to the page we started on (the page with the “I would like some” button).

You can also set the secondary action to Stay. When a button has such a secondary action, it is “immune” to automatic page changes like those initiated when you Visit a page. For example, we might set up a Visit page to fill in the blank for “I feel ______”. This page might have buttons with adjectives like “good” or “happy”. We might also want to put a button with a modifier like “very”. Since we want to be able to select the “very” button without returning from the Visit (so that we could say that we are “very happy”, for example), we would assign it a Stay secondary action.
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Secondary actions: Navigate, Visit, and return from Visit

A button with a Navigate or Visit secondary action will have a small right-pointing arrow in the upper or lower right-hand corner (depending on where the button label is), as indicated in the  Figure above.  An arrow on a white background indicates a Navigate secondary action. An arrow on a gray background with a left-pointing inset arrow indicates a Visit secondary action. After navigating to a page through a Visit button, all the buttons on that page will have left-pointing arrows in the upper or lower left-hand corner indicating that selecting a button will return you to the previous page. If a button on the Visit page has a secondary action of Stay however, it will have no left-pointing arrow.

By default, a button with a Navigate or Visit secondary action will have a small right-pointing arrow in the upper or lower right-hand corner (depending on where the button label is). An arrow on a white background indicates a Navigate secondary action. An arrow on a gray background with a left-pointing inset arrow indicates a Visit secondary action. After navigating to a page through a Visit button, all the buttons on that page will have left-pointing arrows in the upper or lower left-hand corner indicating that selecting a button will return you to the previous page. If a button on the Visit page has a secondary action of Stay however, it will have no left-pointing arrow. You can turn off the arrows by checking the Hide Arrows button on the Advanced tab of the Button Properties dialog (see section XXX, page YYY). Turning off the arrows can be helpful when you’re using very small buttons.

2.5.3.Editing the Button's Label

Regardless of the Action associated with a button, you can always edit its text label by entering text in the Label slot.  If there is a picture on the button, the label text will appear at the bottom of the button.  If there is no picture, the text will be centered in the button.  Note that when you create a Navigate or Control button, a default label like "Back" or "Clear" may appear in the Label slot.  You can edit this label if you wish.  If the Action is Speak Label, then the button label will be spoken when the button is activated.  If the Action is anything else, then the button label merely serves as reminder of the button function.

2.5.4. Editing the Button's Message

If the button Action is Speak Message, then you can enter the spoken message for the button in the Message slot.  The message will not appear anywhere on the button – the Label slot is used to specify text that is supposed to appear on the button.  If the Action is anything other than Speak Message, you will not be able to edit the Message slot text.  A message may not be longer than 448 characters.

2.5.5. Changing the Button's Picture

You can pick the symbol that will appear on the button by tapping on the Browse button to the right of the Picture slot.  The Symbol Selection Dialog will be presented and provide a means to select from the available symbols on your machine. For Control buttons, a pre-defined symbol is used but is able to be changed just like you can on any other button.   See Symbol Selection (section 2.5.14) for additional details.  If the button label is blank when you select a symbol, that symbol’s name will be inserted in the Label field.  If the label wasn’t blank, but you would like to use the symbol name rather than the current label, just tap on the Picture field (the name of the symbol) and the label will be replaced.  

For future expansion, ChatPC can support additional symbol sets. Contact us for the latest symbol availability and pricing information. When additional symbol sets are installed, they are accessible through the Symbol Selection dialog by selecting Up a Folder from the symbol list until this choice is no longer available. At this point, you will see a list of the three default symbol sets—Custom, Enkidu, and MJ (the Mayer-Johnson color PCS symbols)—plus any other installed sets. To browse through the pictures, tap the name of the symbol set.

To add custom pictures to your ChatPC vocabulary go to the Importing Images section, 7.4.

2.5.6. Setting up a Navigation or Visit Button

If you would like to use the button to navigate between different pages in the configuration, select the Navigate action.  

A Visit action is similar to a Navigate action, but means “go to the indicated page, but come back to the current page after you’ve selected a button on that page.”  The Visit action is used to set up temporary pages that behave like pop-up pages.  

A button with a Navigate or Visit action is represented visually as a stack of papers with their corners folder over.  A Visit button has an additional arrow in the upper right or lower right corner to differentiate it from a Navigate button.

When a button Action is set to Navigate or Visit, you can use the Navigate/Visit drop-down list to determine the page to which a button tap will transport you.  All of the pages in the configuration are listed by name.  In addition, you will find two special entries – Back and Home.   The Back navigation command tells ChatPC to return to the page that you were on before coming to the current page.  The Home command tells the system to return to the very first page in the configuration (the home page).  You can change the home page by:

· tapping the View menu

· tapping Page Editing

· choose the Set Home Page option from the menu

When a button Action is set to Navigate or Visit, use the Navigate/Visit list to determine the page to which a button tap will transport you. All of the pages in the configuration are listed by name. In addition, you will find three special entries – <Back>, <Home>, and <New Page>. The <Back> navigation command tells Portable IMPACT to return to the page that you were on before coming to the current page. The <Home> command tells the system to return to the very first page in the configuration (the home page). You can change the home page by selecting View > Page Editing > Set Home Page. 

The <New Page> navigation command tells Portable IMPACT to create a new page and link the current button to that page. When you select  the <New Page> entry, you will be asked to provide a name and button layout (the number of rows and columns in the button grid) for the new page. See section XXX (page YYY) for more details on creating new pages. If for any reason you don’t actually want to create a new page, select Cancel.
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Secondary actions: Navigate, Visit, and return from Visit

A button with a Navigate or Visit secondary action will have a small right-pointing arrow in the upper or lower right-hand corner (depending on where the button label is), as indicated in the Figure above.  An arrow on a white background indicates a Navigate secondary action. An arrow on a gray background with a left-pointing inset arrow indicates a Visit secondary action. After navigating to a page through a Visit button, all the buttons on that page will have left-pointing arrows in the upper or lower left-hand corner indicating that selecting a button will return you to the previous page.

2.5.7. Setting Control Actions

When you set the Action to Control, you will have to select a Function from a choice of different control types (the Function list is displayed in the same place as the Navigate list). Brief descriptions of each type of control are provided below. Some of these control types have pictures associated with them. You can change these pictures, just like you can on any other button.

Edit: Backspace: Delete previous character.

Edit: Backword: Delete previous word.

Edit: Clear: Clear the contents of the Editor Window.

Edit: Redo: Reinstate any action undone using an Edit: Undo command.

Edit: Undo: Undo the last action.

Speak: All: Speak the contents of the Editor Window.

Speak: Pause: Temporarily pause speech immediately, resuming with second button activation.
Speak: Sentence: Speak the last sentence appearing in the Editor Window.

Speak: Stop: Halt speech immediately.

Volume Up & Volume Down: Increase or decrease system volume.

2.5.8.Using Recorded Messages

If the Play Audio action is selected, you can change the audio clip associated with a button by choosing the Browse button to the right of the Audio slot.  A dialog for selecting the sound file (in wav format) will pop up.  Tap on one of the sound files and then hit OK to select it (or just tap twice quickly on the file).  If you want a preview of the file before selecting it, tap once on the file and then tap on the Preview button.  If you want to record a new sound file, tap on the Record button and the Sound Recorder dialog will appear.  See the next section for instructions on how to use this dialog to record wav files.  As with pictures, if the button label is blank when you select an audio file, that file’s name (minus any extensions) will be inserted in the Label field.  You can tap on the Audio field to manually force the label to be the same as the file name.

2.5.8.1. Sound Recorder Menu

The Sound Recorder menu allows you to record digital sound files right on your ChatPC.  This dialog can be accessed when browsing for a sound file to include on a button with a Play Audio action (see Using Recorded Messages, above).  The sound files that you record on the device are stored on the same memory card on which your configurations are stored, so you must be careful not to use up all your available memory.  The Time field shows how long a sound clip you can record at the quality set with the Speech Quality drop-down list.  You will be able to record more speech at Low quality than you can at Medium quality, and more at Medium than you can at High.  For most people, the Low or Medium settings provide more than adequate speech quality.

[image: image26.png]Chatpc 14p @R

Sound Recorder

avalable Record
Tie (hr:min:sec) Speech Qualty:

Rec Time (sec) File 526 (bytes):





To record speech, simply select the desired Speech Quality and tap on the Record button.  ChatPC will immediately begin to record sound through the device’s built-in microphone.  As you record, the Rec Time field will show how long the speech clip is, while the File Size field will show the size of the clip.  The Time field will also change to show how much more speech you can store on the memory card.  Tap on Stop when you’re done recording.  You can listen to what you’ve recorded by tapping on the Play button.  Once you’re happy with a recording, enter a name for the speech clip in the Filename field and then tap OK.

The microphone is located at the top of the ChatPC where the speaker connector plugs into IPAQ.  To record the best digitized speech you may want to practice a bit with different speaking volumes and distances from the microphone.  Try to record speech in a quiet environment.  To avoid clicks at the start and end of a speech clip, try leaving brief pauses (roughly half a second) before and after you speak (tap Record, pause, speak, pause, tap Stop).

With your PC Editor, you can use any .wav file as audio to be spoken. On your computer, copy the .wav files to the 

C:\Program Files\Saltillo\ChatPC Editor\Sounds\Custom directory.  You can then add the sound to a key from the Play Audio dialog.  Then transfer the configuration to your ChatPC by:

· tapping  the Tools menu

· tapping Transfer Utilities

· choosing Transfer Files. 

See section 4.3.1.1. for details.  Remember that sound files automatically get copied to your device whenever you transfer the configuration that uses them.

2.5.9. Clearing a Button's Contents

If you want to restore the action, label, message, audio, and picture of a button to its default state, tap the Reset button. Be careful when selecting this option—you will lose any previous changes you had made to the button. If you only want to erase the picture on a button, use the Clear button.

2.5.10. Editing the “Next” Button

Once you have completed editing the current button, you can start editing the “next” button on the page by tapping the Next button. The button order is just like word order in reading – left-to-right and top-to-bottom.  The “next” button is the one that appears right after the current button on the page. Tapping the Next button is exactly the same as tapping the OK button and then double-tapping on the next button to edit it (except much more convenient!).  Note that after you use the Next button, any changes you made to the “previous” button cannot be undone.

2.5.11. This Button Tab: Changing the Appearance of a Single Button

You can change the Font, Font Color, Body Color, and Border Color of the button using the controls on the This Button tab.  Simply use the pull-down lists to select the font or color you want for the button.  The available  fonts range from 11 point (extremely small) to 40 point (extremely large).  A wide range of colors is available.  If you're planning to use symbols on the button, you will probably want to use a light color – the symbols don't look as good on dark backgrounds.  The "Pale" and "Wash" colors work best.

The fonts or colors you set on the This Button tab will override any default settings you make on the All Buttons tab.  If you would prefer the button to use a default font or color setting, you'll need to choose the Default option (available through the drop-down lists) for that setting.  Alternatively, you can tap on the Use Defaults button to reset all the button settings to the defaults specified on the All Buttons tab.

If you don’t want a button to appear on the page at all, you can check the Hide Button box. After checking this box, the button preview will be replaced with the word “Hidden”. When you exit out of the Button Properties dialog, you’ll find that the button has disappeared from the page. The button is actually still there – you can still select and edit it – but it will be both invisible and unselectable once you return to run mode. If you want to restore a hidden button, simply uncheck the Hide Button box.
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2.5.12. All Buttons Tab: Changing the Appearance of All Buttons

If you don't specify a font or color or border width for a button, it will use the default button appearances that are specified on the All Buttons tab. If you’ve defined a non-default value for a setting on the This Button tab, you will be unable to change the setting on the All Buttons tab. If you want the button to use the default appearances provided with ChatPC, tap the Use Defaults button. 

NOTE: Selecting the defaults will not change any override settings you made on the This Buttons tab.
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2.5.13.Advanced Tab: Changing the Features of the Current Page

The controls on the Advanced tab are used to change page features (such as colors) and advanced button properties (such as shape and label position). You can change the background color of the current page using the This Page Color list. The Default Page Color control is used to set the default background color for all pages. If This Page Color is set as <Default>, the Default Page Color will be used for the current page.

The Default Button Style control allows you to set the form of the buttons. You can choose from rectangular (the default), raised, rounded, and beveled. If you select beveled, you will be unable to change any of the button colors—the colors are fixed for this style.

By default, button labels appear below the button symbols. If you want the labels to appear above the symbols, tap the Swap Label Pos button. Tapping the button again will restore the labels-below-symbols layout.

By default, a button that has a secondary action will include a small arrow in a box in the upper corner of the button. This graphic is designed to remind the user of the button’s secondary action. For some users, however, the arrows may be distracting or confusing. The arrows can be disabled by checking the Hide Arrows button.
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2.5.14. Symbol Selection 

Invoked from the Labels tab of the Button Properties Dialog, the Symbol Selection Dialog provides a convenient method for previewing and selecting an image for buttons (see diagram, next page).  You will be able to select one of over 3900 images in the Mayer-Johnson symbol set.

The left portion of the Symbol Selection dialog provides a navigable folder structure for exploring the various symbol categories.  Tap once on the folder to navigate into that folder and see the symbols stored there.  A symbol can be previewed by tapping once on the name in the symbol list.  The text box below the symbol list shows the folder to which the preview symbol belongs.  With the PC Editor (or with an external keyboard attached to the ChatPC device), you can use the keyboard’s arrow keys to quickly step through previews of the symbols.  Tapping the OK button selects the previewed symbol and exits the dialog.  Alternatively, you can double tap a symbol name to select that symbol.  

The Symbol Selection Dialog also has a search feature that allows you to type in the name or partial name of a symbol or item you are looking for.  The symbol search engine will identify all the matching symbols or categories and display the results in the symbol list on the left.  Simply type the word or string in the Search slot and then tap on the Search button.  Tap on the Browse button to return to symbol browsing.
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You can import or paste your own pictures using the PC Editor.  See section 7.5 for details.

2.6. Swapping Two Buttons

You can quickly rearrange the layout of buttons on a page using "drag-and-drop swapping".  This procedure allows you to swap the contents of two buttons.  Tap on the first button with your stylus (or finger) and hold it on the screen, drag the button over the top of the second button, then lift the stylus from the screen.  The contents of the two buttons will be immediately swapped.  While you are dragging the button you will see a rectangular outline of the button moving along with the stylus.  The first button will appear in its select state, as will the button your stylus is currently over.  If you lift the stylus when it's not over any button or it's over the first button, no swap will occur.

2.7.Cutting, Copying, and Pasting Buttons

In many popular Windows applications clicking on the right mouse button will popup a menu that provides quick access to common commands.  ChatPC has popup menus to help you with editing.  In the PC Editor, simply move the mouse over a token and click the right mouse button.  Because there’s no right mouse button on ChatPC devices, you’ll need to access the popup menu in a different way.  Tap on a token and hold the stylus (or your finger) against the screen without moving.  After about a second, you’ll see the popup menu.  Remember not to move the stylus or you’ll start a “drag-and-swap” operation.  This may sound a little difficult, but we think you’ll find it pretty easy, especially after a few tries.

Once the popup menu is open, you’ll see some familiar options.  Select Copy Button to copy the contents of the current token into a clipboard, or select Cut Button to copy the contents and then reset the token to a blank state.  Once you’ve copied or cut a token, you can move to another token and select Paste Button.  As you’d expect, the contents of the token you copied (or cut) will appear.  Be careful – there’s no way to undo a paste operation.  If you don’t want to copy the graphics or text of a button, but just want to copy its appearance (body color, border color, font color, and font – the features you can set on the This Button tab of the Button Properties Dialog), select Paste Look.  If you select Clear Button, the token contents will be erased but they will not be copied to a clipboard (meaning that you can’t paste the cleared token somewhere else later).  Finally, the Edit Button menu item is equivalent to double-tapping the button – the Button Properties Dialog will appear so that you can edit the button.

If you select Clear Button, the token contents will be erased but they will not be copied to a clipboard (meaning that you can’t paste the cleared token somewhere else later). The Edit Button menu item is equivalent to double-tapping the button – the Button Properties dialog will appear so that you can edit the button.

You can hide (or show) individual buttons using the Hide Button (or Show Button) popup menu items. This is the equivalent of checking (or unchecking) the Hide Button box in the This Button tab of the Button Properties dialog (see section 4.20.10, page 81). A hidden button will be invisible, but can still be selected while in edit mode. In run mode, a hidden button is both invisible and unselectable.

The popup menu also includes an Undo entry that will allow you to reverse the effects of the last button editing command. This menu item is only enabled for the single button that was most recently edited. After you have used Undo on a button, you can use Redo to restore the button changes. The Undo and Redo options will not work if you change pages or if you leave Edit Mode and then return.

In the PC Editor, you can use the familiar Windows shortcuts to cut, copy, and paste the contents of the buttons, and to undo the previous action. Move the mouse over the target token and press Ctrl-C to copy, Ctrl-X to cut, Ctrl-V to paste, Ctrl-V to paste, and Ctrl-Z to undo or redo the last action. Additionally, you can use Ctrl-B to perform the Paste Look function and Ctrl-H to hide (or show) a button. These shortcuts really come in handy when you’re doing a lot of cutting and pasting. 


If you’re using the PC Editor, you can put the mouse over a button and use the PC keyboard to append text to the button label (and message) without having to go into the Button Properties dialog. Tapping the Enter key will erase the label of the button.

2.8. Pages
You must be in Edit Mode (flashing red box around window) to Add or Modify a Page:

· tap on the View menu

· choose Go To Edit Mode
2.8.1. Adding a New Page

Pages are levels of specific vocabulary linked together to create a vocabulary set (configuration) specific to the device user.  

To add a new page to a configuration you can either select the Add Page icon from the toolbar
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or 

· select the View menu
· choose Page Editing

· choose the Add Page menu item. 
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In either case, a dialog will pop up and request information about the new page. You can type out a name for the new page or use the default name suggested by ChatPC.  Page names are important for configurations with multiple pages since they provide a way to navigate from one page to another. By default, the name “Page 1” will be assigned to the first page of your new configuration. If you want to give the page a more descriptive name (like “Food” or “Medical care”), enter this name in the New Page Name box. 
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You will also have to select the number of buttons that appear on a page using the Page Type list. The available grid sizes are 2x2, 2x3 No Labels, 3x3, 3x4, 3x4 Small Symbols, 4x4, 5x5, 1x4 Phrase, and 2x6 Phrase. The first number represents the number of button columns and the second the number of button rows. Most pages are designed for use with pictures and icons, and have buttons which are more-or-less square. The 2x3 No Labels configuration has buttons that are too squat to include both text labels and symbols. The Phrase pages are designed for showing longer text sentences, and have buttons which are much wider than they are tall. Pictures cannot be displayed on these Phrase buttons. You can mix pages with different grid sizes in a single configuration.

After you tap on OK a blank page will be created and you will be back in Edit Mode ready to edit each button.

2.8.2. Duplicate a Page

This feature is handy when building symbol configurations where you would like the same buttons to be displayed on every page. Create a page with the buttons that will be on every page, and duplicate that page as many times as you would like. Then go back to each page and fill in the remaining buttons.

If instead of creating a blank page you want to create a copy of the current page:

· Be sure the page that you want to duplicate is showing (You can use the drop down list embedded in the toolbar at the bottom of the screen.) 

· tap the View menu

· choose Page Editing
· choose the Duplicate Page menu item

You can specify a page name for a duplicated page, but you cannot specify a page type – it must be of the same type as the page that is being copied.  After tapping on OK, you will be returned to edit mode on the new page.  Because you duplicated the page you were on, it may not look like the screen changed at all.  However, you can identify the current page by looking at the page name shown on the edit toolbar.


2.8.3. Importing and Exporting Pages

You might want to share pages with another person, or between configurations. ChatPC provides you with a method to save one or more pages to a file (to “export” the pages) so that these pages can be loaded into another configuration (“imported”). To export a series of pages to a file, go into Edit Mode by: 

· selecting the View menu
· choose Go to Edit Mode
· select the View menu again
· choose Page Editing 

· choose Export Pages 

You will then see a list of all the exportable pages in the current configuration. Tap all the pages you want to store. The pages you select will be highlighted. To unselect a page just tap it a second time. 
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When you’ve selected all the pages that you want to export, tap OK. You will then be asked to enter a name for the pages file. Enter a descriptive name and tap OK.

To import pages from a file:

· select the View menu

· choose Go to Edit Mode
· select the View menu again

· choose Page Editing

· choose Import Pages 

· select a file from the resulting list of page files

· tap OK
After a few seconds, the specified pages will be available in your configuration. Of course, to use these pages you will need to add navigation links from the original pages so that you can get to them. For more information about adding Navigation links, see section 2.5.6.

When you import pages, some of the imported page names may be identical to existing page names. To differentiate the new pages from the old pages, ChatPC will automatically append a number to the new page names. For example, if you had a “Greetings” page in a configuration and imported a page with the same name, the name of the imported page would be changed to “Greetings 1”. A dialog will appear to tell you of the change. After the page importing process has completed, you can change the name of the new pages by: 

· selecting View 

· Page Editing 

· Rename Page
3.  Customizing Configurations

· Speech

· Pronunciation

· Text editing

· Access

· Appearance of the Window

· Locking and Unlocking Configurations

· Hardware Buttons

· The PC Editor
3.1. Speech 

ChatPC currently supports speech synthesis through the DECtalk™ Software.  You can use the synthesizer to speak individual characters, words, phrases, or sentences.  Or you can select exactly what and when you want to speak.  The Speech menu is accessed by:

· selecting the Tools menu

· choosing Options
· tapping on the Speech tab
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3.1.1. Synthesis Type Section

ChatPC supports speech synthesis through software (via the DECtalk™ Software).  Speech synthesis can be disabled by checking the None button.

3.1.2. Voice Section
ChatPC can use the DECtalk™ Software speech synthesizer to produce speech.  You may choose between one of 9 different voices provided by the synthesizer using the Voice pull-down list.  The available voices are:



Paul

Adult male



Betty

Adult female



Harry

Large-voiced adult male



Frank

Elderly adult male



Dennis

Deep-voiced adult male



Kit

Child



Ursula

Elderly adult female



Rita

Husky-voiced adult female



Wendy

Whispering adult female

The Preview button will allow you to hear a sample of the voice that is selected to help you decide which voice you would prefer to use.  The sample says, "Hello, my name is _____.  Would you like me to be your voice?”

If you are using the PC Editor, you will not have access to DECtalk voices (unless you happen to have installed them yourself on the PC).  If there are any “SAPI” voices on your computer, you should be able to select them from the Voice pull-down list.  If you’re having trouble with SAPI voices, try a Microsoft voice (which will have a “[MS]” after it).  

3.1.3. Speak Section

You can configure ChatPC to speak after every character, every word, every phrase, or every sentence (or any combination of these settings).  In addition, certain configurations may provide “Speak Sentence” buttons right within the interface window.  The speech modes are set by checking on the appropriate box (Character, Word, Phrase, and Sentence).  You can also set the speaking rate, in words per minute (wpm) for each mode of speech.  Generally, you’ll want to have faster rates for shorter utterances.  Thus the character rate should be faster than the sentence rate.

3.1.4. Volume Section

The loudness of all synthetic speech can be set using the Volume slider.  The volume specified here overrides the system volume (the PocketPC volume).  

NOTE:  The speaker volume can also be adjusted using the volume control on the right side of the ChatPC or by adding volume control functions to buttons on vocabulary pages.

3.2. Pronunciation Editor 

ChatPC uses DECtalk speech synthesis to provide you with your voice.  The program knows how to pronounce most words, but you'll occasionally find words that are mispronounced. To help DECtalk out with these words, ChatPC uses a pronunciation table, which stores information on their correct pronunciations.  You can add, delete, and modify the word pronunciation table using the Pronunciation Editor.  To access the Pronunciation Editor:

· Tap on the Tools Menu
· Choose Pronunciation Editor
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3.2.1.  Adding New Pronunciations

To add a new pronunciation for a word, tap the Add button.  A new popup dialog will appear.  Type the word for which you want to specify a new pronunciation in the slot labeled Word.  The word cannot contain any spaces or punctuation other than hyphens or apostrophes.  Then spell out the pronunciation in the slot labeled Pronunciation.  For example, for "Craig" you might use "Creg", and for "orchestra" you might use "orkestra".  If you're familiar with DECtalk phonemes, you can use those too – just place the pronunciation within brackets ([]).  You can hear the default DECtalk pronunciation of the word by tapping on the Try Original button, and you can hear your new pronunciation by tapping on the Try Pronunciation button.  You may have to try several different pronunciations to find one that's satisfying.  Once you're content with the new pronunciation, tap the OK button.  The new word and its pronunciation will appear in the list.  If you want to change the pronunciation, you can edit it using the Edit button.

3.2.2. Editing Existing Pronunciations

To edit the pronunciation of a word already in the pronunciation table, tap on it in the pronunciation list then tap the Edit button.  The same popup dialog used for entering a new pronunciation will appear, with the Word and Pronunciation fields already filled in. You will not be able to change the Word field, but you can of course edit the pronunciation (and use the Try Original and Try Pronunciation buttons).  When you are done editing the pronunciation, tap the OK Button.  The modified pronunciation will appear in the pronunciation list.

3.2.3. Removing Pronunciations

You can remove an entry from the pronunciation table by first selecting the word from the pronunciation list, then tapping on the Remove button.  This pronunciation exception will be permanently deleted from the system, so use caution when using this option.

3.2.4. Restoring the Default Pronunciations

You can restore the pronunciation table that ships with ChatPC by opening the Tools menu and choosing System Utilities > Reset User Files.

WARNING: If you select this option, all changes that you made to the pronunciation table will be irretrievably lost. You can only select this option when there is no configuration loaded into ChatPC.

3.3. Text Editing

The spacing between words, symbols, and punctuation marks is very predictable in typed English.  For example, after a comma there is generally a single space before the start of the next word.  After a period, however, there are usually two spaces before the next sentence starts.  If you enable autospacing, ChatPC will insert the correct number of spaces after punctuation marks.  It knows about special cases like “Mr. Rogers” and “8.32”, where the period should not be followed by two spaces.   Check the Auto-space and auto-caps box to enable automatic spacing.

Capitalization in English is also very predictable.  If you check the Auto-space and auto-caps  box, ChatPC will also capitalize the first word in each sentence for you.  As with auto-spacing, the system knows about common special cases like “www.saltillo.com”, so you don’t have to worry about autocapitalization mistakes.  In those rare cases where ChatPC capitalizes a letter that you wanted to remain lower case, simply press the Undo button or backspace over it and retype the letter – the lower-case version will appear.

To change the text editing setting:

· tap on the Tools menu

· choose Options


· tap on the General tab

· remove the check in front of Auto-space and auto-caps (the device is shipped with this function on)
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3.4. Accessing the ChatPC,  Help for Users Who Have Trouble Selecting Buttons or Keys

Some people who use ChatPC may have trouble reliably selecting individual buttons or keys due to tremors or lack of fine movement control.  To assist these individuals, we've included several different methods of "filtering" user input to make selections more reliable.  The StickyKeys feature allows you to enter shifted characters by tapping the shift key and then the character (rather than tapping them simultaneously).  The FilterKeys options help prevent you from accidentally selecting the same button twice (due to jitter or to holding the button down too long).  They also help to prevent selections caused by accidentally brushing the screen or keyboard while trying to select a button.  To set up ChatPC's input methods:

· tap on the Tools menu

· choose Options  
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3.4.1. Configure Touchscreen

ChatPC provides 3 different modes of touchscreen input: Select on Push, Select on Release, and Touch Dwell. To choose a mode, select Tools > Options, then tap the Configure button next to the Touchscreen check box. 

· In Select on Push mode the button will be selected when you first touch the button. The button will not go back to its normal appearance until you release the button.

· In Select on Release mode you can touch anywhere on the screen and drag your finger (or stylus) around until you are on the button you want. A “focus” indication box is drawn around each button as you drag your finger over it. This focus box shows you which button will be selected when you release. Releasing on the desired button will select it.

· In Touch Dwell mode, a button is not selected until you have held your finger on it for a certain period of time. You can set the Dwell Time using the numeric control in the dialog. As with Select on Release, a focus indication box is drawn around the button you are currently touching. 

NOTE: The Touch Dwell mode allows for dwell selection in the configuration window (where the buttons are displayed) and in the Editor Window, but does not allow for menu and toolbar selections.

The Set Color button in the focus indication section allows you to set the color of the focus indication box that is drawn while in Select on Release or Dwell mode. If the Dwell Click button is checked, a “click” sound will occur whenever a button is chosen using Dwell selection.

By default, if you tap on the editor window, ChatPC will speak the contents of the editor. If the system is already speaking when you tap on the editor, it will stop speaking. This behavior can be disabled by unchecking the Tap Editor to Speak box. When this button is unchecked, tapping the editor window will have no effect on the system.
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3.4.2. Configure Input Filtering

Selecting the desired on-screen button may be difficult for some individuals due to tremors or limited fine motor control.  This dialog has controls that will configure the touchscreen to filter out unwanted inputs.

You can then tailor the input filtering options by pressing the input filtering Configure button.
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3.4.3. StickyKeys

If you check the StickyKeys box, the system will allow you to enter shifted (or controlled) characters by first pressing the shift key and then pressing a character key.  Without StickyKeys set, you have to press the two keys simultaneously.  For touchscreen input, StickyKeys will always be turned on, regardless of the setting in this dialog.

3.4.4. FilterKeys

NOTE:  The FilterKeys settings will affect touchscreen input.  However, input from the optional KeySync external keyboard will not be affected if FilterKeys is set to Ignore quick input and slow down repeat rate.

For additional control over touchscreen input, including button “debouncing”, tap on the FilterKeys checkbox.  If Ignore repeated input is checked then you will have debounce control through the BounceKeys section (see below).  If, on the other hand, Ignore quick input and slow down repeat rate is checked, then you will have control over the repeat rate (through the RepeatKeys section) and will be able to set the minimum time a button must be depressed before it is selected (through the SlowKeys section).

3.4.5.RepeatKeys

You can disable repeats using the No repeat button or enable them using the Slow down repeat button.  If the latter is selected, you can set the amount of time (in seconds) that must pass between the time the button is initially pressed and the time it starts repeating using the Repeat delay control.  Once the minimum repeat delay has elapsed, the time (in seconds) between each repeat is set using the Repeat rate control.  To access any of the controls in the RepeatKeys section, you must have checked the FilterKeys box and the Ignore quick input and slow down repeat rate button in the FilterKeys section.

3.4.6. SlowKeys

To prevent accidental key presses from activating a key, you can set the minimum time that a key must be depressed before it registers.  This is done using the Keys must be held down for control. The default delay time is 1 second.  You can change the delays in increments of 0.1 seconds (100 milliseconds).  To access the control in the SlowKeys section, you must have checked the FilterKeys box and the Ignore quick input and slow down repeat rate button in the FilterKeys section.

3.4.7. BounceKeys

By setting the Ignore inputs faster than control, you can prevent the system from responding to accidental keyboard presses that follow one another very quickly.  To access the control in the BounceKeys section, you must have checked the FilterKeys box and the Ignore repeated input  button in the FilterKeys section.
3.5. What Appears in the Window

3.5.1. Editor Window
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For some configurations, you may not want to have a visible editor window.  You can toggle the existence of this window by:

· selecting the View menu

· selecting Main Editor  

Even when the editor window is not showing, the message you produce will still be entered into the window – it just won’t be visible until the window is enabled again.

The editor window displays the text that you’ve entered using ChatPC.  As described above, you can eliminate the editor.  You can toggle between vertical and horizontal scrolling mode (see below).  The size of the text that appears in the window can be changed using the Font Size toolbar button.  Tapping anywhere in the editor (except the scroll bar) will cause ChatPC to speak the entire contents of the editor window.  A second tap will stop the speech.

When editing a configuration, you can make the editor window taller or shorter by tapping on the horizontal “splitter bar” right below the editor and dragging the stylus up or down on the screen.  Pull the stylus away from the screen when the editor window is the desired size.  

The editor window can operate in two different modes.  With Horizontal Editor turned off, text that is displayed in the editor will fill the editor from left to right until it reaches the right edge.  When there are too many characters to fit on a single line (at the current font size), text will start appearing on the next line and if necessary, the text will scroll up.  The scroll bar on the right can be used to scroll up and down to see any line of text.  If the edit window height is small and the font is large, the text will seem to disappear as it scrolls up and out of view.  Horizontal editor scrolling can be turned on by:

· selecting the View menu

· choosing Horizontal Editor menu item

In this mode, text will fill the editor from the left to right as before.  When text reaches the right side of the editor, all of the text will begin to scroll horizontally to the left.  This mode will allow you to always see the last few words in the editor, but will not allow you to see any text that has scrolled out of the window.

3.5.2. Full Screen

If you find that the menus and toolbar are taking up too much screen space, or if you want to prevent a user from accessing these controls, you can hide them by selecting the Full Screen menu item. When you select this option, you will see a dialog box telling you how to exit Full Screen mode, then the menus and toolbar will disappear.
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To exit Full Screen mode, press the hardware “record” button on the device (near the top on the left side).


[image: image47.png]Power Button
Action Control

Record





If you’re in Dedicated Device mode (see section3.9) you will be given the option to specify a Full Screen password. You might want to specify a password if you’re using Full Screen mode to prevent the user from accessing menus (either deliberately or accidentally). This password will be required to exit the mode. If you forget your password, use the emergency password “bosco” to exit.

3.6. Locking and Unlocking Configurations 

The Lock Config or Unlock Config options are used to keep a user from changing the operation or appearance of the buttons.  If the configuration is currently not locked, the menu item will say Lock Config.  If it is currently locked, the menu item will say Unlock Config

You can lock a configuration to prevent anyone from editing it without knowing the password.  This is also useful for preventing accidental interface changes.  To lock a configuration:

· select the View menu
· choose the Lock menu item (you will be asked to enter the password)

· enter a password (don’t choose a word from the predictor when entering a password)

· tap OK (you will be asked to confirm the password)

· re-type the same password (don’t choose a word from the predictor when entering a password)

· tap OK

The configuration will now be locked.

If you try to edit a locked configuration, you will automatically be prompted for the password.  If you supply an incorrect password, you will be unable to edit the interface.  If you provide the correct password, the configuration will remain unlocked until you lock it again.  Whenever you re-lock a configuration, you will be asked whether you want to use the existing password or set a new password.

If you forget your configuration password, you can use the backup password.  

· select the View menu
· choose the About ChatPC menu item

· find the ID field

The backup password is the first 8 characters of this field.  (dashes count as a character)

3.7. Hardware Buttons
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The three buttons on the lower right part of the device can be configured to provide shortcuts to several common functions.  The top button (the Rocket button) performs the Clear Editor function, the lower left button (the Calendar button) will speak the contents of the editor, and the lower right button (the Contacts button) performs the Navigate Back function, sending you back to the last page you were on.  To turn the hardware buttons off:

· tap on the Tools Menu

· choose Options
· choose the System tab
· uncheck “Use hardware buttons as shortcuts”
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NOTE: The Record button (the button located on the bottom of the left side of the device) is always configured to work with the ChatPC software.  If ChatPC is not currently running, the Record button will launch the software.  If it is running, the Record button is used to toggle between normal and Full Screen modes.

3.8. System Settings: “Setting Dialogs” Option

You might occasionally want to change the settings of the system hardware so that it’s better suited to your needs. For example, you might want to change the brightness of the screen. To access the dialogs that allow you to make such changes:

· tap on the Tools menu

· choose Options
· choose the System tab

· use the Setting dialogs control
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The following hardware dialogs are available:


Align Screen

Recalibrate the touchscreen and double-tap timing


Brightness

Set the screen brightness and automatic dimming feature

Input


Configure the on-screen mini-keyboard


PC Connection

Define the default connection mode and speed


Power


Check battery status and set automatic power-down


Screen Taps

Set screen tap and key click sounds

For full documentation of these dialogs, consult the hardware manual for your device.

3.9. Dedicated Device Mode

Some individuals prefer the simplicity and limited functionality of a dedicated device.  This is useful for beginning users or computer novices who do not want the additional functionality – and associated complexity – that their PocketPC device can offer. 

· tap on the Tools menu

· tap on Options

· tap on the System tab

By selecting the Act like dedicated device check box, ChatPC can be configured so that no other functionality outside of the ChatPC software is available to the user.  Once checked, your ChatPC computer looks and acts like a dedicated communication device.  You will not be able to select the View->Hide Program menu item to get back to the “today” screen, nor will you be allowed to exit the program.  Even if you do a soft reset, ChatPC will start-up immediately and take over control of the device.
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.

4. More ChatPC Software

· Overview of Menus

4. Menus

The pull-down menus at the bottom left of the ChatPC window allow you to determine which configuration will be used, which augmentative options are enabled, how and when to speak messages, and how a wide variety of other options are configured.  Some of these features are accessed directly through the pull-down menus, while others are accessed through pop-up dialog boxes called up through the menus.

You can access menu items using the touchscreen, either with the stylus or your finger.  Tap on the menu name in the lower left portion of the screen.  Once the menu appears, tap on the selection you want.

Note: If the menus do not appear at the bottom of the display, the ChatPC has been set to 'full screen' mode.  Press the record button to turn the menus back on.
4.1.File Menu

The File menu allows you to load standard and user-modified configurations into ChatPC.  It also lets you create new configurations and recall recently loaded configurations.

The easiest way to load a configuration is to use either the Standard Configs or the User Configs menu option:

· Choosing Standard Configs opens a list of the standard configurations on the device. The standard configs are a great place to start when designing your own configurations. (After you have personalized a standard configuration with your custom phrase or symbol pages, it can be loaded from the User Configs menu item.)

· Choosing User Configs opens a list of all the user-generated configurations that are stored on the device. As you create new configurations, they will automatically show up in this menu. Choosing User Configs opens a list of all the user-generated configurations that are stored on the device. As you create new configurations, they will automatically show up in this menu.  Whenever you change one of your customized configurations, a backup will be automatically stored in a safe location.  To recover a config backed up in this fashion, use the Load Config option (described below).
To load a standard or user configuration, tap the name of the one that you want to load. The name of the configuration that is currently loaded will appear with a check next to it in the list.

Configurations brings up a menu that has items for creating a new configuration (New Config), loading a user-generated configuration (Load Config…), unloading the current configuration (Unload Config), saving the current configuration (Save Config), or saving the current  configuration with a new name (Save Config As…).  When saving a configuration that hasn’t previously been named, you will be prompted to enter a filename.  Type in the name on the miniature onscreen keyboard, then tap OK to save the configuration.  You can read more on editing configurations in section 2.4.

The Configurations menu item brings up a menu that has items for creating a new configuration (New Config), loading a user-generated configuration (Load Config), unloading the current configuration (Unload Config), saving the current configuration (Save Config), or saving the current configuration with a new name (Save Config As). Similar to text files, configurations can be loaded, edited and saved. You can read more about editing configurations in section 5 (page 89).  If you want to recover a previous version of a user configuration, use the Load Config option to look for a config with “_backup” appended onto the end of the configuration name.  After you load a backup configuration, you should immediately use Save Config As to rename it (making sure to get rid of the “_backup” part of the name).  The Print Selected Pages and Print All Pages menu items allow you to print your configuration, one page on each sheet of paper.  If you select Print Selected Pages, you will be offered a chance to select individual pages for printing.  Note that the Print menu items are only available on the PC Editor, not on the device itself.

Recent Configs show a list of the last 8 configurations that were loaded.  This menu item is useful for quickly changing between commonly used configurations.

The final item in the File menu is Exit.  Selecting this will cause ChatPC to shut down.  You will not be able to exit the program if it is in Dedicated Device mode.

4.2. View Menu

The View menu lets you alter the general appearance and layout of the ChatPC window itself – not the configuration that’s running in the window.

The first item in the view menu is used to toggle between two different modes of operation called Run Mode and Edit Mode.  Run Mode is what is used when you are using ChatPC as a communication device.  Edit Mode is used when you want to change the appearance or behavior of particular buttons or pages.  When you are in Run Mode, the menu item will say Go to Edit Mode, allowing you to toggle the mode.  Likewise, when you are in Edit Mode, the menu item will say Go to Run Mode.

The second menu item is used to Lock or Unlock a configuration to keep a user from changing the operation or appearance of the buttons.  If the configuration is currently not locked, the menu item will say Lock Config.  If it is currently locked, the menu item will say Unlock Config.  For more information on locking and unlocking configurations, read section 3.6.

The Page Editing menu item will display a sub-menu full of commands related to creating and modifying pages within a configuration.  This option is only available when you are in Edit Mode.   See section 2.

For some configurations, you may not want to have a visible editor window.  You can toggle the existence of this window by selecting Main Editor.  Even when the editor window is not showing, the message you produce will still be entered into the window – it just won’t be visible until the window is displayed again.

The Editor Window can operate in two different modes.  With Horizontal Editor turned off, text that is displayed in the editor will fill the editor from left to right until it reaches the right edge.  When there are too many characters to fit on a single line (at the current font size), text will start appearing on the next line and if necessary, the text will scroll up.  The scroll bar on the right can be used to scroll up and down to see any line of text.  If the edit window height is small and the font is large, the text will seem to disappear as it scrolls up and out of view.  Horizontal editor scrolling can be turned on by selecting the View->Horizontal Editor menu item.  In this mode, text will fill the editor from the left to right as before.  When text reaches the right side of the editor, all of the text will begin to scroll horizontally to the left.  This mode will allow you to always see the last few words in the editor, but will not allow you to see any text that has scrolled out of the window.

If you find that the menus and tool bar are taking up too much screen space, or if you want to prevent a user from accessing these controls, you can hide them by selecting Full Screen.  When you select this menu item, you will see a dialog box telling you how to exit full screen mode, then the menus and tool bar will disappear.  To exit full screen mode, hit the hardware “record” button on the device.  If you’re in Dedicated Device mode (see 3.9), you will be given the option to specify a full screen password.  You may want to specify a password if you’re using full screen mode to prevent the user from accessing menus (either deliberately or accidentally).  This password will be required to exit full screen mode.  If you forget your password, use the emergency password “bosco” to exit.

To recover the menus and tool bar after using the Full Screen menu item, hit the hardware record button on your device.  This button is located on the left side of the device, about halfway up.  If you didn’t specify a full screen password, the menus will appear after a brief pause.  If you specified a password, you will be prompted to enter that password.  If you’ve forgotten your full screen password, you can use the back-up password “bosco”.  Once you’ve entered a valid password, the menu and toolbar will reappear.

If you would like to clear the editor of any text, you can select Clear Editor.  This function can also be accessed through a tool bar button and through any clear buttons in the current configuration.

NOTE:  Although the Clear Editor button does not prompt you before clearing the editor, an Undo button can be used to undo a Clear Editor action – allowing you to retrieve your text if you accidentally cleared the editor of text you wanted to save.

When ChatPC is running, you won’t have access to the PocketPC Start menu (the menu that lists the applications on the device).  To access the Start menu, select Hide Program from the View menu.  After you do this, ChatPC will disappear and you’ll see the “Today” screen of PocketPC.  You can now select whatever application you want using the Start menu.  When you’re ready to return to ChatPC, simply select it from the Start menu or tap the record button on the left side of the device.  The Hide Program option will not be available when ChatPC is operating in Dedicated Device mode.

To access the online help, select Help Topics.  To get information about the ChatPC software including version number and product ID, select About ChatPC. 

4.2.1. Page Editing

NOTE: This sub-menu will only be available when the device is in Edit Mode.

The Go to Page item will display a dialog box that will allow you to pick the page you want displayed from a list of all the pages in the configuration.  Select the page you want and tap on OK.  The Add Page item will display a dialog box that will allow you to enter the name of the new page and select what type of page you want to add (number of locations).  After adding a page, the new page will be displayed.  The Delete Page item will delete the page that is currently displayed.

NOTE: The keyboard page associated with every configuration is locked and cannot be deleted.

The Duplicate Page item will create a new page with all of the same buttons as the current page.  A dialog box will be displayed to ask for the name of the new page.  This feature is handy when building symbol configurations where you would like the same buttons to be displayed on every page.  Simply create a page with the buttons that will be on every page, and duplicate that page as many times as you would like.  Then go back to each page and fill in the remaining buttons.

The Rename Page item displays a dialog box that asks for a new name for the current page.  The Set Home Page item is used to set which page will be displayed when a configuration is first loaded. You can clear all the buttons on a page (make them blank) by selecting Clear Page. You will be asked if you’re sure before the buttons are actually cleared.

ChatPC allows you to export (save) and import (load) individual pages using the Import Pages and Export Pages commands. For details on these processes, see section 2.8.3.

4.3. Tools Menu

The Tools menu is used to access options that allow you to configure ChatPC.  

To change the way a word is pronounced by the speech synthesizer, select Pronunciation Editor, and the Pronunciation dialog will be displayed (see section 3.2).  

The items in the File Utilities sub-menu allows you to delete and rename the custom files on your device, automatically delete unused files, and pack (and unpack) configurations for archiving, sending to another person, or posting on a web site.

The System Utilities item allows you to reset default options and files and manage software upgrades.

On the PC Editor (only), the Transfer Utilities sub-menu is used to transfer custom files between your PC and your ChatPC device and to backup (and restore) your device.

Using the Logging sub-menu, you can configure electronic recording of message production (see section 5.

Finally, to access generic options such as input techniques and speech synthesis parameters, open the Options dialog by selecting Options
4.3.1.File Utilities Menu

The file maintenance menu allows you to manage the configuration, sound, and user files that are on the machine.  

4.3.1.1. Manage Files

As you use ChatPC to communicate, you will build up a number of custom files such as user configurations, recorded sounds, imported images, and stored text files. On occasion, you might want to manually delete or rename these files. To do this:

· select Tools menu

· choose File Utilities

· choose Manage Files and the Manage Files dialog will open.
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The Manage Files dialog consists of a list of custom files of the specified type, a control for changing the file type, and buttons for renaming and deleting selected files. By default, the dialog lists the user configurations on the system. 

To rename a configuration, select the configuration in the list to highlight it, then click the Rename button. Enter the new configuration name in the small window that opens.

WARNING: If you click Delete instead of Rename, the configuration will be permanently deleted from your system. Be very sure that you really want to delete a file, or that you have a safe backup of the file on your PC, before using Delete.

You can also use the Manage Files dialog to delete several configurations at the same time. To do this, hold down the Ctrl key on your keyboard while clicking on each configuration that you want to delete. All of the configurations that you select will be highlighted. When you click the Delete button, the configurations will be deleted. You cannot Rename several files at once.

If you want to rename or delete other types of files, you’ll need to change the file type listed in the box at the top of the dialog. The following file types are available:


Pages


Individual symbol and phrase pages 


Sounds


Recorded sounds stored in the .wav format 


Packed Files

Packed configurations 


Logfiles

Encrypted logging activity 


Backups

Device backup files (PC Editor only)

The Rename and Delete procedure remains the same regardless of what file type is selected. When listing custom Sounds files, the Manage Files dialog also offers a Preview button which can be used to hear the selected file. Be especially careful when renaming or deleting Sounds, since they might be needed by existing User Configurations. 

NOTE: The Manage Files menu item replaces the Rename/Delete Configs and Rename/Delete WAV Files menu items from earlier versions of ChatPC (before version 3.0).

4.3.1.2. Cleanup Unused Files

Using the PC Editor, you can import custom images and sounds into a configuration.  If you imported such a multimedia file in the past and don’t use it anymore, it will take up valuable storage space on your device.  Select the Cleanup Unused Files menu option to permanently delete any unused images and sounds that you have imported.  Multimedia files that are used by any custom configuration on the device will not be deleted.  Standard Mayer-Johnson symbols will not be deleted.  The cleanup process may take several minutes.

4.3.1.3. Pack Config

ChatPC’s packing function allows you to combine an entire configuration and all of its components into one “packed” file for easy sharing or back-up to your desktop or other data media (floppy, CD, Zip disk, etc.).  The Pack Config menu item lets you pick one of the user configs on your device or PC Editor and then packs all of its components (custom sounds and images) into a single file.  Packed files are placed into the Temp folder located in the same folder as the Impact program.  If you pack a configuration on your ChatPC device, it will be located in the \Storage Card\My Documents\ChatPC\Temp folder.  Once packed in a single file, the configuration can easily be copied to your desktop computer, stored on floppy or CD for back-up, emailed to a friend, or even transferred between ChatPC devices via the infrared port.
NOTE:  Infrared transfer cannot be done while in Dedicated Device mode.  A brief overview of infrared transfer is given here; you should consult the manual (on CD) provided by the computer manufacturer for additional details about transferring files via the infrared port.    

To select the file for transfer:

Select the View->Hide Program menu item to access the PocketPC today screen.  From the Start menu, select Programs and then the File Explorer.  Using the File Explorer, navigate to the file that you want to transfer (for packed files, they are located in the \Storage Card\My Documents\ChatPC\Temp directory).  Tap on the file and hold the stylus to the touch screen until the pop-up menu shows.  From there, select Send via Infrared…
To receive a file via infrared transfer:

From the Start menu, select Programs and then the Infrared Receive.  Be sure to line up the infrared ports on the two machines that are performing the transfer.  The machines will detect one another and complete the transfer.

Once the file has been transferred:

You’ll need to move the Pack file once it’s transferred.  By default, files transferred via infrared are stored under the \My Documents folder.  Bring up the File Explorer (located under Start->Programs) and then select the file and hold the stylus to the touch screen to obtain the pop-up menu and then Cut the file.  Navigate to the \Storage Card\My Documents\ChatPC\Temp folder and then touch the screen in the blank space below the listed files and hold to obtain the pop-up menu.  Select Paste from this menu.  From within ChatPC, the file will now appear in the list of available packed files when you select Unpack Config (see next section).

4.3.1.4. Unpack Config

The Unpack Config function allows you to unpack a packed configuration for use on your portable ChatPC device or your desktop editor.  After selecting this item, you will be asked to choose one of the packed files found on your device or computer.  This file will then be automatically unpacked and put into your User Configs directory for easy access.  Remember that if you unpack from your PC Editor, the configuration will only be on your PC – not on your device (and vice versa if you unpack on your device).  You can always use Export Config and Import Config to transfer configurations once they’ve been unpacked, however.

4.3.2. System Utilities Menu

This menu allows you to restore default options and default user files (pronunciation exceptions) and manage software upgrades. To open the menu, open the Tools menu and choose System Utilities.

The Reset User Files option replaces all of the customized user files with the defaults that were initially shipped with your machine. Pronunciation exceptions are all replaced by the defaults.

NOTE: You can only restore the default user files when there is no configuration loaded. Restoring defaults permanently removes all of the customized user data. Do not select this option unless you want to delete all of the entries in the pronunciation exception list.

The Reset Options menu item resets all of the options (for example, speaking voice and selection method) to their factory defaults. This is particularly useful if you’ve inadvertently changed some ChatPC options and can’t recover from these changes.

4.3.2.1. Upgrading the Software

The first step in preparing for a software upgrade is to open the Tools menu and choose Prepare for Upgrade. 

NOTE: This option ensures that all of your personal settings and configurations are saved during the upgrade procedure.

Once prepared, your system can be upgraded by choosing Complete Upgrade. Specific instructions for upgrading your machine should be included with the Upgrade Package. See the Upgrade Package you received with your new memory card for additional details.

4.3.3.Transfer Utilities Menu

The Transfer Utilities menu item provides access to several functions that are useful for moving your configurations from one machine to another.  Whether it be from the PC Editor to the device or from one device to another, the following four functions give you the tools you need to back-up and share your configurations.  
4.3.3.1. Transfer Files (PC Editor only)

The PC Editor allows you to create and modify configurations on your Windows PC. Of course, this feature wouldn’t be very useful if you couldn’t transfer these configurations to your device. To exchange configurations and other important information between your PC Editor and your device, connect the device to the PC (see section7) and select Tools > Transfer Utilities > Transfer Files from your PC Editor menu. After a second or two, the Transfer Files dialog will appear.
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The Transfer Files dialog contains two lists of files:

· The PC Files box lists all of the user configurations that are currently on your PC.

· The Device Files box lists all of the user configurations that are currently on your device.

NOTE: If you open the Transfer Files dialog when your device isn’t connected to your PC, the Device Files box will be disabled.

To transfer a configuration from your PC to your device (to “export” a configuration), click the PC configuration you want to export in the PC Files box. The configuration you selected will be highlighted. Then click the Copy to Device button. All of the configuration components (including custom images and sound files) will be exported to the ChatPC. Depending upon the size of the configuration and number of custom images and sounds it uses, the transfer can take just a few seconds, or it can take several minutes. When the transfer is complete, the exported configuration will appear in the Device Files box, and will also show up under the File > User Configs list on the device.

If you need to transfer configurations from your device to your PC (“import” a configuration), select the configuration from the Device Files box to highlight it. Click the Copy to PC button to start the transfer. Once the transfer is complete, the configuration will appear in the PC Files list, and will also show up under the File > User Configs list on your PC Editor.

NOTE: The Transfer Files method replaces the Export Config and Import Config menu items from earlier versions of ChatPC (before version 3.0).

You can use the Transfer Files dialog to transfer several configurations at the same time. To do this, hold down the Ctrl key on your keyboard while clicking on each configuration that you want to transfer. Each configuration that you selected will be highlighted. When you click the Copy to Device (or Copy to PC) button, the selected configurations will be transferred.

Importing and exporting configurations is the primary purpose of the Transfer Files dialog, but you can also import and export other types of files by changing the file type listed in the box at the top of the dialog. The file types that can be transferred are:


Pages


Individual symbol and phrase pages 


Sounds


Recorded sounds stored in the wav format 


Packed Files

Packed configurations 


Logfiles

Encrypted logging activity 


User Files

Custom pronunciations
Once the file type has been selected, the transfer procedure is identical. When transferring any type of file, be aware that even though a file has the same name on the device and on the PC, it may not have the same content.

Like the Manage Files dialog, the Transfer Files dialog also lets you delete, rename, and preview individual files on your PC. With the Transfer Files dialog, however, you can also delete and rename files on your device right from your PC Editor. Since all of the User Files are needed by ChatPC, you cannot rename or delete these files.

4.3.4.Logging Menu

If used properly and with appropriate safeguards, electronic recording of augmentative communication can provide a wealth of clinical and research data.  We’ll refer to “electronic recording of augmentative communication” as “logging”, and the resulting files as “logfiles”.  ChatPC is one of the first commercial products to support the logging standard being proposed by the Rehabilitation Engineering Research Center on Communication Enhancement (the AAC-RERC).  The AAC-RERC is funded by the National Institute on Disability and Rehabilitation Research (NIDRR), an office of the U.S. Department of Education.  Most of the major AAC manufacturers have agreed to adopt this logging standard.  See www.enkidu.net/logfile.html for a thorough description of the standard.

Logging is intended solely for clinical and research purposes.  However, the potential for misuse (by clinicians, researchers, family members, or anyone else) is extremely serious.  Be aware that there may be ethical and legal issues associated with the use of logging.  Saltillo is working with augmented communicators, clinicians, researchers, and other manufacturers to help establish a set of protocols to protect user privacy.

To help prevent misuse, ChatPC supports several different forms of logfile encryption.  When encryption is enabled, logfile content can only be read using a standards-compliant logfile analysis program.  An additional level of security is provided by an optional password.  We urge you to encrypt logfiles whenever possible.

The logging options are accessed through the Tools->Logging menu.  Once logging has been configured using the Logging Setup dialog, you may pause logging at any time by selecting the Tools->Logging->Pause Logging menu item.  Resume logging by selecting this same item (which will now read Resume Logging).  To stop logging, choose the Tools->Logging->Stop Logging menu item.  Once you stop logging, you will not be able to restart logging to the same file.  You will need to configure a new logfile using the Logging Setup dialog.

5.  Clinical and Research Data

· Data Logging

5.1.Data Logging 

If used properly and with appropriate safeguards, electronic recording of augmentative communication can provide a wealth of clinical and research data.  We’ll refer to “electronic recording of augmentative communication” as “logging”, and the resulting files as “logfiles”.  ChatPC is one of the first commercial products to support the logging standard being proposed by the Rehabilitation Engineering Research Center on Communication Enhancement (the AAC-RERC).  The AAC-RERC is funded by the National Institute on Disability and Rehabilitation Research (NIDRR), an office of the U.S. Department of Education.  Most of the major AAC manufacturers have agreed to adopt this logging standard.  See www.enkidu.net/logfile.html for a thorough description of the standard.

Logging is intended solely for clinical and research purposes.  However, the potential for misuse (by clinicians, researchers, family members, or anyone else) is extremely serious.  Be aware that there may be ethical and legal issues associated with the use of logging.  Saltillo is working with augmented communicators, clinicians, researchers, and other manufacturers to help establish a set of protocols to protect user privacy.

To help prevent misuse, ChatPC supports several different forms of logfile encryption.  When encryption is enabled, logfile content can only be read using a standards-compliant logfile analysis program.  An additional level of security is provided by an optional password.  We urge you to encrypt logfiles whenever possible.

5.2.Data Logging Setup

The logging options are accessed by:

· tapping the Tools menu

· choosing the Logging menu

· select the Configure Logging item.  (This option is unavailable if you are currently logging.)  

You can now select logging options through the Logging Setup dialog.  To select the file to which logging data will be saved (the logfile), tap on Browse or simply type the filename in the File box (you must include.log in your file name).   By default the logfile will tag entries with labels like “T” for “Time” and “O” for “Output”.  You can disable these labels by unselecting the Field Labels checkbox.
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Three types of encryption can be selected using the Encryption drop-down list.  In Normal encryption, all characters except spaces and certain field delimiters are encoded in a recoverable format.  Even spaces are encoded with Strong encryption.  With Perfect encryption, the output data will be encrypted in an unrecoverable manner.  Although the messages recorded under perfect encryption can never be recovered, certain types of logfile analysis are still possible.  For example, the overall communication rate can be computed without knowing the actual messages.

For Normal and Strong encryption, an encryption key is required.  This string of characters is specified in the Key field.  The key may be any combination of letters (lower or upper case) and numbers.  Do not use punctuation marks or other symbols in the key.  Additionally, you may specify a password in the Password field.  Without a password, any standards-compliant analysis program (such as ACQUA) can decrypt an encrypted file (except for those encoded with Perfect encryption).  If a password is specified, however, an analysis program will not be able to decrypt the logfile without that password.  If you choose to use a password, make sure that you’ll remember it – if you forget the password the logfile cannot be decrypted.

The Fields list is used to configure what kind of information will be sent to the logfile.  Select the information fields from the Fields list by clicking on them (click again to unselect).  Many of these fields are self-explanatory.  For detailed information, consult the logfile standards web pages at www.enkidu.net/logfile.html.   If the Field Labels box is checked, each field will be tagged in the logfile with a unique abbreviation (like T for Time).

Once you have configured the logfile, tap OK to start logging (or Cancel to exit without starting to log).  Until logging is manually stopped (using the Tools->Logging->Stop Logging menu item), a new configuration loaded, or ChatPC is shut down, all subsequent communication events will be sent to the logfile.

NOTE: After you stop logging, you will not be able to restart logging to the same file. You will need to configure a new logfile using the Logging Setup dialog.

Transfer the Logging File to your PC

Once you have stopped logging a file has been created on your device and can be moved to your PC for analysis.

· attach the ChatPC device to your PC running the ChatPC Editor and ActiveSync

· choose the Transfer Utilities menu from the ChatPC Editor

· choose Transfer Files

· choose Log Files 
· tap the file from the Device Files listing
· choose    

You can now use your Windows Explorer and navigate to \ProgramFiles\Saltillo\ChatPC Editor\LogFiles\.The data is always encrypted and can only be viewed using a logfile compliant program such as ACQUA (www.enkidu.net/acqua.html).   
6.  Introducing the Pocket PC Software

· About PocketPC

· How to Exit ChatPC 

· How to Re-load ChatPC
6.1 About PocketPC

ChatPC runs on a portable computer that uses Microsoft’s “PocketPC” operating system.  PocketPC is designed to  resemble Windows 95/98.  When ChatPC isn’t running, a task bar along the top of the screen provides access to all the programs on the device.  Simply tap on the Windows Flag to reveal a pop-up menu of options.  This manual assumes that you have some experience using Windows and are comfortable with concepts such as navigating menus, clicking, and double-clicking.

Unlike normal Windows, PocketPC is designed to run on portable computers with less powerful microprocessors and less memory than desktop computers.   Some of the more sophisticated Windows 95/98 features are absent from PocketPC, but the basic functionality remains the same.  One important addition to PocketPC is it’s “instant on” capability – the desktop appears as soon as the portable computer is turned on, and there is no need to close application before you turn the computer off.

Another major distinction is that instead of using a mouse, the computer has a built-in touch screen.  To perform the equivalent of a "click" in PocketPC, you can tap the screen at the desired location either with a finger or the stylus included with the device.  Never use a sharp metal object such as a pen or paperclip for tapping, as it will damage the screen. 
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If you cannot find the information you need regarding operation of your Casio EM-500 in this manual, please refer to the included CD-ROM titled " CASSIOPEIA Software Applications ".  The CD-ROM contains electronic versions of Getting Started with the CASSIOPEIA (for information on operating the device) and the Pocket PC User's Guide (for information on using PocketPC).

If you cannot find the information you need regarding operation of your HP iPAQ 3835 in this manual, please refer to the included CD-ROM titled “iPAQ Pocket PC Companion CD”. The CD-ROM contains electronic versions of iPAQ Pocket PC Reference Guide (for information on operating the device) and the iPAQ Pocket PC User’s Guide (for information on using Windows CE).

6.2.Stopping ChatPC
As mentioned before, we recommend that you always leave ChatPC running – even when you turn off your device.  However, if you need to stop the program for some reason, you can select Exit from the File menu.  You will then be asked if you are sure that you want to exit the program.  Selecting "Yes" will stop ChatPC, while selecting "No" will leave it running.  

Another option is to choose Hide Program from the View menu.

Note: The Exit or Hide Program options are not available when in 'dedicated' mode.  To leave Dedicated Mode:

· select the Tools menu

· choose Options

· choose the System tab

· un-check Act Like Dedicated Device

· choose OK

Exit and Hide Program are now available 

6.3.Restarting ChatPC

If for some reason the ChatPC application is not running the screen will now show a window, with a “Window Flag” at the top left.  Tap once on the "Windows Flag" and you will see "ChatPC" near the top of the list of applications.  (If you don't see it, refer to the note below).  Tap on it and the program will start running. Once the program is running you can turn the computer's power off and on without exiting the program.

Loading a configuration.  ChatPC is now running, but the main window will be empty.  ChatPC allows you to load a variety of interfaces that have different button layouts.  Each layout is called a configuration.  Tap on the File menu, and then tap on Standard Configs.  You will now see the two configurations included with ChatPC: Symbol-Base and VocabPC Simply tap on the one you want to load.  Complicated configurations with many pages may take up to 2 minutes to load, but most will load quicker.  Once loaded, you can leave ChatPC running and your chosen configuration will always be ready for you to use.  You’re done!  Just start tapping the onscreen buttons and ChatPC will speak the button contents.

NOTE: If you receive the device and the batteries have already completely discharged, you will not be able to find the ChatPC item in the Start menu.  Immediately plug the device in, to start recharging the batteries.  Then restore the ChatPC software, see below.

6.3.1.Restoring ChatPC

Some of the software components for ChatPC are stored in battery-backed up memory.  This means that if the battery (and the backup battery) is drained completely, some of the software components will need to be restored.

You will be presented with a series of screens asking you to calibrate the screen, set the date/time, and provide other information.  (Note: Calibrating the screen takes a steady hand, you need to press and hold the stylus on the small "+" on the screen.  If you are not able to do this yourself, have someone help you.)

· tap on the Windows Flag

· choose Programs

· tap on File Explorer

· near the top of the resulting window, tap on My Documents
· when a pop-up menu appears, tap on My Device

· tap on Storage Card in the main window

· tap the file ChatPC Installer (A dialog will appear informing you that ChatPC is going to be reinstalled.)

· tap on OK (After about 10 seconds another dialog will tell you that the process has completed successfully.)

· tap on OK again

· tap on  PowCtrl (it will take only moments for this to load)

· tap on Update (after a few moments you will get a file warning)

· tap YES
· unplug the two cables attaching the IPAQ to the amplifier circuit in the rubber case (The charger cable in upper left hand corner needs to be unplugged.  Also unplug the audio connector at the top of the ChatPC (you may need a small screwdriver to pry out the connector which is recessed in the rubber case).  

· press back on the rubber case at the top of the screen and pop the IPAQ computer out of the case

· turn the device On
· using the stylus, press the Reset button on the bottom of the IPAQ computer

· reinstall the IPAQ into the rubber case by popping it back into the rubber cases and reattaching the connectors.

If, ChatPC is not already installed, you should be able to select ChatPC from the Start Menu. 

· choose the File menu

· choose Standard Configs (using the device for the first time) 

or User Configs (if you already have vocabulary created) 

· choose the configuration of your choice
7. Using ChatPC and the ChatPC Editor with your Desktop to expand your systems capabilities

· Connecting to a PC 

· Installing ChatPC Editor and Active Sync software

· Using the ChatPC Editor

· Transferring Files

· Importing an Image

· Backing Up Your Device 

· Using On-Line Help

· Using an External Keyboard

· Software Updates

7. Connecting to a PC

Your ChatPC device comes with a Windows PC Editor.  By connecting your device to your PC, you can use the Editor to …

· design and test configurations right on your desktop or laptop machine

· perform a backup of your device

· transfer configurations between the PC Editor program and the device

· transfer text files to the PC for printing

· install 3rd party software on the device

The ChatPC Editor software will run on any Windows 95/98/NT/2000 machine.  The primary purpose of the PC Editor is to allow you to design and test configurations right on your desktop or laptop machine.  Because you’ll have a keyboard and mouse available, developing configurations in this way can be much quicker than doing so on the ChatPC device itself.  It also allows you to work on configurations when the device itself isn’t available.

7.1. Installing the PC Editor and Active Sync Software onto your PC

To install the PC Editor and ActiveSync:

· Insert the ChatPC Editor CD into your computer  

· You should see a Welcome Screen appear (this may take a few moments), if not, you will need to navigate to your CD through Windows Explorer and choose setup.exe.

· Step through the installation by choosing Next at each screen

· Once the installation occurs choose Finish to complete the process

· Take the ChatPC Editor CD out of the computer and put the ActiveSync CD in.  You should see a Window Explorer screen appear (this may take a few moments)

· Double click on Setup

· Step through the installation by choosing Next at each screen and follow the instructions

· Take the CD out of your computer once the installation is complete

· This has placed both the Microsoft ActiveSync application and the ChatPC Editor application into your Programs folder.  

· This process will not need to be repeated.

If you want the PC Editor to have synthetic speech and you have a Soundblaster-compatible sound card (you probably do), you’ll also have to install the free Microsoft text-to-speech libraries.  These libraries are also included on your Saltillo CD-ROM.  Simply double-click on

“spchapi.exe” and then “msttsl.exe”.  Once you do this, you’ll have access to the Microsoft voices through the Speech Menu.  Remember that your ChatPC device uses DECtalk for speech synthesis, so speech will sound different on your PC.  Due to licensing restrictions, we are not able to provide DECtalk for the PC Editor.

If you’re using a Windows 95 computer, you may find that the PC Editor will not run.  If this happens, it means that you have an older interface library.  One possible remedy is to install Microsoft Internet Explorer 5.0 from our CD-ROM.  Installing this browser will automatically update your interface libraries, but may cause other system problems.  If you’re willing to take this risk, you can install the program by double-clicking on “IE5\setup.exe”.

WARNING:  Installing Microsoft Internet Explorer 5.0 may cause your system to become unstable or crash.   Install at your own risk!
7.2. Using the PC Editor

Once you’ve successfully installed the PC Editor onto your computer, you can start it up by selecting:

· Start Menu

· Programs

· ChatPC Editor
After a brief splash screen, the PC Editor will appear.  You can use this program to do just about anything that you can on your actual ChatPC device.  Although the dialog boxes will appear slightly different and a couple of the options are modified for the PC, this User’s Manual will serve just as well for the PC Editor as it does for the device itself.

7.3. Transfering Files (PC Editor only)

To transfer a configuration from your PC to your device:

· click the PC configuration you want to export in the PC Files box. (The configuration you selected will be highlighted.) 

· then click the Copy to Device button (All of the configuration components (including custom images and sound files) will be exported to the ChatPC.) 

Depending upon the size of the configuration and number of custom images and sounds it uses, the transfer can take just a few seconds, or it can take several minutes. When the transfer is complete, the exported configuration will appear in the Device Files box, and will also show up under the File > User Configs list on the device.

To transfer configurations from your device to your PC: 

· select the configuration from the Device Files box to highlight it 

· click the Copy to PC button to start the transfer 

Once the transfer is complete, the configuration will appear in the PC Files list, and will also show up under the File > User Configs list on your PC Editor.
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NOTE: The Transfer Files method replaces the Export Config and Import Config menu items from earlier versions of ChatPC (before version 3.0). The PC Editor allows you to create and modify configurations on your Windows PC. Of course, this feature wouldn’t be very useful if you couldn’t transfer these configurations to your device. To exchange configurations and other important information between your PC Editor and your device, connect the device to the PC (see previous page) and select Tools > Transfer Utilities > Transfer Files from your PC Editor menu. After a second or two, the Transfer Files dialog will appear.
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The Transfer Files dialog contains two lists of files:

· The PC Files box lists all of the user configurations that are currently on your PC.

· The Device Files box lists all of the user configurations that are currently on your device.

NOTE: If you open the Transfer Files dialog when your device isn’t connected to your PC, the Device Files box will be disabled.

You can use the Transfer Files dialog to transfer several configurations at the same time. To do this, hold down the Ctrl key on your keyboard while clicking on each configuration that you want to transfer. Each configuration that you selected will be highlighted. When you click the Copy to Device (or Copy to PC) button, the selected configurations will be transferred.

Importing and exporting configurations is the primary purpose of the Transfer Files dialog, but you can also import and export other types of files by changing the file type listed in the box at the top of the dialog. The file types that can be transferred are:


Pages


Individual symbol and phrase pages 


Sounds


Recorded sounds stored in the wav format 


Packed Files

Packed configurations 


Logfiles

Encrypted logging activity 


User Files

Custom pronunciations

Once the file type has been selected, the transfer procedure is identical. When transferring any type of file, be aware that even though a file has the same name on the device and on the PC, it may not have the same content.

Like the Manage Files dialog, the Transfer Files dialog also lets you delete, rename, and preview individual files on your PC. With the Transfer Files dialog, however, you can also delete and rename files on your device right from your PC Editor. Since all of the User Files are needed by ChatPC, you cannot rename or delete these files.

If you have trouble connecting, please consult ActiveSync’s online help.  Please note that ActiveSync is a Microsoft program.  If you have persistent problems getting connected, you may have to contact the technical support department of Microsoft or that of your device manufacturer (Hewlett Packard).

Once the configuration has been transferred: 

· tap the File Menu 

· tap User Configs
· choose the new configuration

7.4. Importing Images

With the included PC Editor program, it is possible to use your own scanned images, downloaded images, or homemade symbols on any button in a configuration.  This can be helpful for individuals that cannot make the connection between a cartoon symbol and a concept or object.  By providing an actual photograph, the user may be better able to select the proper message.  If you find that the symbol you need is just not available within the Mayer-Johnson symbols, you can create your own symbol using a graphics program on your PC, then import that image directly into your configuration.

The Editor will handle most bmp, gif, and jpeg images (although there are some non-standard versions of these formats that it will not handle). There is no need to resize your images to fit in the configuration buttons—the Editor will do this for you. When you import an image, the Editor will make a copy, resize the copy, and then store it in with other “custom” images (as opposed to the “standard” Mayer-Johnson symbols). When you transfer a configuration from the PC to your ChatPC device using the Tools > Transfer Utilities > Transfer Files option, any custom images used by that configuration will also be transferred to your device.

Images are imported by:

· making sure that you have the latest version of the users vocabulary loaded on the PC Editor, if not, see section 7.3. and load it onto the ChatPC Editor

· go to the View menu

· choose Go to Edit Mode
· double click on a blank key

· select the Browse button, as if you were going to choose a Mayer Johnson symbol for your button 

· click on the Import button

You can now browse your computer’s hard disk for bmp, gif, and jpeg images.  When you find the image you want to import, double-click on it to select it.

You will see a preview of the image, scaled to fit the button.  If you like, you can now browse through the images on your hard disk from the Symbol Selection Dialog just as you normally do for Mayer Johnson symbols.  Once you have selected the image you wish to import, click on OK and the image will appear on the button.  If you decide you don’t want to import an image, you can Cancel out of the Symbol Selection Dialog, or you can click on the Home button to return to browsing the Mayer Johnson symbols.

If you tap Browse for a button that has a custom image, you will start browsing in the “Custom” folder. If you move up a folder, you will find yourself at the top level symbol folder (where all of the installed symbol sets will be listed). If you want to reuse an image you have already imported, browse to the “Custom” folder—you don’t have to re-import the image.

If you encounter problems when you try to import an image, or if you want to import an image that isn’t in bmp, gif, or jpeg format, try saving it to a different format using a third-party image conversion utility. There are many such commercial utilities out there (for example, Adobe PhotoDeluxe and Photoshop, Corel Paint, and Jasc Paintshop Pro). Freeware programs, such as the easy-to-use IrfanView (download from www.irfanview.com/english.htm), offer free non-commercial use.

Using the PC Editor, you can also paste images from your system clipboard into the Symbol Selection dialog. Pasting an image is much like importing an image, but instead of selecting Import from the Symbol Selection dialog, you select Paste. If there is a valid image on you system clipboard, it will appear in the preview box of the dialog. If you decide you don’t want to use that image on your button, you can Cancel out of the Symbol Selection dialog, you can select the Home button to return to browsing the Mayer-Johnson symbols, or you can use the Import button to import a picture from your hard disk.

If you decide to keep the pasted picture, click OK.  Once you do this, a dialog will appear and ask you to name the image you’ve pasted.  Portable IMPACT will suggest a generic name for your (something like “Image0003.jpg”). If you don’t plan on using this image in other configurations or on other buttons, you’ll probably just want to hit OK to stick with the generic name. If you want to reuse the image, however, you may want to give it a descriptive name so it’ll be easy to find later. To change the image name from the suggested default name, simply type in the new name, then hit OK.  Once you hit OK, the image will be scaled and stored in the “Custom” folder, just like imported images are.

7.5. Packing and Unpacking Configurations

ChatPC’s packing function allows you to combine an entire configuration and all of its components into one “packed” file for easy sharing or backup to your desktop PC or other storage media (floppy, CD, Zip disk, etc.). The Pack Config menu item lets you pick one of the user configurations on your device or PC Editor and then packs all of its components (custom sounds and images) into a single file. Packed files are placed into the Temp folder located in the same folder as the ChatPC program. If you pack a configuration on your ChatPC device, it will be located in the \Storage Card\My Documents\ChatPC\Temp folder. After it is packed in a single file, the configuration can easily be copied to your desktop computer, stored on floppy disk or CD for backup, emailed to a friend, or even transferred between ChatPC devices via the infrared port.

NOTE: Infrared transfer cannot be done while ChatPC is in Dedicated Device mode. A brief overview of infrared transfer is given here; you should consult the manual provided by the computer manufacturer for additional details about transferring files via the infrared port.

To select the file for infrared transfer:

Choose View > Hide Program to access the Windows CE “Today” screen. From the Start menu, choose Programs > File Explorer. Using the File Explorer, navigate to the file that you want to transfer (for packed files, they are located in the \Storage Card\My Documents\ChatPC\Temp directory). Tap the file and hold the stylus to the touchscreen until the pop-up menu shows. From there, select Send via Infrared. 
To receive a file via infrared transfer:

From the Start menu, select Programs > Infrared Receive. Be sure to line up the infrared ports on the two machines that are performing the transfer. The machines will detect one another and complete the transfer.

After the file has been transferred:

You’ll need to move the Pack file after it is transferred. By default, files transferred via infrared are stored under the \My Documents folder. Open the File Explorer (located under Start > Programs) and then select the file and hold the stylus to the touchscreen to open the pop-up menu and then Cut the file. Navigate to the \Storage Card\My Documents\ChatPC\Temp folder and then touch the screen in the blank space below the listed files and hold to open the pop-up menu. Select Paste from this menu. From within ChatPC, the file will now appear in the list of packed files when you select Unpack Config (see below).

The Unpack Config function allows you to unpack a packed configuration for use on your ChatPC device or your desktop PC Editor. After selecting this item, you will be asked to choose one of the packed files found on your device or computer. This file will then be unpacked and put into your User Configs list for easy access. Remember that if you unpack a file with your PC Editor, the configuration will only be on your PC—not on your device (and vice versa if you unpack on your device). You can always use the Transfer Files command to transfer configurations between your PC and the device after they have been unpacked.

7.6. Device Backup  (This does not backup your ChatPC’s configurations)

This backup will ensure that your iPAQ can be restored to the backed-up functional state in the event that your batteries drain completely.  Since it is fairly common for people to leave their devices unplugged for extended periods of time, it is very helpful to do this kind of backup periodically to protect against losing data.  A device backup will not save any information that resides on your device’s memory card.  This includes all of your ChatPC configurations.  Consult the following section for backing up this information.

To perform a device backup, you must first connect your iPAQ to a PC using the provided USB/serial cradle.  Once the device is connected, Select Microsoft ActiveSync from the Start menu on the Windows computer.  From the Tools menu in the ActiveSync dialog box, select Backup/Restore.  If this is your first time backing up the device, select Full Backup.  If you are just updating a backup that you made earlier, select Incremental Backup.  For more information on device backups (and restoring from backup), consult the ActiveSync on-line help.

7.7. ChatPC Backup

As you use ChatPC to communication, a number of custom files will be created on your device’s memory card. These files include configurations that you have modified or created, sounds that you’ve recorded, and images that you’ve imported. Although a memory card can’t “crash” like a disk drive can, it is possible to lose this information. We therefore encourage you to use ChatPC’s backup utility to periodically archive your custom files.

To backup the data on your memory card, connect your device to your PC and choose Tools > Transfer Utilities > Backup Device to PC from the menu of the PC Editor. You will be asked to specify the name of the backup file that will store your custom data. We suggest using a name like “Tom 06-15-2001” that includes the date. After you specify the name of the backup file, the PC Editor will begin to transfer files from the device to your PC. Once you begin a backup, it cannot be terminated. Depending on how many custom files you have on your device, this process can take a very long time—thirty minutes or more.

The backup file you created will be stored in the Backup folder of your PC Editor installation folder (typically C:\Program Files\Saltillo\ChatPC Editor\). If you also backup your PC (always a good idea), make sure that your ChatPC backup files also get backed up.

To restore your custom files from a backup file, connect your device and choose Tools > Transfer Utilities > Restore from Backup from the menu of the PC Editor. You will be asked to select an existing backup file. After you select a file, the PC Editor will begin to transfer files from the PC to your device. As with the backup, once the restore process has been started it cannot be stopped.

NOTE: The restore process will overwrite any custom files that you already have on your device. Be very sure that this is OK before you start to restore from a backup file.

We strongly recommend backing up your device at least once a month.

7.8. Configuration Backup

If you have been making a lot of changes to a configuration that is stored on your device, it might be prudent to make a backup of that configuration in case something unforeseen happens on the device.  The “Device Backup” described above will not save your configuration information.  This is the same process as described in section 7.3 

· to perform a configuration backup, you must first connect the PC and the iPAQ with the included USB cable

· go to the Start Menu on your computer

· choose Programs
· choose ChatPC Editor and open the program

· go to the Tools Menu on the ChatPC Editor

· go to Transfer Utilities
· select the configuration from the Device Files box to highlight it 

· click the Copy to PC button to start the transfer

You will then see the list of configurations available on the ChatPC device.  Choose the configuration that you would like to import.  The transfer will take some time possibly up to two minutes to transfer.  You now have a copy of the configuration that can be exported to the device in the event that the original becomes corrupted or is accidentally erased.

7.9.Using On-Line Help

ChatPC comes with an on-line help system to aid in solving problems and explain the use of different features.  Although not as comprehensive as this User's Manual, on-line help can be useful when the User's Manual is not at hand.  On-line help is accessed by selecting the Help Topics menu item from the View menu.

7.10.Using an External Keyboard

Your ChatPC can support an optional external keyboard (KeySync keyboard).  The keyboard comes with a very simple Operation Manual and a floppy disk containing the keyboard driver.  If you purchased the keyboard at the same time as your device, the keyboard driver will already be installed.  To check if the driver is installed, simply tap the Start menu and look for an item called "U-KeyMIPS".  Note: You will need to remove the Casio from the rubber case to use the external keyboard.  See section 8.1.

If that item is not there, you will need to first connect your device to a PC by installing the ActiveSync software that comes with the system.  See Section 7.1 for instructions on how to install ActiveSync.  Once your ChatPC device is connected to the PC, follow the instruction in the KeySync keyboard Operations Manual for loading the device driver (it is a simple operation involving copying one file from a floppy disk to your device).

Once the driver is installed you need to turn it on when you want to use the keyboard and turn it off if you want to connect to the PC (since both operations use the serial port).  When the driver is running, a tiny keyboard icon will show up in the bottom right corner of the screen when you are on the Today page.  To turn the driver off, double-tap that icon and hit the close box (X in upper-right corner).

With the driver running, simply plug the keyboard into the serial cable coming out of the docking cradle.  Make sure to also turn the keyboard on by pushing the power switch (located along the left side of the keyboard) away from you.  You can now use the keyboard to type in button titles and messages while programming.

7.11.Prepare for a Software Upgrade

The first step in preparing for a software upgrade is to open the Tools menu and choose Prepare for Upgrade. 

NOTE: This option ensures that all of your personal settings and configurations are saved during the upgrade procedure.

Once prepared, your system can be upgraded by choosing Complete Upgrade. Specific instructions for upgrading your machine should be included with the Upgrade Package. See the Upgrade Package you received with your new memory card for additional details.

2.  ChatPC Hardware

· Hardware Overview 

· Removing the iPAQ from the Rubberized Case

· Replacing the iPAQ Main Battery

· Replacing the iPAQ Backup Battery

· Replacing the Amplifier Battery

· Performing a Soft Reset

· Care and Maintenance
8. Hardware Overview

The ChatPC hardware consists of a HP iPAQ PocketPC computer housed inside a rubberized case.  The case provides protection for the electronic circuits and also holds an audio amplifier and speaker to provide plenty of volume for speaking, even in noisy environments.  
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8.1. Removing the iPAQ from the Rubberized Case

There are instances where you may need to remove the iPAQ from the rubberized case.  For example, you may need to replace batteries, connect the ChatPC to a PC computer for a data down load or you may need to perform a soft reset.

Use the following steps for removing the iPAQ from the case.

1. Unplug the two plugs connecting the iPAQ to the amplifier circuit.  You need to unplug the charging connector in the upper left hand side of the device.  You also need to unplug the audio connector at the top of the unit.  (You may need a small, straight screwdriver to help remove this connector, which is recessed in the rubber case.

2. Push the rubber case at the top of the screen back and pop out iPAQ from the rubber case.

When ready to do so, pop the iPAQ back into the rubber case and reattach the connectors.

8.2.Replacing the iPAQ Main Battery

The main battery is a iPAQ Model#:JK-211LT 3.8V 1100mAh Lithium Ion battery.  You can get this battery at electronic stores that sell Casio portable computers or at www.casio.com.  Make sure that the backup battery is installed when you change the main battery.  (However, if both the main battery and the backup battery need to be replaced, change the main battery as described in this section (including charging) then change the backup battery.)

Note: More detailed information for changing batteries can be found in the Hardware Manual on the Cassiopeia Software Applications Manual CD.

To change the main battery:

1. Remove the Casio from the rubberized case as described above.

2. Move the slide switch on the back of the Casio to the 'Main' position.

3. Push the stylus into the hole at the bottom of the Casio to pop off the main battery door.

4. Remove the battery by pulling on the clear plastic tab.

5. Replace the battery with the new one.  Make sure it is oriented the same way as the one you just removed.

6. Snap the main battery cover back on.

7. Move the slide switch back to the Lock (center) position.

8. Reassemble the ChatPC in the rubber case.

9. Charge the device for 4 hours.

8.3.Replacing the iPAQ Backup Battery

The backup battery is a Model #: CR2032 Lithium watch battery.  You can get this battery at electronic stores and many department stores that sell watch batteries.  Make sure that the main battery is installed and charged when you change the backup battery.  (If both the main battery and the backup battery need to be replaced, first change the main battery as described above (including charging) then change the backup battery.)

Note: More detailed information for changing batteries can be found in the Hardware Manual on the Cassiopeia Software Applications Manual CD.

To change the backup battery:

1. Remove the Casio from the rubberized case as described above

2. Move the slide switch on the back of the Casio to the 'Backup' position.

3. Remove the cover over the backup battery.

4. Remove the backup battery.

5. Replace the battery with the new one.  Make sure it is oriented the same way as the one you just removed (the + side should be pointed out).

6. Snap the backup battery cover back on.

7. Move the slide switch back to the Lock (center) position.

8. Reassemble the ChatPC in the rubber case.

8.4.Replacing the Amplifier Battery

The amplifier battery is a rechargable 9V Nickel Cadmium (NiCad) battery.  You can get this battery at electronic stores.  Note: Only replace the amplifier battery with a Nickel Cadmium battery. 
To change the Amplifier battery:

1. Remove the iPAQ from the rubberized case as described above

2. Replace with a 9V NiCad battery.

3. Reassemble the ChatPC in the rubber case.

8.5.Performing a Soft Reset

There are times you may need to perform a 'soft reset'.  For example if the program 'locks up' you may need to perform a soft reset.  To perform this action, use the stylus to press the Reset button on the bottom of the iPAQ, a half inch to the right of the rectangular synchronization connector.  

8.6.  Care and Maintenance

Your ChatPC device is intended for use in normal communication situations. Your device is not waterproof, so use extreme caution when using it around water.  As with most electronic devices, you should never use ChatPC when you are actually in the water (for example, a pool or bath).

If you wish to clean the plastic and glass portions of your device, use a cloth dampened with water or diluted window cleaning fluid. Do not spray or splash liquid directly on the device. For additional cleaning power, moisten a clean cloth in a mixture of one part water and one part vinegar.

When charging ChatPC, use only the AC charger that came with device. If you discard all or part of your device, dispose of all electronic components according to local regulations. Replacement and repair of the electronic components of your device should only be done by qualified service personnel (except for the speaker battery, which you may replace). Contact Saltillo or your local distributor for instructions on how to get your ChatPC device repaired.

9.  Troubleshooting

Realizing the importance of reliability in a communication aid, we have tried to make ChatPC as reliable as possible.  Due to the software’s complexity, however, you may find that the system does not always behave as expected.  This section contains a list of common problems and solutions.  If the problem you are having is not listed below, refer to the end of this section for how to contact technical support.

· I can't find ChatPC in the Start menu.

· The computer is not responding.

· The computer keeps turning off by itself.

· The screen dims when I don't want it to.

· The screen is too dark.

· The device shows "Cannot find 'ChatPC'…" when I try to run ChatPC.

· What do I do if I get the message "The system has encountered a storage card error…"?

· No speech is coming out when I type.

· It takes a long time for a new configuration to load.

· Why doesn't the icon show up next to ChatPC in the Start menu?

· I lost the tool bar and menus.

· I lost the editor window.

· I can't find my product ID or serial number.

· My ChatPC Demo won’t speak any longer

· Getting Technical Support

9.1.I can't find ChatPC in the Start menu.

The most common problem people have with their ChatPC device is running out of battery power by leaving it unplugged for too long (a week or two).  Some of the software components for ChatPC are stored in battery-backed up memory.  This means that if the battery (and the backup battery) is drained completely, some of the software components will need to be restored.

If both the main and backup batteries have drained completely, nothing will happen when you try to turn on the computer.  Recharge the batteries and follow the instructions below for recovering ChatPC.

· Go the Start Menu

· Choose Programs

· tap on File Explorer

· near the top of the resulting window, tap on My Documents
· when a pop-up menu appears, tap on My Device

· tap on Storage Card in the main window

· tap the file ChatPC Installer (A dialog will appear informing you that ChatPC is going to be reinstalled.)

· tap on OK (After about 10 seconds another dialog will tell you that the process has completed successfully.)

· tap on OK again

· tap on  PowCtrl (it will take only moments for this to load)

· tap on Update (after a few moments you will get a file warning)

· tap YES
Now perform a soft reset as described in the box below.  After performing the soft reset, if ChatPC is not already installed, you should be able to select ChatPC from the Start Menu.


NOTE: You must recharge your ChatPC device after a full day of use or several partial use days.  If the device is going to sit unused for any extended period of time (more than a couple days) it must be plugged in, or you will have to restore the system again.

9.2.The computer is not responding.

If your configuration has "locked up" and nothing that you do will make it respond, you may need to reset the device.  First, try tapping on the hardware record button (on the left side of the device).  This will often lead to a full recovery.  If this does not work, then you will have no choice but to perform a soft reset.

If the menus of ChatPC are still responding and you want to save the text currently in the Editor window, do that now using the Save Text item in the File > Text Files menu. Locate the recessed button on the back of the machine labeled “RESET” and press it using the stylus. All applications that are running at the time of the reset will be stopped. You will not lose any changes to the options set through the dialog boxes.

9.3.The computer keeps turning off by itself.

The ChatPC computer is designed to conserve battery power  (your iPAQ 3835 user's manual describes this feature in detail).  The computer is set to power down after several minutes of inactivity.  You can adjust the amount of idle time before the computer will automatically power down by: 

· Go to the Tools menu

· Go to Options

· Go to System

· Go to Suspend after:
The first option is use system settings.  If this choice is selected, you control the "Power Off" settings through the Settings dialog ( Power dialog (at the bottom of the System screen).  That dialog will allow you to set the computer to power off between 1 and 5 minutes.  If you need to have the power stay on longer than 5 minutes (such as during a demonstration), use one of the other settings (10, 20, 30, 40, or 50 minutes).  Using a setting of infinite, will keep the power on continuously.  This is dangerous since it can drain the batteries completely.

If these settings are correct, and your machine still powers down after a short time of inactivity, it may be low on battery power.  This condition is usually accompanied by a warning message from the system.  If this is the case, either run the computer from a powered outlet or recharge the batteries as soon as possible.

9.4.The screen dims when I don't want it to.
Another battery saving feature of PocketPC  devices is called Auto Dimming.  You can adjust the amount of time the system will wait before it dims the screen or you can turn this feature off entirely.  To change the dimming settings:

· Go to the Tools menu

· Go to Options

· Go to System 

· Go to Settings Dialogs

· Choose Brightness

· Choose Auto Dim

Adjust the settings as desired.  

WARNING: Increasing the time before the backlight is dimmed or turning Auto Dimming off entirely can dramatically decrease battery life.

9.5.The screen is too dark.
You can adjust the screen brightness and contrast by:

· Going to the Tools menu

· Go to Options

· Go to Settings dialogs

· Choose brightness

Adjust as needed.

WARNING: Increasing the brightness of the screen can dramatically decrease battery life.

9.6.The device shows "Cannot find 'ChatPC ... '  when I try to run ChatPC.

The complete text of the message is
Cannot find 'ChatPC' (or one of its components). Make sure the path and filename are correct and that all the required libraries are available.

Try the following remedies in order.  After each one, try to run ChatPC.

1. Reseat the MultiMedia Card by:

· removing the Casio from the rubberized case (see section 8.1.)

· sliding the slide switch toward Free on the back of the Casio

· open the rubber door

· push down on the thin black MultiMedia card to release it

· reseat the card into it’s slot making sure that it latches into place (you may need to try seating the card a couple of times before it latches properly, the mechanism alternates releasing and latching the card)

· move the slide switch to the left, away from Free to lock the card into place

· Turn the device back over and turn it on

· If ChatPC is running:

· Re-load your configuration and you should be set to go, 

· If ChatPC is not running:

· Tap the Windows Flag in the upper left corner

· Choose ChatPC from the menu

If ChatPC is not in the Menu proceed with reinstalling the ChatPC Software as described next.

2.  Reinstall the ChatPC Software

· Go the Start Menu

· Choose Programs

· tap on File Explorer

· near the top of the resulting window, tap on My Documents
· when a pop-up menu appears, tap on My Device

· tap on Storage Card in the main window

· tap the file ChatPC Installer (A dialog will appear informing you that ChatPC is going to be reinstalled.)

· tap on OK (After about 10 seconds another dialog will tell you that the process has completed successfully.)

· tap on OK again

· tap on  PowCtrl (it will take only moments for this to load)

· tap on Update (after a few moments you will get a file warning)

· tap YES
· remove the iPAQ from the rubberized case (see section 8.1)

· turn the device on

· press the Reset button on the bottom of the iPAQ
If ChatPC is not already installed, you should be able to select ChatPC from the Start Menu.

9.7.What do I do if I get the message "The system has encountered a storage card error…"?
The complete text of the message is

The system has encountered a storage card error (error code 5). If a storage card was removed, please reinsert it, and then select Yes to retry or No to fail.

WARNING:  Failing this error may result in lost data.
This message will be encountered if you remove the MultiMedia card while the ChatPC software is running.  It could also possibly indicate a the MultiMedia card may not be seated properly in it’s slot.

Reinsert the MultiMedia card if it has been removed. If the card is already in, reinstall the card by:

· removing the iPAQ from the rubberized case (see section 8.1.)

· sliding the slide switch toward Free on the back of the Casio

· open the rubber door

· push down on the thin black MultiMedia card to release it

· reseat the card into it’s slot making sure that it latches into place (you may need to try seating the card a couple of times before it latches properly, the mechanism alternates releasing and latching the card)

· move the slide switch to the left, away from Free to lock the card into place

· reassemble the ChatPC into the rubber case.

9.8.No speech is coming out when I type.

There are four items that may be causing speech problems. 

· Check the speaker control on the right side of the ChatPC and make sure it is turned on (set to the 1 setting).  

· Turn the volume knob clockwise to increase volume. 

· If other sounds – such as screen tap clicks and pop-up window noises (like when you exit the software) – are still working, the problem might lie in the software settings for speech. To view the settings, bring up the speech tab under the options dialog (from the View menu, select Options… and then the Speech tab).  Make sure that the synthesis type is set to software.  Review the voice and speech settings to ensure they are correct, and be sure the volume is towards the loud setting

· Test and (if necessary) replace the speaker battery (see below).

If speech still is not working, you will need to determine if the failure is in the speaker or on the computer.  To do this, unplug the speaker and listen to the on-board speaker to see if speech is working.  (The speaker connector is at the top of the device. You may need a small screwdriver to pry out the connector which is recessed in the rubber case.) Since the on-board speaker is not amplified, you may have to do this in a quiet environment.  If you can hear the speech when the speaker is unplugged, the battery may be discharged.  Plug the charger into the jack on the lower-right hand side of the ChatPC.  Plug the speaker back in and try the speech again.  If the speaker only works when the charger is plugged in, you may need to replace the speaker.  Replace the battery only with a 9V Nickel Cadmium battery.

 See if the speech or other operating system sounds are produced by your device.  If speech is the only sound not coming from your device, start up ChatPC and double check the speech settings.  If your speaker or your computer is damaged, contact a technical support representative for instructions on how to proceed.

9.9.It takes a long time for a new configuration to load.

There may be some situations where your ChatPC computer is running too many programs and is low on memory or the memory has become corrupted and needs to be "reinitialized".  This situation is most easily recognized when configurations take much longer than normal to load.  This inconvenience is easy to fix by following these simple steps.

If ChatPC is already running, exit the program and shut down any other programs that may be running.  By using the Task Manager (which can be accessed through the Start button, Settings options, System tab, Memory icon, Running Programs tab), you can view and shut down all of the programs running on your machine.  After restarting ChatPC, the configurations should load more quickly.

If ChatPC has been loading a configuration for quite some time (5 minutes or more), and your system is not responding, you may need to reset the machine.  See the box on page 52 for performing a soft reset.  For additional details on resetting the device see your HP iPAQ 3835 owner's manual.  Once reset, the machine should function normally and load times for your configurations will return to normal.

9.10.Why doesn't the Saltillo icon show up next to ChatPC in the Start menu?

There normally is a small icon based on the Saltillo logo that shows up just to the left of the words "ChatPC" in the Start menu.  If you reset the machine (by pressing the reset button) then select the Start menu within about 4-10 seconds, the system will not be able to find the MultiMedia card (since it has not turned on yet) and will therefore not be able to find the correct icon.  It will instead substitute a default icon that looks like a window.  This situation does not hurt anything, but it is easily remedied.  Simply reset the machine by removing the iPAQ from the rubberized case as described in 8.1.  Then with the device on use the stylus to press the Reset button on the back of the iPAQ and wait about 10 seconds before accessing the start menu.  Now the proper icon will be displayed.

9.11.I lost the tool bar and menus.

The tool bar and menus are hidden when the system is put into Full Screen mode.   To get out of Full Screen mode, press the Voice Recorder button located on the left side of the device.  See section 3.5.2. for more details on Full Screen mode. 

9.12.I lost the editor window.

If you do not have an editor window showing then you need to display it by checking the Main Editor option under the view menu. 

9.13.I can't find my product ID or serial number.

Your product ID is located under the Help menu in the About ChatPC… dialog box.  

The serial number for your computer hardware is located on the back of the iPAQ computer.  You will need to remove the iPAQ from the rubber case in order to see it.

9.14.My ChatPC Demo won’t speak any longer

Speech synthesis in the PC Demo version of ChatPC is disabled 90 days after it is installed on your desktop or laptop machine.  Only speech will be disabled – everything else will work normally.  When your 90 days runs out, you will be notified by a dialog.  

Getting Technical Support

If you run into problems that you can’t solve by any of the above methods, contact technical support by phone at 1-800-382-8622 between 9 AM and 5 PM EST, or by email at service@saltillo.com.  We’ll do our best to get things working as quickly as possible.

10.  Warranty

The ChatPC is covered by warranties by Saltillo Corporation and Hewlett Packard.  All warranty and service should be arranged through Saltillo Corporation.

The Saltillo warranty covers the rubberized case and its included amplifier, battery and speaker.  Saltillo warrants these parts to be free from defect in material and workmanship under normal use for a period of one year from date of purchase.

The Casio warranty covers the Casio EM-500 computer.  Casio warrants the EM-500 to be free from defect in material and workmanship under normal use for a period of one year from date of purchase.  This warranty will not apply if the product has been misused, abused or altered.  Casio considers bending of the unit or any breaks or cracks in the LCD screen to be misuse.  Help to protect your ChatPC by using it in the protective rubber case and the optional carrying case. 
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Note: If you are using VocabPC or the Symbol Base configurations as the basis of your configuration, a template page has been created for you.  To create a new page, make a duplicate of the template instead of creating a new blank page.  See Duplicate Page below.





Note: If you are using VocabPC or the Symbol Base configurations as the basis of your configuration , a template page has been created for you.  Choose the template page from the drop down list prior to choosing Duplicate Page.





Note:  Be sure to save the interface after you've created the password:
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WARNING: The computer is designed to power off automatically to conserve battery power.  Use this power control dialog with care or you may cause the batteries to be completely drained, which may cause a loss of data.





Important Note:  Always make sure that you have the current vocabulary (configuration) from your ChatPC unit prior to making changes on the PC Editor.  





NOTE:  Importing a configuration to your desktop is a great way to backup your custom configurations.  Another good way to back them up is to use Pack Config (see below) to pack them and then copy them from your device to a floppy or zip disk.








Performing a Soft Reset: The reset switch is located on the bottom of the iPAQ computer.  To perform a soft reset:


unplug the two cables attaching the Casio to the amplifier circuit in the rubber case (The charger cable in upper left hand corner needs to be unplugged.  Also unplug the audio connector at the top of the ChatPC (you may need a small screwdriver to pry out the connector which is recessed in the rubber case).  


press back on the rubber case at the top of the screen and pop the Casio computer out of the case


turn the device On


using the stylus, press the Reset button on the back of the Casio computer


reinstall the Casio into the rubber case by popping it back into the rubber cases and reattaching the connectors.





NOTE: You cannot cut and paste between the PC Editor and other applications.
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