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Section 1

Executive Summary

This paper describes a simple implementation of Portal’s Infranet® Software (Version 6.0.3) on Dell™ PowerEdge™ Servers in a simulated Application Solution Provider’s (ASP) environment.  For this study, the simulated ASP will use Microsoft® Exchange™ 2000 Server as the hosted application providing email for the simulated customers.  Documenting the integration of Infranet software into this simulated ASP environment should help ASPs who are considering integrating Infranet into their solution.

Portal Software is a leading provider of software for customer management and billing solutions for next-generation communications and e-services. Portal’s Infranet software is a robust, extensible, and customizable software platform that can be integrated with existing applications to perform customer management and to create and customize billing solutions.  When integrated into an ASP environment, Infranet offers a comprehensive solution for managing customers and provides optimal business models and pricing plans to allow the ASP to customize service offerings for it’s users.

For this study, Infranet software was installed in a single server configuration (Infranet’s demo configuration) and integrated into a simple ASP solution to document the process for this simple deployment.  Infranet was integrated into Microsoft Exchange 2000 Server, the hosted ASP solution. With this configuration, only Infranet client applications required to complete this solution were used.  Using this single server installation, testing, tuning, and validation were done to better understand the deployment of Infranet in a real ASP environment.

Section 2
Introduction

Internet infrastructure build-out is expected to continue at a rapid pace, with much of that growth manifesting itself within the Service Provider (SP) space. Industry leading Application Service Providers (ASPs), Internet Service Providers (ISPs), Web Hosting and other emerging technology providers are seeking efficient and cost effective methods of deploying and managing the ever growing racks of servers, storage, appliances and networking gear which is required to keep pace with the demands of their customers.

In order to provide a complete solution to Service Providers, Dell’s Internet Partner Division (IPD) has been created to facilitate delivery of services tailored to the unique needs of this market segment. This strategy involves not only highly customized offerings and services for the full range of Dell PowerEdge Servers, PowerApp™ Appliances, and PowerVault™ Storage, but also includes partnerships with key software solution providers which provide high value add for the Service Provider. 

Portal Software, via its partnership with Dell, offers Infranet, a customer management and billing solution for next generation services, including Internet Protocol (IP) services. Portal entered into the billing business in the mid-90s by providing billing solutions for ISPs, and has evolved its technology to support new market segments as they emerge.  The latest versions of Infranet are enhanced to incorporate features designed to address the needs of ASPs. Portal’s Infranet provides key, integrated components of the business process infrastructure for the Service Provider, thereby allowing the SP to focus on its core competency of bringing new and innovative services to customers.

This paper provides a description of Portal Infranet as well as a high level description of the deployment of this software on Dell PowerEdge Servers in a low-complexity scenario in a Service Provider setting. Infranet installations are typically customized to the specific requirements of the Service Provider, so this paper is not presented as a comprehensive, step-by-step guide for all installations. 

Section 3

Portal Infranet Software Overview

Infranet is a customer management and billing software platform for communications and e-services that provides the implementer with advanced features to allow customization for their solution.  It delivers virtually unlimited flexibility and exponential scalability for managing and accelerating the implementation of complex, multi-service Internet business models. Infranet also allows ASPs to develop pricing and provision services to effectively manage customer usage, and encompasses the ability to provide sophisticated billing information while remaining flexible enough to meet changing market demands.

ASPs need flexibility in handling sophisticated billing information to meet the needs for different customer environments. Infranet can track account usage across the corporation using hierarchies that match the organizational structure of the company. This allows the flexibility to itemize and bill different organizations in a way that meets the customers needs. Using Infranet’s various reports the ASP can track accounts receivable and payable, cash flow, credit card details, general ledger, taxes, new and closed accounts, and customer usage information.

As the demand for hosted applications increases, the ASP will be faced with demand to offer complex combinations of services as product suites.  They will require tools to define collections of applications as solution offerings and to create pricing models that can dynamically change to meet market demands.  Infranet provides support for many business models with the flexibility to create pricing terms that are tailored specifically for a customer’s needs.  In addition to addressing the billing needs for hosting applications, Infranet offers integration with a full range of other services like Dial-up, virtual private networks (VPNs), wireless internet, voice and fax over IP, and other services.

Infranet was designed with to scale to support enterprise customers while also providing secure, reliable service. In order to provide exponential scalability Infranet is based on an open architecture to allow rapid deployment of new software packages into the ASPs set of solutions. Using Infranet’s four-tier, client-server architecture the ASP can spread the load across multiple servers.  Various load balancing techniques can further improve scalability.  Reliability and availability are enhanced by the software’s ability to take advantage of redundant processing capabilities with automatic re-routing of connections between tiers.

Implementing Infranet

Infranet is intended to support implementations enterprise users. To provide maximum scalability, reliability, and availability, the implementer would distribute Infranet components across several servers to achieve the desired performance.

An implementation of Infranet can range from a single demonstration server to a multi-tier, multi-server installation. The single server installation will be discussed in this paper.  All components of Infranet will be installed and configured on a single server, along with the SQL database.  Many different solutions use Infranet in the implementation. This paper is intended to discuss a simple implementation of Infranet as an ASP solution.

Using Infranet can accomplish the following tasks and can save the ASP from writing and maintaining their own in-house customer management and billing software. The tasks are:

· Set up a pricing model to charge for services

· Register customers over the Web or by using customer service representatives (CSRs)

· Perform authentication and authorization for customers whenever they use ASP services

· Track all activity, including customer activity, CSR activity, and Infranet system activity

· Bill customers directly to their credit cards or by sending an invoice

· Manage customer accounts

A feature in Infranet is the ability to provide customers with offerings or software applications that are tracked and monitored and can be billed based on certain criteria like usage or fixed fee.  The tracked or monitored information is passed to Infranet where it is processed based on a price list configured for that customer.

Infranet Four-Tier Architecture

The Infranet system is based on a four-tier architecture that provides scalability by allowing ASPs to spread increasing computational loads across as many servers as needed. The four tiers consist of Application Tier, Business Process Tier, Object Tier, and the Data Tier. (See Figure 1.)
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Figure 1 Infranet Architecture in an ASP solution

1. The Infranet Client Applications, or Application Tier, can consist of two types of client applications:

· The client tools, Infranet Administrator and Infranet Customer Center, are used for system configuration and user administration.

· Custom applications are written to integrate third-party applications and capture customer usage data. 

2. The Connection Manager Tier, or Business Process Tier, is comprised of Connection Managers (CM) and Facilities Modules (FM). CM provides the connection between the client applications and the rest of the Infranet system. FM processes the data passed in by the client applications.

3. The Data Manager, or Object Tier, is a set of Data Managers that translate the request passed by the CM into a language that the Database can recognize.

4. The Database, or Data Tier, consists of the Infranet Database as well as other data access systems.

Infranet provides a comprehensive set of system tuning guidelines that allow the ASP to configure the system to match the application.

Transaction management functions have been built into the software’s object layer to take full advantage of available hardware. Reliability and availability are enhanced by the software’s ability to take advantage of redundant processing capabilities with automatic re-routing of connections between tiers.

Using Infranet’s Software Development Kit 

Infranet is based on an open architecture that allows the ASP to integrate applications using the documented API.  It is also possible to customize standard features of Infranet, which allow the integration of Infranet into a custom solution. 

Using Infranet’s Software Development Kit (SDK), an ASP can customize Infranet for their specific business solution.  Using the SDK, developers can create custom objects or modify existing objects.  Also included with Infranet are a set of client applications, business policies, Data Managers, and storage objects that can be modified and enhanced to better integrate with the ASPs solution.  They are:

· Infranet can be customized at several different levels.

· Customized applications can be written that take data from a third-party and pass the data to Infranet for processing.

· The default policies can be modified to better implement business objectives.

· A new storage class can be created to hold information needed for the business solution.

· Create a new Facilities Module to add additional business logic.

· Create a new Data Manager to access a custom storage system.

Figure 2 illustrates the different levels of Infranet that can be customized to better implement the ASP’s solution.  When Infranet is customized for the ASP’s solution, it may involve changes to more than one of Infranet’s components.
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Figure 2 Infranet’s different levels of customization

Section 4
Simulated ASP Architecture for Deploying Infranet

The Servers

The Dell Technical Marketing Application Service Provider (DTM ASP) was designed to be a simple ASP environment configuration to validate the integration of software packages on a low-end Dell Enterprise Server configuration, while still providing some level of scalability for future growth.  Microsoft® Exchange™ 2000 was selected to be the application provided by the DTM ASP because most customers require email services and Exchange is a very popular email server application.  

In a low-end configuration of Infranet, it is possible to install and run the entire product on a single server.  The Dell PowerEdge™ 2450 was selected as the server for this test because of its small rack footprint size and expandability.  It was configured with Windows® NT Server 4.0, Microsoft SQL Server™ 7.0, and other necessary Infranet components.   A Dell PowerEdge 6450 was used as the Exchange 2000 server.  See Appendix A for complete hardware configuration information.

The Clients

Client workstations were used to simulate a large number of users running Outlook email client accessing Dell’s DTM ASP Exchange email application.  The client workstations were Dell OptiPlex GX1 500L systems with single 500 MHz Pentium® III processors, 256MB memory and 100BaseT Network Interface Card (NIC).  They were configured with Windows 2000 Professional, and Outlook 2000. A simple batch file was created for each of the clients that used MAPI to send a fixed number of messages from each client.

The Network

A switched 100 Mbps Ethernet local area network (LAN) environment was used to connect all the systems.  No wide area network (WAN) environment was used because the objective of this test was to validate Infranet software on Dell PowerEdge servers.  The network was not a focus of the test.

Figure 3  shows Infranet installed on a single server.
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Figure 3 Configurations for Simple Portal Implementation

Scalability of Servers

As the number of customers and users increase, Infranet capacity can also increase by distributing Infranet components to multiple servers.  The ability to add capacity to an Infranet system by adding new servers allows it to grow as needed.  ASPs who choose Infranet on Dell PowerEdge servers for their customer billing solution can scale up as their business grows. The test of Infranet on a PowerEdge 2450 is designed to give ASPs an idea of what type of capacity and performance is available on the low end.  

The Infranet four-tier architecture allows for scalability for large deployments.  All of Infranet can be installed on the same server, as has been done for this test, in a low-end scenario.  For more high-end Infranet solutions, each tier could be placed on a separate server or multiple servers could be used for each tier.

The three-tier model often recommended by Dell for configuration of server infrastructure applies to Infranet as well.  The first tier is the Infranet Client applications.  The second tier is for the Connection Manager and Data Manager layers of Infranet.  The third tier, otherwise known as the backend, is for the database.  Figure 4, which maps the four-tier Infranet architecture to the commonly used three-tier server model, provides some insight into what types of servers should be used as more servers are added to an Infranet installation.
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Figure 4 Infranet Architecture on Dell 3-Tier implementation 

The low-end Infranet solution tested here will first start to encounter bottlenecks in the database.  The first system added to the configuration will need to be a dedicated Database server.  The step up would then be an additional system to handle the Infranet client applications.  By separating first the database and then the client applications, the configuration has now reached a mid-level of complexity.  Additional systems would be added based on the specific environment.  At the high-end, it would be beneficial to add a Storage Area Network (SAN) for the database.  This would help to increase database performance and allow for a higher maximum storage capacity.

Section 6
The Test Methodology

The intent of this study was not to create a real ASP environment, but to document the integration of Infranet into a simulated ASP environment. For this study, Infranet was installed on a single server (Infranet’s Demo configuration) and Microsoft Exchange 2000 was selected as the hosted application used to generate test data. Scenarios will be created which represent a day of user activity for the simulated ASP environment. The number of users for each scenario will be increased by a factor of 10 as time and resources allow.  This will increase the size of the log file that will be loaded into the Infranet database.

The Windows 2000 logging facility will be used to capture data imported into Infranet for each scenario.  This data will then be processed by Infranet against multiple Price Plans, configured using Infranet’s Pricing Tool, and the results will be validated.  Resource utilization will be monitored and documented for each of the scenarios, so that an ASP would better understand the requirements for deploying Infranet in their environment.

Infranet provides many client tools that can be customized for an environment.  Most ASPs will need to write some custom code to integrate Infranet into their solution.  Infranet supports multiple client libraries to support C, C++, Java, and Perl. These libraries provide the flexibility needed to integrate Infranet into an ASP’s environment.

Perl scripts were used to pre-process the log files and to automate the import of data into Infranet, using Infranet’s Universal Event Loader (UEL) client application.  Using Perl scripts with UEL to import the data into the Infranet database was relatively simple.

Configuration Validation Test

Since the installation and configuration of Infranet requires several servers (Infranet Server, database server), and several client applications it is a good idea to have sample log files to validate and tune the environment. As Infranet client applications are installed and configured, use the sample log files to verify the configuration works as expected.

The ASP Test Clients

Dell OptiPlex computers were configured as MAPI clients running MS Outlook 2000 and connected to Dell’s Microsoft Exchange server.  Each system represented an ASP customer, and executed a MAPISend batch file that sent a predetermined number of mail messages.

The Exchange Server was configured to log the number of mail messages sent by each of the client system.  The log was then parsed using Perl scripts to simplify data. The simplified log data was then imported into Infranet.

 Test Scenarios

A scenario consists of a number of client systems sending a predetermined number of mail messages.  The Exchange server was configured to log the number of mail messages sent from the clients in the application log.  Then Perl scripts were used to load the data into the Infranet database.

· MAPISend200 to MAPISend60K – represent a DOS batch program that send the number of messages represented by the file name.

· Run200 to Run200K - represent the application logs containing the number of messages represented by the name of the file.

Table 1 shows the number of messages sent by each client to create each of the application log files.

Table 1 Simulation Matrix
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Infranet Pricing Plans

Three plans were created for pricing application usage for Dell’s ASP, and as customers are created, they are associated with a plan. By reviewing the different price plans it is possible to see the flexibility of the pricing tools and helps individuals to better understand how to customize their own plan. Step-by-step instructions on how the price plans were created are included in Appendix D.

Price Plans include:

· 100050 – This plan will charge an initial $20 setup fee and $50 per month for the first 1000 messages and then a per message fee of .03 cents.

· Flat – This plan charges a $20 setup fee and $50 per month unlimited messages.

· Tiered – This plan charges a variable fee that is based on the number of messages sent per month.  Zero to 100 messages are .10 cents each; 101 to 1000 messages are .08 cents each; and over 1001 message are .05 cents each. 

Section 7
Test Results Summary

Validating the Configuration

After installing and configuring the Infranet Server, the Infranet client applications were installed and configured to complete this simulated ASP solution.  Sample log files of various sizes were used throughout the installation and configuration to validate and debug the solution.

Improving Performance

Even though Infranet documentation provides suggestions for improving the performance of importing log files into Infranet using UEL, it became apparent that a large log file required more time to load than had been planned for in the execution of each test scenario (24 hours).  As the log file size doubled, the amount of time it took to load into the Infranet database grew exponentially. (See Table 2.) The performance of loading log files using UEL could be improved using Perl scripts to parse relevant data from the log files and splitting the large log files into smaller files that the UEL could process much faster.  By keeping log files to about 50 entries per file or by splitting large log files into smaller log files of about 50 entries each allowed a more consistent load time into the Infranet database.  So by splitting a large log file into a fixed number of entries per file allowed for a calculated load time for all of the smaller files (time to load one file times number of files = total load time).

Table 2 Test Case Execution Matrix
	Test Case
	Execution Time
	CPU Time
	Memory
	PhysicalDisk Time

	Run200
	34 sec
	45%
	<200M
	<4%

	Run2000
	5.3 min
	48%
	<200M
	<4%

	Run20000
	53 min
	49%
	<300M
	<6%

	Run200000
	Not Available*
	56%
	Not Available*
	Not Available* 


* Loading very large log files into Infranet is not very practical when considering the amount of time it takes to load when using UEL. Keeping the log files under 100 entries per file provides the best performance.

Execution Time - The amount of time required to load the data into the Infranet database.  The log files were split into smaller files that contained 50 entries each. 

CPU Time - % User Time. As long as only one copy of the UEL was run at a time, the CPU utilization remained consistent.  When running multiple copies of the UEL program to load the log files the % User Time increased to about 90%, with Total CPU utilization going to 100%. 

Memory – The UEL is a command line Java application that uses a minimal about of memory.

PhysicalDisk Time – The amount of time accessing the disk remained low even when loading large log files.

Section 8
Conclusions

By keeping this study as simple as possible yet including detailed information, an ASP planning to integrate Infranet software should be better able to understand the process of the integration.

Even though Infranet offers flexibility when integrating into an existing environment, careful planning should be done to choose the hardware configuration that will provide the flexibility necessary to integrate Infranet into an ASP solution. By starting with a single server configuration on a robust server like the PowerEdge 2450, the initial testing, integration, and validation work can be done on this single server configuration.  Then this system can be deployed into a production environment and additional systems can be added to scale Infranet to the ASPs solution.  The first step to scale Infranet would be to move the database onto a separate server. Then additional servers could be added to the configuration to create redundant Infranet components to further scale the solution. Infranet’s architecture allows for additional servers by changing the configuration to point to the new servers.

Infranet provides a robust solution that offers flexibility when integrating into an existing environment. The ASP implementer should plan to customize Infranet to tightly integrate it into their solution. This may involve programming to customize existing applications as well as writing applications or scripts to import the data into Infranet.

Customization of an existing application may be required in order to get relevant data from applications into Infranet.  After deciding on how to bill a customer for application usage, the ASP implementer will need to figure how to get this data from the application so that it can be imported into Infranet.  Some applications log information into the Windows 2000 application log.  Therefore, if the information that an ASP wants to use is already being logged it is easy to import that into Infranet.  If the ASP’s applications don’t log the required information for billing the customer, then customization of the application is required.

Using a Perl script to filter an application log file before creating a template with Universal Event Mapper (UEM), simplified the customization of UEM.  Also, using Perl scripts to filter and load the application log files into Infranet improved performance and allowed consistent load times regardless of the log file size. By splitting large log files into smaller files containing 50 entries each, consistent results regardless of the log file size were achieved. 

Infranet uses its own log files and configuration files and not the Windows application log or the system registry.  Therefore, plan on monitoring the Infranet log files to make sure there is adequate space for them to grow.  Understanding the information contained in the configuration file will help to customize Infranet for a specific ASP deployment.


Dell, PowerApp, PowerVault and PowerEdge are trademarks of Dell Computer Corporation.  Microsoft, Windows, SQL Server and Exchange are registered trademarks or trademarks of Microsoft Corporation. Intel and Pentium is a registered trademark of Intel Corporation. Portal and Infranet are trademarks of Portal Software, Inc. or its subsidiaries. Other trademarks and trade names may be used in this document to refer to either the entities claiming the marks and names or their products.  Dell disclaims proprietary interest in the marks and names of others.

©Copyright 2001 Dell Computer Corporation.  All rights reserved.  Reproduction in any manner whatsoever without the express written permission of Dell Computer Corporation is strictly forbidden.  For more information, contact Dell.  Dell cannot be responsible for errors in typography or photography.

Information in this document is subject to change without notice.

Section 9
Acknowledgements

Fred Gonce and Todd Muirhead would like to acknowledge Tom Kolnowski, Dave Jaffe, Richard Hou, Amy Jimenez, John Ellis, and Guy Westbrook for their assistance in providing feedback and help with hardware and software that was used for this testing.

Appendix A: Server Installation

This section describes the installation steps and software applications used in this study. For more information on Portal products and services, see http://www.portal.com. 

Server Software 

Table 3 lists the software required for each of the servers used in this study.  Review this list to better understand the software required for each of the servers used for this configuration.

	Server Name
	Function
	Required Software

	XPSERV1
	Infranet Server
	Microsoft Windows NT Server (with SP 6) SQL 7.0 (with SP 2) Infranet.

	XPEXCH1
	Application Server, MS Exchange 2000 
	Microsoft Windows 2000 Advanced Server (with SP1) with MS Exchange 2000

	XPDCSERV
	Domain Controller, DHCP Server, DNS Server
	Microsoft Windows 2000 Advanced Server (with SP1), Active Directory, IIS, DHCP, DNS


Table 3 Server name and function with required software

Preparing for Infranet installation:

The following software applications were used in preparation for the Infranet installation described in this paper.

· Microsoft Windows 2000 Advanced Server w/SP1 

· Microsoft Windows NT Server w/SP 6

· Microsoft SQL 7.0 w/SP2 

· Microsoft Exchange 2000

· Infranet software web site to download Infranet software 6.03

· WinZip software to extract downloaded package

· Access to the Infranet documentation for installation, configuration, and deployment

· Install Windows 2000 Advanced Server with Service Pack 1.

Installing Domain Controller

The following steps were taken to install the Domain Controller used in this study.

· Install Windows 2000 Advanced Server with Service Pack 1 

· Install Active Directory for use with MS Exchange Server

· Install DNS and verify name resolution between systems using “nslookup <hostname> or <IP address>”.

· Install DHCP. Because there are several servers and many clients, DHCP was used and reservations for server systems were assigned.

Installing Infranet Server on PowerEdge 2450

For this installation, it was necessary to install all the components of Infranet and Microsoft SQL 7.0 (SP2) on a single system.

· Install Windows NT Server with Service Pack 6 (default installation)

· Join the domain.

· Install SQL 7.0 with SP2.  
· Follow Portal’s “Configuring SQL Server on Windows NT” for details on installation and configuration of SQL and ODBC.

· Follow Infranet’s instructions for configuring SQL for Infranet.

· Install Infranet 6.0.1

· Then, install Infranet 6.0.3 patch.

· Install Infranet client packages: Administrator, UEM, UEL, and Pricing Tool.

Installing Microsoft Exchange Server on PowerEdge 6450

· Install Windows 2000 Advanced Server with Service Pack 1 

· Select NNTP under IIS during install

· Join the domain of the Domain Controller (DC).

· Log on as “Administrator” on the domain.

· Install Microsoft Exchange 2000
Installing and configuring the clients

· Install Windows 2000 Professional with Service Pack 1

· Install Microsoft Outlook 2000

· Copy custom mail script to test directory

Appendix B: Hardware Configuration


Server Hardware Configuration

PowerEdge 2450

2 - CPU 866 Mhz

1024 Mb Ram, 

2 - 16 gig drives (RAID 1)

Intel Pro 10/100

PowerEdge 6450

CPU 700 Mhz

512 Mb Ram

4 - 16 Gig drives (RAID 5)

Intel Pro 10/100

Client Hardware Configuration

OptiPlex GX1

CPU 700 Mhz

256Mb Ram

10gig

Intel Pro 10/100

Appendix C: Detailed Test Results

 
Tables 4 through Table 7 show the results achieved for each test case.

Table 4 Test Case Results for Run200

	Run200
	Initial Value
	Execute_Testcase
	Bill_Processing

	Customer
	# msg
	Plan
	$
	Counter
	$
	Counter
	$
	Counter

	A
	200
	100050
	20
	-1000
	20
	-800
	70
	-1000

	Execution Time
	34 sec
	5 sec


The performance monitor was run on a separate server to find resource bottlenecks. 

· Processor: % User Time - about 45%

· PhysicalDisk: % Disk Time  - about 1%

· Memory: Committed bytes – less than 200M (for entire system)

Table 5 Test Case Results for Run2000

	Run2000
	Initial Value
	Execute_Testcase
	Bill_Processing

	Customer
	# msg
	Plan
	$
	Counter
	$
	Counter
	$
	Counter

	A
	200
	100050
	20
	-1000
	20
	-800
	70
	-1000

	B
	200
	Tiered
	50
	-
	50
	200
	116
	0

	C
	600
	Flat
	70
	-
	70
	-
	120
	-

	D
	1000
	100050
	20
	-1000
	20
	0
	70
	-1000

	Execution Time
	5.30 minutes
	7 sec


The performance monitor was run on a separate server to find resource bottlenecks.

· Processor: % User Time - about 48%

· PhysicalDisk: % Disk Time  - less than 4%

· Memory: Committed bytes – less than 200M (for entire system)

Table 6 Test Case Results for Run20000

	Run20000
	Initial Value
	Execute_Testcase
	Bill_Processing

	Customer
	# msg
	Plan
	$
	Counter
	$
	Counter
	$
	Counter

	A
	200
	100050
	20
	-1000
	20
	-800
	70
	-1000

	B
	200
	Tiered
	50
	-
	50
	200
	116
	0

	C
	600
	Flat
	70
	-
	70
	-
	120
	-

	D
	1000
	100050
	20
	-1000
	20
	0
	70
	-1000

	E
	6000
	Tiered
	50
	-
	50
	6000
	300
	0

	F
	6000
	Flat
	70
	-
	70
	-
	120
	-

	G
	6000
	100050
	20
	-1000
	20
	5000
	220
	-1000

	Execution Time
	53 minutes
	10 sec


The performance monitor was run on a separate server to find resource bottlenecks.

· Processor: % User Time - about 49%

· PhysicalDisk: % Disk Time  - less than 4%

· Memory: Committed bytes – less than 200M (for entire system)

Table 7 Test Case Results for Run200000

	Run200000
	Initial Value
	Execute_Testcase
	Bill_Processing

	Customer
	# msg
	Plan
	$
	Counter
	$
	Counter
	$
	Counter

	A
	200
	100050
	20
	-1000
	20
	-800
	70
	-1000

	B
	200
	Tiered
	50
	-
	50
	200
	116
	0

	C
	600
	Flat
	70
	-
	70
	-
	120
	-

	D
	1000
	100050
	20
	-1000
	20
	0
	70
	1000

	E
	6000
	Tiered
	50
	-
	50
	6000
	300
	0

	F
	6000
	Flat
	70
	-
	70
	-
	120
	-

	G
	6000
	100050
	20
	-1000
	20
	6000
	220
	-1000

	H
	60000
	Tiered
	50
	-
	50
	60000
	3100
	0

	I
	60000
	Flat
	70
	-
	70
	-
	120
	-

	J
	60000
	100050
	20
	-1000
	20
	59000
	1770
	1000

	Execution Time
	Not Available*
	Not Available*


*Due to the large size of the log files used in this test case, execution times were not possible. 

Dell monitored the performance on the server by running a performance monitor on a different server to see if there were any resources bottlenecks.

· Processor: % User Time - about 56%

· PhysicalDisk: % Disk Time  - about 4%

· Memory: Committed bytes – less than 300M (for entire system)

Appendix D: Configuring Infranet for the ASP 

 
Overview

1. Creating a Custom Application Log File

2. Create a Custom Event and Service

3. Create Price Plans

4. Product

5. Deal

6. Plan

7. Plan List

8. Create a Custom Template

9. Create Users

10. Loading Data into Infranet

Creating a Custom Application Log File

To determine what data needed to be tracked and logged, Windows 2000 event logging facilities was used to log user activity on the Exchange 2000 server.

Create a Custom Event and Service 

Using Developer Workshop,  a custom event and service for the  ASP solution was created.

Start “Infranet Developer Workshop” 

Connect to Infranet

User Name: root.0.0.0.1

Password: password

CM Host Name: <hostname>

CM Connection Port: 11960

Database Number: 0.0.0.1

Edit “\sys\dm_odbc\pin.conf”

Set “- dm dd_write_enable_fields = 1”

Set “- dm dd_write_enable_objects = 1”

Select “Classes” tab.

Select “Create New Storage Class” from tool bar

Class Name: /service/asp

Label: Test ASP Services

Select “OK”

Change:

Read Access: Global

Write Access: Global

Select “Create New Storage Class” from tool bar

Class Name: /event/activity/exchange

Label: MS Exchange Log Event

Select “OK”

Change

Read Access: Global

Write Access: Global

Select “Tools->Options”

Allow Commits: Yes

Select “File->Save”


Filename: EventActivityExchange.psc

Then “File->Commit Class”

Add event and service entries to files and load:

Copy “\Infranet\sys\data\pricing\example\pin_event_map” to

pin_event_map_exchange

Edit and Add the following to end of file:


# Added for MS Exchange ASP Demo

/service/asp
: /event/activity/exchange

: Exchange ASP Event

Copy “/Infranet\sys\data\pricing\example\pin_beid” to “pin_beid_exchange”

Edit and Add the following line to end of file:

1000500 0  0  0.000000  0.000000  0.000000    EXM   Exm   Exchange Mail Counter 

Load files:

Load_event_map   -dv  pin_event_map_exchange

Load_pin_beid   -dv  pin_beid_exchange

Create Price Plans
Product

Use the “Infranet->Pricing Tool” to Products.

For this study, five products were created.

Exchange ASP Monthly Fee ($50) Product

· Create a new product

· Product Name: Exchange ASP Monthly Fee ($50) Product

· Subscription

· Applies to: /service/asp

· Event Type: Monthly Cycle forward Event(Add)

· RUM Name: Occurrence

· Edit…

· Rate Plan Properties->Name: cycle_forward_monthly

· Rate Tiers->New->Tier Name: Exchange ASP Monthly Fee

· Rate Tier Duration->Always Applies

· Rate Data->Rate Name: Exchange ASP Monthly Fee

· Quantity Discount Brackets->Add

· Balance Impacts->Add

· Resource ID: US Dollar

· Scaled Amount: 50.00

Exchange ASP Setup Fee ($20) Product

· Create a new product

· Product Name: Exchange ASP Setup Fee ($20) Product

· Subscription

· Applies to: /service/asp

· Event Type: Product Purchase Fee Event (Add)

· RUM Name: Occurrence

· Edit…

· Rate Plan Properties->Name: Purchase

· Rate Tiers->New->Tier Name: Exchange ASP Setup Fee

· Rate Tier Duration->Always Applies

· Rate Data->Rate Name: Exchange ASP Setup Fee

· Quantity Discount Brackets->Add

· Balance Impacts->Add

· Resource ID: US Dollar

· GLID: Purchase Fee

· Fixed Amount: 20.00

Exchange ASP Accumulated Usage Product

· Create a new product

· Product Name: Exchange ASP Accumulated Usage Product

· Subscription

· Applies to: /service/asp

· Event Type: Exchange ASP Event (Add)

· RUM Name: Occurrence

· Edit…

· Rate Plan Properties->Name: Exchange ASP Accumulated Usage

· Rate Tiers->New->Tier Name: Exchange ASP Accumulated Usage Product

· Rate Tier Duration->Always Applies

· Rate Data->Rate Name: Exchange ASP Accumulated Usage Product 

· Quantity Discount Brackets->Add

· Balance Impacts->Add

· Resource ID: Exchange Mail

· Fixed Amount: 1.00

Exchange ASP Accumulated Tiers Product

· Create a new product

· Product Name: Exchange ASP Accumulated Tiers Product

· Subscription

· Applies to: /service/asp

· Event Type: Cycle Fold Event (Add)

· Edit…

i. Plan Selector Name: Exchange ASP Accumulated Tiers

ii. PIN_FLD_FOLD.PIN_FLD_RESOURCE: Exchange Mail Counter [1000500]

iii. Rate Plan: Exchange ASP Accumulated Tiers

iv. Impact Category: default

v. Edit Plans…

vi. Exchange ASP Accumulated Tiers

vii. Rate Tiers->New->Tier Name: Exchange ASP Accumulated Tiers

viii. Rate Tier Duration->Always Applies

ix. Rate Data->Rate Name: Exchange ASP Accumulated Tiers

x. Based on: Resource Balance / Exchange Mail Counter

xi. Quantity Discount Brackets->Add

xii. Maximum: 101.00

xiii. Balance Impacts->Add

xiv. Resource ID: US Dollar

xv. Scaled Amount: .10

xvi. Balance Impacts->Add

xvii. Resource ID: Exchange Mail

xviii. Scaled Amount: 1.00

xix. Press: OK

xx. Quantity Discount Brackets->Add

xxi. Minimum: 101.00

xxii. Maximum: 1001.00

xxiii. Balance Impacts->Add

xxiv. Resource ID: US Dollar

xxv. Fixed Amount: .08

xxvi. Resource ID: Exchange Mail

xxvii. Scaled Amount: 1

xxviii. Balance Impacts->Add

xxix. Resource ID: US Dollar

xxx. Fixed Amount: .05

xxxi. Resource ID: Exchange Mail

xxxii. Scaled Amount: 1

Exchange ASP 1000/50 Product

· Create a new product

· Product Name: Exchange ASP 1000/50 Product

· Subscription

· Applies to: /service/asp

· Event Type: Cycle Fold Event (Add)

i. Plan Selector Name: Exchange ASP 1000/50

ii. PIN_FLD_FOLD.PIN_FLD_RESOURCE: Exchange Mail Counter [1000500]

iii. Rate Plan: Exchange ASP 1000/50

iv. Impact Category: default

v. Edit Plans…

vi. Exchange ASP 1000/50

vii. Rate Tiers->New->Tier Name: Exchange ASP 1000/50

viii. Rate Tier Duration->Always Applies

ix. Rate Data->Rate Name: Exchange ASP 1000/50

x. Based on: Resource Balance / Exchange Mail Counter

xi. Quantity Discount Brackets->Add

xii. Balance Impacts->Add

xiii. Maximum: 1.00

xiv. Resource ID: US Dollar

xv. Fixed Amount: 50.00

xvi. Resource ID: Exchange Mail

xvii. Scaled Amount: 1

xviii. Press: OK

xix. Quantity Discount Brackets->Add

xx. Balance Impacts->Add

xxi. Minimum: 1.00

xxii. Resource ID: US Dollar

xxiii. Fixed Amount: 50.00

xxiv. Scaled Amount: .03

xxv. Resource ID: Exchange Mail

xxvi. Scaled Amount: 1

xxvii. Press: OK 

· Event Type: Monthly Cycle Forward Event (Add)

i. RUM Name: Occurrence

ii. Edit…

iii. Rate Plan Properties->Name: cycle_forward_monthly

iv. Rate Tiers->New->Tier Name: 1000 Free Emails

v. Rate Tier Duration->Always Applies

vi. Rate Data->Rate Name: 1000 Free Emails

vii. Quantity Discount Brackets->Add

viii. Balance Impacts->Add

ix. Resource ID: Exchange Mail

x. Fixed Amount: 1,000

Deals

Use the “Infranet->Pricing Tool” to Deals.

For this study, three deals were created:

Exchange ASP Flat Monthly Fee ($50) Deal

· Create New Deal from tool bar

· Name: Exchange ASP Flat Monthly Fee ($50) Deal

· Applies To: /service/asp

· Products: Exchange ASP $50 Monthly Fee

· Quantity: 1

· Products: Exchange ASP Setup Fee

· Quantity: 1

Exchange ASP Accumulated Tiered Usage Deal

· Create New Deal 

· Name: Exchange ASP Accumulated Tiered Usage Deal

· Applies To: /service/asp

· Products: Exchange ASP Accumulated Usage 

· Quantity: 1

· Products: Exchange ASP Accumulated Tiers

· Quantity: 1

· Products: Exchange ASP Setup Fee

· Quantity: 1

Exchange ASP 1000/50 Deal

· Create New Deal

· Name: Exchange ASP 1000/50 Deal

· Applies To: /service/asp

· Products: Exchange ASP 1000/50

· Quantity: 1

· Products: Exchange ASP Accumulated Usage

· Quantity: 1

· Products: Exchange ASP Setup Fee

· Quantity: 1

Plans

Use the “Infranet->Pricing Tool” to Plans.

Exchange ASP Flat Monthly Fee ($50) Plan

· Create New Plan

· Name: Exchange ASP Flat Monthly Fee ($50) Plan

· Service Type: /service/asp

· Deal: Exchange ASP Flat Monthly Fee

Exchange ASP Accumulated Tiered Usage Plan

· Create New Plan

· Name: Exchange ASP Accumulated Tiered Usage Plan

· Service Type: /service/asp

· Deal: Exchange ASP Accumulated Tiered Usage

Exchange ASP 1000/50 Plan

· Create New Plan

· Name: Exchange ASP 1000/50 Plan

· Service Type: /service/asp

· Deal: Exchange ASP 1000/50

Plan List

Use the “Infranet->Pricing Tool” to Products, Deals, Plans, and Plan List.

· Create Plan List

· Name: Exchange ASP

· Selected Plans: Exchange ASP * (all)

Configuring Universal Event Mapper

Open the “Universal Event Loader”.

Sign on:


Username: root.0.0.0.1


Password: password


Hostname: <hostname>


Port connection: 11960

From the “Template” window

Select “New”

Open your log file

From the “Create a New Template” window

Select “File Format” tab


Template Name: <template name>


Description: <my template>

NOTE: Perl scripts were used to remove unnecessary information from log files.

Select “Event Properties” tab


Select “/event/activity/exchange”


Event Load Options



Order by: None (improves load performance)



Group by: None

Select “Event Load Opcode” tab


Select “Other”



Enter “PCM_OP_ACT_USAGE”



Number “163”


“/event Fields and Input Flist



Select PIN_FLD_EVENT click “Add”



Click on “PIN_FLD_EVENT” under mapped fields



Now add “PIN_FLD_LOGIN” and “PIN_FLD_UNRATED_QUANTITY”



It should look like the following




PIN_FLD_EVENT




|- PIN_FLD_LOGIN




|- PIN_FLD_UNRATED_QUANTITY



Select “PIN_FLD_LOGIN”




Next click on the area next to it under columns




Add the column corresponding to the entry



Select “PIN_FLD_UNRATED_QUANTITY”




Next click on the area next to it under columns




Add the column corresponding to the entry

Select “Account ID” tab


Select “/service/asp” Login “A” under “PCM_OP_ACT_FIND”

Select “Apply” to save and the “Ok” to exit.

Using the Administrator Tool to create users

Open “Infranet Administrator”

Select “New Account”

Select <package name> then “OK”

Select “Next”

Enter data for required fields:


NAME:


First: Test

Middle: packageA

Last: LoginID

Address: 123 Street

City: RR

State: TX

Zip: 99999

Select “Next” twice

Select “Invoice”

Select “Next” twice

Service Name: LoginID

Password: LoginID

Using Universal Event Loader

Change to the “\Infranet\apps\uel” directory.

Customize “Infranet.properties” file for your configuration.

Note: Dell recommends changing the directories to point to valid NT directories.

Change “localhost” to be your systems hostname.

Load the log file using the UEL

· uel –t <template_name> <log_file_name>

Verify that the data was loaded into Infranet
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